The user should be prompted to install language packs needed for their selected language(s) which are not currently installed

Bug #1525281 reported by Wise Melon on 2015-12-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Undecided
Unassigned
gnome-control-center (Ubuntu)
Undecided
Unassigned

Bug Description

When I installed Ubuntu GNOME 15.10 with GNOME 3.18 I selected "English (UK)" as my language. However when I then installed other programs such as GIMP and LibreOffice, and used Firefox I found that language for spell checkers etc was "English (US)", and this would be because the default is that and the correct language packs for all these programs have not been installed.

I have found that the only way to install all the needed language packs is to install the language-selector-gnome. Because when started it will say "Some translations or writing aids available for your chosen languages are not installed yet. Do you want to install them now?" and give you the option to install them, however when starting the gnome-control-center and going to the "Region & Language" section there is no such prompt, and in fact no way to install additional language packs for the chosen language.

And as the language-selector-gnome does actually break some stuff and is a Unity thing, one should need to install it on GNOME, there should be an easy way of doing it through the built-in tools made available to the user.

summary: - Necessary language packs are not installed for language which is set in
- the installer but not installed after that matter
+ It should be checked which language packs need to be installed but
+ aren't already installed, and then the user should be prompted to do so
summary: - It should be checked which language packs need to be installed but
- aren't already installed, and then the user should be prompted to do so
+ The user should be prompted to install language packs needed for their
+ selected language(s) which are not currently installed

I have also filed a report on this issue upstream: https://bugzilla.gnome.org/show_bug.cgi?id=763637

description: updated
tags: added: wily xenial
Tim Lunn (darkxst) wrote :

This is not an upstream bug, they don't have language pack support.

It should however be easy enough to hook up the language pack code to run a check on first visit to region panel.

Changed in ubuntu-gnome:
milestone: none → xenial

Ok, I have closed the upstream bug and will remove it from this report then.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.18.2-1ubuntu6

---------------
gnome-control-center (1:3.18.2-1ubuntu6) xenial; urgency=medium

  * debian/patches:
    - ubuntu-region-packagekit.patch:
       fix detection of installed language packs (LP: #1556684)
       fix typo, thanks Nikita (LP: #1556693)
       fix crash on 32-bit systems
    - 52_region_language.patch:
       improve debug message
       fix locale warning
    - ubuntu-region-langpack-install.patch:
       check for missing language packs when loading region panel, this will
       pull in packs that arent included with the installer (LP: #1525281)

 -- Tim Lunn <email address hidden> Sun, 20 Mar 2016 15:26:18 +1100

Changed in gnome-control-center (Ubuntu):
status: New → Fix Released
Tim Lunn (darkxst) on 2016-03-21
Changed in ubuntu-gnome:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers