[Ffe] Support installing Language packs from gnome-control-center

Bug #1479907 reported by Wise Melon on 2015-07-30
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Wishlist
Unassigned
gnome-control-center (Ubuntu)
Undecided
Unassigned
gnome-desktop3 (Ubuntu)
Undecided
Unassigned

Bug Description

Since we don't ship language-selector-gnome in Ubuntu GNOME there is currently no way for users to install language packs. Currently they would only be installed when doing a non-English install, after installation the only way is for the user to install language-selector.

We want to allow for users to be able to install language packs via the gnome-control-center region panel. I had a set of patches from 3.6/3.8 era that implemented this, and got quite a bit of testing, but sat and bit-rot until now. The packagekit code, which is the bulk of the changes was well tested back then.

Basically there are two patches to gnome-control-center:
1. provides an API for installing language packs using packagekit what provides and the 'Modify' dbus helpers.
2. Integrates this into the UI, I've hi-jacked the "More Languages" dialog this time, which provides much simpler integration than the previous approach, technically that breaks UI Freeze, but currently it's completely disabled, so shouldn't be a problem documentation wise, not that we have any documentation really.

gnome-desktop requires a simple one liner patch, that changes the format of the locale code strings sent to g-c-c, I suppose this could be considered breaking API, but that API was added specifically for this feature and has been unused the last few cycles.

Changes are staged on: ppa:ubuntu-gnome-packaging/staging

Tim Lunn (darkxst) wrote :

We don't install language selector since it causes a duplicate language panel in gnome-control-center, and we prefer to use the upstream GNOME panel.

There is however a work in progress to add support for installing language packs directly from gnome-control-center region panel. That should land in 15.10, however is unlikely to include support for uninstalling language packs.

Changed in ubuntu-gnome:
importance: Undecided → Wishlist
milestone: none → wily
status: New → Confirmed
Tim Lunn (darkxst) on 2015-08-09
summary: - Have gnome-language-selector installed by default
+ Support installing Language packs from gnome-control-center
Tim Lunn (darkxst) on 2015-09-11
summary: - Support installing Language packs from gnome-control-center
+ [Ffe] Support installing Language packs from gnome-control-center
Tim Lunn (darkxst) on 2015-09-11
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-desktop3 (Ubuntu):
status: New → Confirmed
Tim Lunn (darkxst) on 2015-09-11
affects: gnome-desktop (Ubuntu) → gnome-desktop3 (Ubuntu)
description: updated
Iain Lane (laney) wrote :

When was this API added to gnome-desktop?

Fine if this really isn't used by anything still.

Changed in gnome-desktop3 (Ubuntu):
status: New → Triaged
Changed in gnome-control-center (Ubuntu):
status: New → Triaged
Tim Lunn (darkxst) wrote :

It was added in the cycle that u-s-d/u-c-c were forked, then the ui patches got broken by gtk 3.8 transition from egglist box to Gtk list box, and were left to rot... its nots used by any of the unity stack and I can't imagine why anyone else would want to use it.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-desktop3 - 3.16.2-2ubuntu2

---------------
gnome-desktop3 (3.16.2-2ubuntu2) wily; urgency=medium

  * debian/patches/ubuntu_language_list_from_SUPPORTED.patch: don't
    strip the territory code from languages returned by
    gnome_get_all_languages() (LP: #1479907)

 -- Tim Lunn <email address hidden> Fri, 11 Sep 2015 15:10:16 +1000

Changed in gnome-desktop3 (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.16.2-2ubuntu3

---------------
gnome-control-center (1:3.16.2-2ubuntu3) wily; urgency=medium

  * Add support for installing language packs from the region panel
    - d/p/ubuntu-region-packagekit.patch,
      ubuntu-region-langpack-install.patch (LP: #1479907)
  * debian/control.in: fix lintian warning
  * debian/git_datetime_missing_timezone.patch: Drop symlinks from patch
  * debian/rules, tz-images/, include-binaries: Install the updated map images
    into build tree, backported from 3.18

 -- Tim Lunn <email address hidden> Fri, 11 Sep 2015 15:14:28 +1000

Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Released
Tim Lunn (darkxst) on 2015-09-15
Changed in ubuntu-gnome:
status: Confirmed → Fix Released

I am running Ubuntu GNOME 15.10 with GNOME 3.18, and I am seeing no sign of this...

Tim Lunn (darkxst) wrote :

Nikita, It is there, but the UI is quite succinct, but based very closely on the upstream design.

Goto the Region & Language panel, click Language. The first list of languages shown are the installed ones, click the "more" item (the three dot icon), you get an "Install Language", Select a language from this and you will get a popup to install the language packs.

There is one caveat and that is that if dpkg/apt are locked, because you have for example synaptic or similar open, then the code just times out, the initial implementation that landed in 15.10 can't detect this case, however we are looking to make a few improvements to this feature during the 16.04 cycle.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers