Illegible dark blue text on grey background

Bug #1404028 reported by Bruce Pieterse on 2014-12-18
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
High
Unassigned
ubuntu-gnome-default-settings (Ubuntu)
High
Unassigned

Bug Description

With text-based plymouth the dark blue text is illegible / hard to read with something like LVM setup with an encrypted disk. I would like to propose a lighter color instead that complements the grey background.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: plymouth 0.9.0-0ubuntu8
ProcVersionSignature: Ubuntu 3.16.0-28.38-generic 3.16.7-ckt1
Uname: Linux 3.16.0-28-generic x86_64
ApportVersion: 2.15-0ubuntu3
Architecture: amd64
CurrentDesktop: GNOME
Date: Thu Dec 18 23:41:35 2014
DefaultPlymouth: /lib/plymouth/themes/ubuntu-gnome-logo/ubuntu-gnome-logo.plymouth
InstallationDate: Installed on 2014-12-18 (0 days ago)
InstallationMedia: Ubuntu-GNOME 15.04 "Vivid Vervet" - Alpha amd64 (20141218)
Lsusb:
 Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: innotek GmbH VirtualBox
ProcCmdLine: BOOT_IMAGE=/vmlinuz-3.16.0-28-generic root=/dev/mapper/ubuntu--gnome--vg-root ro quiet splash
ProcFB:

ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.16.0-28-generic root=/dev/mapper/ubuntu--gnome--vg-root ro quiet splash
SourcePackage: plymouth
TextPlymouth: /lib/plymouth/themes/ubuntu-gnome-text/ubuntu-gnome-text.plymouth
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.board.name: VirtualBox
dmi.board.vendor: Oracle Corporation
dmi.board.version: 1.2
dmi.chassis.type: 1
dmi.chassis.vendor: Oracle Corporation
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH

Bruce Pieterse (octoquad) wrote :
Bruce Pieterse (octoquad) wrote :

Only affects Ubuntu Gnome

affects: plymouth (Ubuntu) → ubuntu-gnome
Changed in ubuntu-gnome:
status: New → Confirmed
milestone: none → vivid
Bruce Pieterse (octoquad) wrote :

Above "Unlocking the disk...". Perhaps the text should be the same color as "Unlocking the disk text" or slightly lighter.

Alfredo Hernández (aldomann) wrote :

Thanks for reporting this. We should fix it for Vivid. This is one of the things I wasn't able to test when theming the Playmouth theme.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-gnome-default-settings (Ubuntu):
status: New → Confirmed
Changed in ubuntu-gnome-default-settings (Ubuntu):
importance: Undecided → High
Alfredo Hernández (aldomann) wrote :

I think I've found the problem in the code. Any way, reading the code, I've realised that maybe we are using the colours wrongly. The bright colour (referred as blue in the code) should be actually the brightest and the dark colour (referred as brown in the code) should show the operations.

In the attachment, the top image is how Plymouth would look if we fixed the dark colour, and the bottom image is how it would look if we also fixed the hierarchy of the colours.

Is the dark (aka brown) colour clear enough or should the colour be more prominent to improve reading?

Bruce Pieterse (octoquad) wrote :

Thanks Alfredo.

In the screenshot provided in comment #3 the really dark text is shown if you put in a incorrect password (above "Unlocking disk ..."). That is probably the most illegible text to read. I prefer the bottom one, but could you also test the incorrect password text as well and see if that is fixed with the bottom suggestion you provided?

Unfortunately I don't see brown any where, however I do recall seeing a brownish orange text when services are shutting down.

Bruce Pieterse (octoquad) wrote :

So this is still pretty hard to read. Another way of testing is to use "Check disc for defects" with a Live CD/USB.

Changed in ubuntu-gnome:
status: Confirmed → Triaged
importance: Undecided → Medium
milestone: vivid → xx
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1404028

tags: added: iso-testing
Adolfo Jayme (fitojb) on 2015-11-28
Changed in ubuntu-gnome-default-settings (Ubuntu):
status: Confirmed → Triaged
tags: added: xenial
removed: vivid
Changed in ubuntu-gnome:
importance: Medium → High
Changed in ubuntu-gnome:
milestone: xenial → yy
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers