[MRE] Update to tracker 1.0.6

Bug #1391102 reported by Tim Lunn on 2014-11-10
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Undecided
Unassigned
tracker (Ubuntu)
Undecided
Unassigned
Utopic
Undecided
Unassigned

Bug Description

[Release Notes ]
NEW in 1.0.5 - 2014-09-02
=========================

  * Fixes: GB#738522, libtracker-data: Guard against failure to create a FTS update statement
  * Fixes: GB#738450, libtracker-data: Guard against failure to open the database
  * Fixes: GB#737769, fs: Keep TrackerCrawler alive across async calls
  * Fixes: GB#737768, fs: TrackerCrawler can crash due to invalid container pointers
  * Fixes: GB#737023, tracker-bus: tracker_sparql_connection_query_async can crash if cancelled

Translations:

  * Updated sk: Dušan Kazik
  * Updated sl: Matej Urbančič

==
1.0.6 contains one further fix for bug https://bugzilla.gnome.org/show_bug.cgi?id=739237

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: tracker 1.2.3-0ubuntu1~utopic1 [origin: LP-PPA-gnome3-team-gnome3-staging]
ProcVersionSignature: Ubuntu 3.16.0-24.32-generic 3.16.4
Uname: Linux 3.16.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.7-0ubuntu10
Architecture: amd64
CurrentDesktop: GNOME
Date: Mon Nov 10 21:13:15 2014
InstallationDate: Installed on 2012-09-23 (778 days ago)
InstallationMedia: Ubuntu GNOME Remix 12.10 "Quantal Quetzal" - Alpha amd64(20120922)
SourcePackage: tracker
UpgradeStatus: No upgrade log present (probably fresh install)

Tim Lunn (darkxst) wrote :
Martyn Russell (martyn-lanedo) wrote :

Please can we push this, the crashes that are fixed are being witnessed for me every time I start my desktop daily. This release fixes that crash!

Steve Langasek (vorlon) wrote :

The title of this bug is 'MRE', but it's not obvious to me how this is covered by the existing micro-release exceptions. tracker is a core dependency of GNOME, but its versioning doesn't appear to correspond to GNOME upstream versioning. Can someone please explain here how tracker 1.0.6 fits the existing GNOME MRE?

Also, this bug has not been marked as fixed for the devel version of Ubuntu. vivid has a newer version than utopic - are all of the bugfixes from tracker 1.0.6 also included in 1.2.4?

Tim Lunn (darkxst) wrote :

Steve, not all GNOME components follow the 3.x versioning (glib, gobject-introspection and clutter are just a few examples) , but given its a core component of GNOME it should be covered by MRE, and it is contained in the official release notes: ftp://ftp.gnome.org/pub/gnome/core/3.14/3.14.2/NEWS

All the bugfixes in 1.0.6 are cherry-picked from 1.2.4 branch, so yes they are already in vivid.

Tim Lunn (darkxst) wrote :

also tracker is part of gnome-suites-core-deps moduleset, as mentioned on the MRE page.....

Hello Tim, or anyone else affected,

Accepted tracker into utopic-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/tracker/1.0.6-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in tracker (Ubuntu Utopic):
status: New → Fix Committed
tags: added: verification-needed
Bruce Pieterse (octoquad) wrote :

Been working fine for the last two days.

tracker:
  Installed: 1.0.6-0ubuntu1
  Candidate: 1.0.6-0ubuntu1
  Version table:
 *** 1.0.6-0ubuntu1 0
        500 http://za.archive.ubuntu.com/ubuntu/ utopic-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     1.0.4-0ubuntu2 0
        500 http://za.archive.ubuntu.com/ubuntu/ utopic/main amd64 Packages

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for tracker has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in tracker (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tracker - 1.0.6-0ubuntu1

---------------
tracker (1.0.6-0ubuntu1) utopic; urgency=medium

  * New upstream bugfix release (LP: #1391102)
 -- Tim Lunn <email address hidden> Mon, 10 Nov 2014 21:17:36 +1100

Changed in tracker (Ubuntu Utopic):
status: Fix Committed → Fix Released
Changed in ubuntu-gnome:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers