gnome-shell crashed with SIGSEGV in clutter_x11_handle_event()

Bug #1278073 reported by Richard Ayotte on 2014-02-09
78
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Undecided
Unassigned

Bug Description

Gnome Shell crashed. Nothing particularly interesting was happening.

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: gnome-shell 3.10.2.1-0ubuntu1~saucy1 [origin: LP-PPA-gnome3-team-gnome3]
ProcVersionSignature: Ubuntu 3.11.0-17.30-generic 3.11.10.3
Uname: Linux 3.11.0-17-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
Date: Sun Feb 9 07:45:25 2014
DisplayManager: gdm
ExecutablePath: /usr/bin/gnome-shell
GsettingsChanges:
 b'org.gnome.desktop.interface' b'clock-show-date' b'true'
 b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
 b'org.gnome.desktop.interface' b'gtk-theme' b"'Adwaita'"
 b'org.gnome.desktop.interface' b'icon-theme' b"'Faience'"
 b'org.gnome.desktop.interface' b'monospace-font-name' b"'Andale Mono 11'"
InstallationDate: Installed on 2011-02-26 (1079 days ago)
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007.1)
MarkForUpload: True
ProcCmdline: /usr/bin/gnome-shell
SegvAnalysis:
 Segfault happened at: 0x7f962c574be0: mov 0xe0(%rdi),%rax
 PC (0x7f962c574be0) ok
 source "0xe0(%rdi)" (0x000000e0) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-shell
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libclutter-1.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libclutter-1.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libclutter-1.0.so.0
 clutter_x11_handle_event () from /usr/lib/x86_64-linux-gnu/libclutter-1.0.so.0
 _meta_plugin_xevent_filter () from /usr/lib/libmutter.so.0
Title: gnome-shell crashed with SIGSEGV in clutter_x11_handle_event()
UpgradeStatus: Upgraded to saucy on 2013-10-05 (126 days ago)
UserGroups: adm admin cdrom dialout libvirtd lpadmin mythtv plugdev root sambashare vboxusers

Richard Ayotte (rich-ayotte) wrote :
information type: Private → Public
Ubuntu GNOME (ug-bot) wrote :

StacktraceTop:
 clutter_grid_layout_set_column_spacing (layout=0x14949520, spacing=0) at ./clutter-grid-layout.c:2048
 ?? ()
 ?? () from /home/darkxst/gnome3-amd64/usr/lib/x86_64-linux-gnu/libcogl.so.12
 ?? ()
 ?? ()

Changed in ubuntu-gnome:
status: New → Invalid
Download full text (3.3 KiB)

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

libgnome-menu-3-0 version 3.8.0-1ubuntu6~saucy1 required, but 3.8.1-0ubuntu2~saucy1 is available
libglapi-mesa version 10.2.0~git20140205.44338cd8-0ubuntu0sarvatt~saucy required, but 10.2.0~git20140210.a21552a9-0ubuntu0sarvatt~saucy is available
libebackend-1.2-7 version 3.10.3-0ubuntu1~saucy1 required, but 3.10.4-0ubuntu1~saucy1 is available
gnome-themes-standard-data version 3.10.0-0ubuntu1~saucy1 required, but 3.10.0-1ubuntu1~saucy1 is available
gnome-accessibility-themes version 3.10.0-0ubuntu1~saucy1 required, but 3.10.0-1ubuntu1~saucy1 is available
libgoa-backend-1.0-1 version 3.10.0-2ubuntu1~saucy1 required, but 3.10.2-1~saucy1 is available
libgdm1 version 3.10.0.1-0ubuntu1~saucy4 required, but 3.10.0.1-0ubuntu2~saucy1 is available
libgoa-1.0-0b version 3.10.0-2ubuntu1~saucy1 required, but 3.10.2-1~saucy1 is available
libecal-1.2-16 version 3.10.3-0ubuntu1~saucy1 required, but 3.10.4-0ubuntu1~saucy1 is available
evolution-data-server version 3.10.3-0ubuntu1~saucy1 required, but 3.10.4-0ubuntu1~saucy1 is available
nautilus-data version 1:3.10.1-0ubuntu2+saucy1 required, but 1:3.10.1-0ubuntu4+saucy1 is available
gnome-themes-standard version 3.10.0-0ubuntu1~saucy1 required, but 3.10.0-1ubuntu1~saucy1 is available
libgl1-mesa-glx version 10.2.0~git20140205.44338cd8-0ubuntu0sarvatt~saucy required, but 10.2.0~git20140210.a21552a9-0ubuntu0sarvatt~saucy is available
libgl1-mesa-dri version 10.2.0~git20140205.44338cd8-0ubuntu0sarvatt~saucy required, but 10.2.0~git20140210.a21552a9-0ubuntu0sarvatt~saucy is available
libedataserver-1.2-18 version 3.10.3-0ubuntu1~saucy1 required, but 3.10.4-0ubuntu1~saucy1 is available
libedata-book-1.2-20 version 3.10.3-0ubuntu1~saucy1 required, but 3.10.4-0ubuntu1~saucy1 is available
evolution-data-server-common version 3.10.3-0ubuntu1~saucy1 required, but 3.10.4-0ubuntu1~saucy1 is available
libedata-cal-1.2-23 version 3.10.3-0ubuntu1~saucy1 required, but 3.10.4-0ubuntu1~saucy1 is available
gnome-menus version 3.8.0-1ubuntu6~saucy1 required, but 3.8.1-0ubuntu2~saucy1 is available
gir1.2-gdm-1.0 version 3.10.0.1-0ubuntu1~saucy4 required, but 3.10.0.1-0ubuntu2~saucy1 is available
libgoa-1.0-common version 3.10.0-2ubuntu1~saucy1 required, but 3.10.2-1~saucy1 is available
libegl1-mesa version 10.2.0~git20140205.44338cd8-0ubuntu0sarvatt~saucy required, but 10.2.0~git20140210.a21552a9-0ubuntu0sarvatt~saucy is available
libebook-contacts-1.2-0 version 3.10.3-0ubuntu1~saucy1 required, but 3.10.4-0ubuntu1~saucy1 is available
gir1.2-gmenu-3.0 version 3.8.0-1ubuntu6~saucy1 required, but 3.8.1-0ubuntu2~saucy1 is available
libcamel-1.2-45 version 3.10.3-0ubuntu1~saucy1 required, but 3.10.4-0ubuntu1~saucy1 is available
libgbm1 version 10.2.0~git20140205.44338cd8-0ubuntu0sarvatt~saucy required, but 10.2.0~git20140210.a21552a9-0ubuntu0sarvatt~saucy is available
libebook-1.2-14 version 3.10.3-0ubuntu1~saucy1 required, but 3.10.4-0ubuntu1~saucy1 is avai...

Read more...

tags: removed: need-amd64-retrace
François Cauwe (fcauwe) on 2014-12-15
Changed in ubuntu-gnome:
status: Invalid → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers