14.04 New GNOME in KVM video issues

Bug #1273276 reported by Doug Smythies on 2014-01-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Undecided
Unassigned

Bug Description

I work on the official Ubuntu Documentation, and run a 14.04 Ubuntu Desktop as a VM on my Ubuntu 12.04 server. I need to go back and forth between Unity Desktop environment and GNOME desktop environment. About a week ago, and synchronous with some GNOME updates, the GNOME desktop environment has issues. The screen is the wrong size, and an app window is clipped and not movable. Unity Desktop environment works fine (well mostly, there seemed to a regression for a day where nothing worked, similar to a few weeks ago, but that seems to be O.K. now).

Note that I use the vmvga driver, because and at least for me the cirrus driver does not work properly. As far as I could determine past issues with the vmvga driver have been fixed.

The GNOME desktop environment doesn't seem to realize the video display resolution settings. There are also entries in /var/log/libvirt/qemu/desk_ss.log, such as:

vmsvga_update_rect: update width too large x: 100, w: 846

Such entries are not present when logging on with Unity Desktop environment.

My system was using vgabios 0.6c-2ubuntu3, but I have now upgraded to 0.7a-3ubuntu3.
I have also tried kernel 3.13

My 12.04 server is headless, I only use VNC for the GUI Desktop screen, and ssh for a cli terminal.

Typically, I am trying to use a 1680X1050 display resolution on my VM as that fits nicely inside my client desktop of 1920X1200. However, even I set the display to 800X600, which is what the GNOME desktop environment always uses, the app windows are still clipped and unmovable (I can set the video by logging on to the Unity desktop environment.)

If I switch to the cirrus driver, then the new GNOME does work, but the video display is terrible and only minimal resolution is available (for both Unity and GNOME Desktops).

I had another VM desktop, that was a GOME only installation, that had not been used since November 17th. I upgraded it also, and have the same results/issues after the upgrade.

I'll post some screen shots and log files.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1273276

tags: added: iso-testing
Doug Smythies (dsmythies) wrote :

I have now done 2 64 bit upgrades, one 32 bit upgrade, and one new installation from the trusty daily ISO, all with the same results. I have now also installed a new 13.10 gnome desktop VM as a reference, and it is working fine.

I am reasonably certain that this bug report is currently misfiled, and am still trying to determine the correct project or package to file it under. Perhaps gnome-settings-daemon.

affects: xserver-xorg-driver-vesa → gnome-settings-daemon
no longer affects: gnome-settings-daemon
Doug Smythies (dsmythies) wrote :

I was able to get some help and direction from darkxst (Tim) on the #ubuntu-gnome IRC channel.

It seems that there is an incompatibility between some of the gnome stuff that was updated a couple of weeks ago, and some stuff that was not. When I upgraded using Tim's ppa ( https://launchpad.net/~darkxst/+archive/gnome310 ), then everything was fine.

So, and for the main VM that I actually want to use, I will just have to wait for the upgrades that will sync up everything. Meanwhile, I should be able to use "xrandr -s 1680x1050' (that Tim suggested) to set the display size to something useful.

Doug Smythies (dsmythies) wrote :

Just an up date: I have been updating my VM every day, but this issue persists.

Doug Smythies (dsmythies) wrote :

Another update: I continue to update my main VM every day, and this issue persists, but now Unity shell on that same VM does not work, and hasn't since 2014.02.17 ( bug 1284536 and bug 1282342 ).

Now my other GNOME only type VM's don't work all. They just give a black screen and/or terminate.
I did a fresh install from the daily 64 bit GNOME ISO of today (2014.02.26) and it doesn't work at all.
I can make it work by switching from the vmvga driver to the cirrus driver, but the cirrus driver has other issues.

I used this command to create the VM:

sudo virt-install -n desk_gnome_tt -r 8192 --disk path=/media/newhd/desk_gnome_tt.img,bus=virtio,size=50 -c trusty-gnome-20140226-amd64.iso --network bridge=br0,model=virtio,mac=52:54:00:a6:7a:8f --video=vmvga --graphics vnc,listen=0.0.0.0 --noautoconsole -v --vcpus=4

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions