network-manager dont use manual configured dns as primary

Bug #1256487 reported by Kaare Baastrup on 2013-11-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Undecided
Unassigned

Bug Description

When wireless connection is set to use fx. googles dns 8.8.8.8 and 8.8.4.4 its still overrulled by dns received by dhcpclient.

 nm-tool | grep DNS
    DNS: 193.162.153.164
    DNS: 194.239.134.83
    DNS: 8.8.8.8
    DNS: 8.8.4.4

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: network-manager 0.9.8.8-0ubuntu1~saucy1 [origin: LP-PPA-gnome3-team-gnome3-staging]
ProcVersionSignature: Ubuntu 3.11.0-14.21-generic 3.11.7
Uname: Linux 3.11.0-14-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
Date: Sat Nov 30 10:36:20 2013
IfupdownConfig:
 auto lo
 iface lo inet loopback
IpRoute:
 default via 192.168.0.1 dev wlan0 proto static
 192.168.0.0/24 dev wlan0 proto kernel scope link src 192.168.0.31 metric 9
MarkForUpload: True
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.NetworkManager.NetworkManager.conf: 2013-11-30T10:32:21.982233
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 eth0 802-3-ethernet unavailable /org/freedesktop/NetworkManager/Devices/1
 wlan0 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.8.8 connected enabled enabled enabled enabled disabled

Kaare Baastrup (kaare-baastrup) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers