Can't set keyboard layout change to alt+shift, ctrl+shift, etc.

Bug #1218322 reported by Dmitriy "Simplehuman" Fedorov on 2013-08-29
This bug affects 985 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
High
Unassigned
Declined for Stable by Tim
gnome-settings-daemon
Unknown
Unknown
gnome-control-center (ALT Linux)
Unknown
Unknown
gnome-control-center (Baltix)
High
Mantas Kriaučiūnas
gnome-control-center (Gentoo Linux)
Invalid
Medium
gnome-control-center (Mandriva)
Invalid
High
gnome-control-center (Ubuntu)
High
William Hua
Nominated for Trusty by Tim
gnome-settings-daemon (Ubuntu)
High
William Hua
Nominated for Trusty by Tim
Saucy
High
William Hua

Bug Description

[Impact]

Can't set keyboard layout change to Ctrl+Shift, Caps Lock, Alt+Shift, etc. Shift, Caps Lock keys are just ignored in settings.

[Test Case]

- open gnome-control-center's text input settings
- click on the "next layout key" entry
- try entering a combination of two modifier keys such as Ctrl+Shift
-> the UI should reflect the new keys

- add at least two input sources through gnome-control-center's text entry settings
- press and release Ctrl+Shift
-> the current input source should change

[Regression Potential]

That UI was not working before, it should only be an improvement (some key combos are not working as expected, that's another issue and shouldn't be mixed with this one)

The input switching shortcut might capture other non-modifier shortcuts, but users will need to consider this when choosing their switching shortcut anyways. For users this bug affects, this represents a working solution for a critical bug.

--

Test results for different keyboard layout change hotkeys may be viewed and added in the Google Docs table, created by Norbert (https://docs.google.com/spreadsheet/ccc?key=0Ao5e713Ig9g_dEJrX2NRYlpLWWVzSWxsVXU4ck9HYVE&usp=sharing).

You can use the tag keyboard-layout-switching-hotkeys to find related bugs.
https://bugs.launchpad.net/ubuntu/+bugs?field.tag=keyboard-layout-switching-hotkeys

For using layout switching hotkeys in Unity Greeter, see bug 1245137.
For using layout switching hotkeys in GNOME lockscreen, see bug 1244548.

--

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: indicator-keyboard 0.0.0+13.10.20130829.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-2.5-generic 3.11.0-rc5
Uname: Linux 3.11.0-2-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.12.1-0ubuntu2
Architecture: amd64
Date: Thu Aug 29 14:21:54 2013
InstallationDate: Installed on 2013-07-31 (28 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130730)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=ru_UA:ru
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=ru_UA.UTF-8
 SHELL=/bin/bash
SourcePackage: indicator-keyboard
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-keyboard (Ubuntu):
status: New → Confirmed
denkin (ks-alexandr) wrote :

confirm this problem, don't work with Alt+Shift too.

Alexander Kubashin (kubashin-a) wrote :

Can't set keyboard switch to Caps Lock (preferred), alt+shift, ctrl+shift etc. Working combination: ctrl+space and 'menu' (both variants uncomfortably for me).

description: updated
suslikk (suslikkreal) wrote :

same bug

2 comments hidden view all 517 comments
Artem Vorotnikov (skybon) wrote :

Does not work with Alt+Shift either. This or very similar bug was reported at GNOME bug tracker.
https://bugzilla.gnome.org/show_bug.cgi?id=681685

Artem Vorotnikov (skybon), it happened right after new indicator-keyboard arrived.

Norbert (nrbrtx) wrote :

I confirm this bug (Regular Ubuntu 13.10).

Igor Zubarev (igor.zubarev) wrote :

Confirm for Saucy Beta Final amd64.

Dmitry Shachnev (mitya57) wrote :

If you set the shortcut via gnome-tweak-tool, layout changing will work (though indicator-keyboard still won't work).

Changed in indicator-keyboard (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Changed in gnome-control-center (Ubuntu):
status: New → Triaged
importance: Undecided → High
robi1h (robi1h) wrote :

Confirmed, doesent work me eather Shift+Tab (Ubuntu 13.10 64bit)

Mike (0x656b694d) wrote :

Setting the shortcut via gnome-tweak-tool has no effect for me.

Anatoly (anatoly-shipov) wrote :

I confirm this bug, too. Affects most ubuntu users from CIS countries who are used to Alt+Shift|Ctrl+Shift layout switching. Any workaround?

loquens (loquens) wrote :

At first for me worked this advise: https://bugs.launchpad.net/ubuntu/+source/indicator-keyboard/+bug/1215826/comments/14#ubuntu

But later it stopped working, and now I am only able to switch layout via modified+symbol key (I use ctrl-space now, but it's not comfortable, as it interferes with app's shortcuts) :(

peerus (tsifra) wrote :

Also had problem with alt-shift combinations set via region and language settings. Solved it by: gnome-tweak-tool -> typing -> key(s) to change layout -> disable

Confirm this bug - the only available combination is Super+Space which cannot be changed. The workaround via gnome-tweak-tool does not work at all.

denkin (ks-alexandr) wrote :

Confirm, still no work, my favorite combination is Ctrl+Shift don't work on a Unity 7 (ubuntu-desktop).

Dmitry Shachnev (mitya57) wrote :

Actually this is maybe an issue in gnome-settings-daemon, which doesn't update org.gnome.desktop.input-sources/current key when shortcuts are pressed.

affects: gnome-control-center (Ubuntu) → gnome-settings-daemon (Ubuntu)
peerus (tsifra) wrote :

Have just checked left ctrl + left shift and it works again. My problem with layout switching was directly related with "key(s) to change layout -> disable". Maybe you should try logout & relogin.

My system: fresh install of ubuntu gnome 13.04 -> upgrade via "update-manager -d" to 13.10 beta.

peerus (tsifra) wrote :

How i've troubleshoot my problem. After upgrade from 13.04 to 13.10 i've noticed that if i press super + space layoyt indicator changes so does input. En-Ru-En.

If i press alt-shift only indicator changes. but If i try to enter text it's still english. after "key(s) to change layout -> disable" alt-shift doen't make sense only super-space works. then i changed super-space to alt-shift in regional and language settings and it works like expected.

Tolchi (sehoon-park) wrote :

most of koreans favorite key combination to change korean-english is shift+space

this combination is no longer avaliable...

peerus (tsifra) wrote :

I feel like another my problem is related somehow with this bug. Please see https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1235586 and leave your comments there if you can reproduce described situation.

NickTh (nick-athens30) wrote :

You can try gnome-tweak-tool.
I can change the keyboard layout from English to Greek with [Alt+Shift] but the icon indicator (up right) remains as is [En].

Jacob Popov (j-a-popov) wrote :

I confirm the bug with the current Saucy.
Using gnome-tweak-tool makes the keyboard switched using XKB, which isn't quite good. Currently Ubuntu relies on iBus, if i'm not mistaken? Therefore the gnome-tweak-tool workaround is not OK, as the indicator doesn't notice any layout changes then.

Which is more, after the yesterday's update I cannot change the layout even with Super+Space any more! No reasonable working hotkey left! So far I'm sticking to Shift+Alt and ignore the indicator.

By the way, why using the indicator which doesn't work?
1) Layout switching in the command-line interface is done ONLY with XKB! We should somehow keep the layout changing hotkeys in XKB similar to the ones used in GUI, shouldn't we?
2) For now, XKB works fine, while the indicator fails. Maybe the indicator should rely on XKB, or at least track the layout change in XKB?

Jacob Popov (j-a-popov) wrote :

peerus, that's quite different bug. Although it's annoying as well, it's reason lurks somewhere else. The patches from that thread seem to do nothing with this bug.

Maxim Kuznetsov (mackuzzz) wrote :

In 13.04 there is ability to change layout while button is pressed. I'm using Caps key. And in 13.10 i can't find any place to make these changes.

Stixy90 (sasha-govrin) wrote :

In 13.04 there is ability to change layout while button is pressed. I'm using Ctrl+Shift key. And in 13.10 i can't find any place to make these changes.

Ivan Kukobko (ivan-kukobko) wrote :

"Text Entry" config recognizes my "Super" (Windows) key as "Mod4+Super+Hyper". Any idea how can I fix it?

VoaNerges (gotham48) wrote :

Hey, guys, can someone run dconf-editor find org -> gnome -> desktop -> input-sources and change xkb-options to ['grp:alt_shift_toggle,grp_led:scroll'] and then switch layout by Alt-Shift? Just to test.

This helped me.

Yup, fixing config in dconf-editor helped for me.
But En/Ru indicator didn't change.

2013/10/11 VoaNerges <email address hidden>

> Hey, guys, can someone run dconf-editor find org -> gnome -> desktop ->
> input-sources and change xkb-options to
> ['grp:alt_shift_toggle,grp_led:scroll'] and then switch layout by Alt-
> Shift? Just to test.
>
> This helped me.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1218322
>
> Title:
> Can't set keyboard layout change to ctrl+shift
>
> Status in “gnome-settings-daemon” package in Ubuntu:
> Triaged
> Status in “indicator-keyboard” package in Ubuntu:
> Triaged
>
> Bug description:
> Can't set keyboard layout change to ctrl+shift, Caps Lock, alt+shift
> etc. "Shift", "CapsLock" keys are just ignored in settings. Also the
> default shortcut was set to "Super+Space" that is inconveniently,
> because Dash is opening when you swich your keyboard layout.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.10
> Package: indicator-keyboard 0.0.0+13.10.20130829.1-0ubuntu1
> ProcVersionSignature: Ubuntu 3.11.0-2.5-generic 3.11.0-rc5
> Uname: Linux 3.11.0-2-generic x86_64
> NonfreeKernelModules: nvidia
> ApportVersion: 2.12.1-0ubuntu2
> Architecture: amd64
> Date: Thu Aug 29 14:21:54 2013
> InstallationDate: Installed on 2013-07-31 (28 days ago)
> InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64
> (20130730)
> MarkForUpload: True
> ProcEnviron:
> LANGUAGE=ru_UA:ru
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=ru_UA.UTF-8
> SHELL=/bin/bash
> SourcePackage: indicator-keyboard
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1218322/+subscriptions
>

I confirm this bug on Ubuntu 13.10, unable to change layout with Ctrl+Shift or Alt+Shift (set in Gnome Control Center -> Keyboard -> Layouts).

loquens (loquens) wrote :

VoaNerges (gotham48), yes, setting toggle key via dconf-editor worked for me, but language icon is not changing upon switch

I've upgraded from previous versions where I had Alt+Shift as the shortcut toggling between English and Hungarian. Now, not being to specify this, I chose Ctrl+Space. The current behavior is:
- If I select English in the indicator or via Ctrl+Space then the layout is English, and Alt+Shift does nothing.
- If I select Hungarian in the indicator or via Ctrl+Space then the layout is initially Hungarian but Alt+Shift toggles between En and Hu, but without updating the indicator.
Total chaos.

In Text Entry Settings, if I press the Windows key plus Space, I get "Mod4+Super+Hyper+Space" displayed -- what the heck??? Mod4 and Hyper, what the hell are those, and why aren't they shown on the Keyboard Layout Chart, and why does the dialog claim I pressed them? And how do I revert to the previous value which was simply Super+Space?

Moreover, Ctrl+Space (my currently specified shortcut) only works if I press Ctrl, press Space, release Space and finally release Ctrl in this order. If I release the two keys in reverse order (which is way more natural for me as my hand quickly rolls over the two keys, rather than stopping and moving backwards) then it doesn't work. Yet again a total usability failure.

This whole thing is a complete disaster :(

Theodore Zahov (tzahov) wrote :

I confirm the bug. Currently trying to make a fresh install of 13.10 latest beta or daily, but both are buggy. "Alt-shift" is gone and even "Super+space" does not work. Instead I get "Mod4+Super+Hyper+space" crazy combination. Extremely annoying and makes the distro unusable for me.

summary: - Can't set keyboard layout change to ctrl+shift
+ Can't set keyboard layout change to ctrl+shift and more
Theodore Zahov (tzahov) on 2013-10-13
summary: - Can't set keyboard layout change to ctrl+shift and more
+ Can't set keyboard layout change to ctrl+shift
Raven (doom-raven) wrote :

I confirm this bug on Ubuntu 13.10 х64

Igor Zubarev (igor.zubarev) wrote :

Still can't set keyboard layout change to ctrl+shift, Caps Lock, alt+shift etc.

suslikk (suslikkreal) wrote :

I'm very sad :(

William Hua (attente) on 2013-10-15
Changed in indicator-keyboard (Ubuntu):
assignee: nobody → William Hua (attente)
Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → William Hua (attente)

Confirmed under Ubuntu Saucy (of today, through the daily iso images).

Shahar Or (mightyiam) on 2013-10-16
summary: - Can't set keyboard layout change to ctrl+shift
+ Can't set keyboard layout change to alt+shift, ctrl+shift, etc.
William Hua (attente) on 2013-10-16
Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → In Progress
Changed in gnome-control-center (Ubuntu):
status: New → In Progress
assignee: nobody → William Hua (attente)
Changed in indicator-keyboard:
status: New → Invalid
Changed in indicator-keyboard (Ubuntu):
status: Triaged → Invalid
Changed in indicator-keyboard:
status: Invalid → Confirmed
assignee: nobody → Alexander Olgin (alexander-a-olgin)
Valery (g-valery) on 2013-10-18
Changed in indicator-keyboard (Ubuntu):
status: Invalid → Confirmed
khadeja (muslimaqq) on 2013-10-18
Changed in indicator-keyboard (Ubuntu):
assignee: William Hua (attente) → khadeja (muslimaqq)
DarkFess (regent-43) on 2013-10-18
Changed in gnome-settings-daemon (Ubuntu):
status: In Progress → Confirmed
Changed in gnome-control-center (Ubuntu):
status: In Progress → Confirmed
Changed in indicator-keyboard (Ubuntu):
assignee: khadeja (muslimaqq) → William Hua (attente)
Changed in indicator-keyboard:
assignee: Alexander Olgin (alexander-a-olgin) → nobody
Norbert (nrbrtx) on 2013-10-18
tags: removed: amd64
affects: indicator-keyboard → ubuntu
affects: ubuntu → indicator-keyboard
Changed in gnome-control-center (Ubuntu):
importance: Undecided → High
Changed in ubuntu-gnome:
status: New → Confirmed
Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
Changed in indicator-keyboard (Ubuntu):
status: Confirmed → Triaged
Changed in hundredpapercuts:
status: New → Confirmed
assignee: nobody → Paper Cuts Ninja (papercuts-ninja)
Changed in indicator-keyboard (Ubuntu):
status: Triaged → Invalid
Changed in indicator-keyboard (Ubuntu Saucy):
status: New → In Progress
importance: Undecided → High
Changed in hundredpapercuts:
status: Confirmed → Invalid
Changed in indicator-keyboard (Ubuntu Saucy):
status: In Progress → Invalid
Changed in indicator-keyboard:
status: Confirmed → Invalid
importance: Undecided → High
Changed in gnome-control-center (Ubuntu Saucy):
importance: Undecided → High
Changed in gnome-settings-daemon (Ubuntu Saucy):
importance: Undecided → High
Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Committed
Changed in ubuntu-gnome:
importance: Undecided → High
Changed in gnome-control-center (Ubuntu Saucy):
status: New → In Progress
description: updated
Changed in gnome-settings-daemon (Ubuntu Saucy):
status: New → Confirmed
Changed in gnome-settings-daemon (Ubuntu Saucy):
status: Confirmed → Triaged
William Hua (attente) on 2013-10-21
description: updated
Adam Conrad (adconrad) on 2013-10-21
Changed in gnome-control-center (Ubuntu Saucy):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in gnome-settings-daemon (Ubuntu Saucy):
status: Triaged → Fix Committed
tags: added: verification-failed
removed: verification-needed
tags: added: verification-needed
removed: verification-failed
Changed in hundredpapercuts:
assignee: Paper Cuts Ninja (papercuts-ninja) → nobody
tags: added: verification-done
removed: verification-needed
tags: added: verification-failed
removed: verification-done
tags: added: verification-done
removed: verification-failed
Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → Fix Committed
Changed in ubuntu-gnome:
status: Confirmed → Fix Committed
Changed in indicator-keyboard (Ubuntu):
assignee: William Hua (attente) → nobody
Changed in gnome-settings-daemon (Ubuntu):
assignee: William Hua (attente) → nobody
Changed in gnome-control-center (Ubuntu):
assignee: William Hua (attente) → nobody
Changed in gnome-settings-daemon (Ubuntu Saucy):
status: Fix Committed → Fix Released
Changed in gnome-settings-daemon (Ubuntu Saucy):
status: Fix Released → Fix Committed
Roman Bedroš (ja-beda) on 2013-10-24
Changed in indicator-keyboard (Ubuntu Saucy):
status: Invalid → Fix Released
Changed in indicator-keyboard (Ubuntu Saucy):
status: Fix Released → Invalid
William Hua (attente) on 2013-10-24
description: updated
Adam Conrad (adconrad) on 2013-10-24
tags: removed: verification-done
tags: added: verification-needed
Changed in gnome-control-center (Ubuntu):
status: Fix Committed → In Progress
Changed in gnome-control-center (Ubuntu Saucy):
status: Fix Committed → In Progress
Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → In Progress
Changed in hundredpapercuts:
importance: Undecided → Medium
Changed in gnome-settings-daemon (Ubuntu Saucy):
status: Fix Committed → In Progress
Changed in ubuntu-gnome:
status: Fix Committed → In Progress
Changed in gnome-control-center (Ubuntu Saucy):
status: In Progress → Fix Committed
Changed in ubuntu-gnome:
status: In Progress → Fix Committed
Changed in gnome-settings-daemon (Ubuntu Saucy):
status: In Progress → Fix Committed
Changed in gnome-settings-daemon (Ubuntu):
status: In Progress → Fix Committed
Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Committed
Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Invalid
Changed in gnome-control-center (Ubuntu Saucy):
status: Fix Committed → Invalid
tags: added: verification-failed
tags: removed: verification-failed
yufw (yynyygy) on 2013-10-27
Changed in indicator-keyboard (Ubuntu Saucy):
status: Invalid → Fix Released
Norbert (nrbrtx) on 2013-10-27
description: updated
Changed in indicator-keyboard (Ubuntu Saucy):
status: Fix Released → Invalid
Norbert (nrbrtx) on 2013-10-27
description: updated
Norbert (nrbrtx) on 2013-10-27
description: updated
Norbert (nrbrtx) on 2013-10-27
description: updated
Norbert (nrbrtx) on 2013-10-27
description: updated
Norbert (nrbrtx) on 2013-10-27
description: updated
Norbert (nrbrtx) on 2013-10-27
description: updated
Norbert (nrbrtx) on 2013-10-27
description: updated
Norbert (nrbrtx) on 2013-10-27
description: updated
Norbert (nrbrtx) on 2013-10-27
description: updated
Norbert (nrbrtx) on 2013-10-27
description: updated
no longer affects: indicator-keyboard (Ubuntu)
no longer affects: gnome-control-center (Ubuntu)
no longer affects: gnome-control-center (Ubuntu Saucy)
no longer affects: indicator-keyboard (Ubuntu Saucy)
no longer affects: hundredpapercuts
affects: indicator-keyboard → hundredpapercuts
no longer affects: gnome-settings-daemon
affects: hundredpapercuts → gnome-settings-daemon
Changed in gnome-settings-daemon:
status: Invalid → Fix Committed
tags: added: verification-failed
removed: verification-needed
Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Triaged
Changed in gnome-settings-daemon (Ubuntu Saucy):
status: Fix Committed → Triaged
Changed in ubuntu-gnome:
status: Fix Committed → Confirmed
Changed in gnome-settings-daemon:
status: Fix Committed → Confirmed
Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → William Hua (attente)
Changed in gnome-settings-daemon (Ubuntu Saucy):
assignee: nobody → William Hua (attente)
Changed in gnome-settings-daemon:
assignee: nobody → William Hua (attente)
Changed in gnome-control-center (Ubuntu):
importance: Undecided → High
status: New → Triaged
tags: added: verification-done
removed: verification-failed
Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-settings-daemon (Ubuntu Saucy):
status: Triaged → Fix Released
Changed in gnome-control-center (Ubuntu):
assignee: nobody → William Hua (attente)
Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → Fix Released
Norbert (nrbrtx) on 2013-10-29
description: updated
Changed in gnome-settings-daemon (Ubuntu):
status: Fix Released → Triaged
Changed in gnome-control-center (Ubuntu):
status: Fix Released → Triaged
Changed in gnome-settings-daemon (Ubuntu Saucy):
status: Fix Released → Triaged
Changed in gnome-settings-daemon:
status: Confirmed → Invalid
Changed in gnome-settings-daemon:
assignee: William Hua (attente) → nobody
Norbert (nrbrtx) on 2013-10-29
description: updated
Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → Fix Released
Norbert (nrbrtx) on 2013-10-29
description: updated
Changed in gnome-settings-daemon (Ubuntu Saucy):
status: Triaged → Fix Released
Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Released
Iain Lane (laney) on 2013-10-31
Changed in gnome-control-center (Ubuntu):
status: Fix Released → Fix Committed
Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
Norbert (nrbrtx) on 2013-10-31
description: updated
Changed in gnome-settings-daemon (Ubuntu Saucy):
status: Fix Released → Triaged
Changed in gnome-settings-daemon (Ubuntu):
status: Fix Released → Triaged
Changed in gnome-control-center (Ubuntu):
status: Fix Released → Triaged
tags: removed: verification-done
tags: added: verification-needed
Norbert (nrbrtx) on 2013-10-31
tags: added: keyboard-layout-switching-hotkeys
tags: added: keyboard-layout-switching-related
Norbert (nrbrtx) on 2013-10-31
description: updated
description: updated
tags: added: verification-done
removed: verification-needed
Norbert (nrbrtx) on 2013-11-02
tags: added: verification-failed
removed: verification-done
description: updated
Lockal (lockal) on 2013-11-04
tags: added: regression
tags: added: verification-done
removed: verification-failed
Norbert (nrbrtx) on 2013-11-04
tags: added: verification-failed
removed: verification-done
tags: added: verification-done
removed: verification-failed
Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Released
William Hua (attente) on 2013-11-12
description: updated
Changed in gnome-control-center (Mandriva):
importance: Unknown → High
status: Unknown → Confirmed
Changed in gnome-control-center (Mandriva):
status: Confirmed → Invalid
Norbert (nrbrtx) on 2013-12-20
tags: added: trusty
Shahar Or (mightyiam) on 2014-01-05
description: updated
Changed in gnome-control-center (Gentoo Linux):
importance: Unknown → Medium
status: Unknown → Invalid
tags: added: ubuntu-desktop-trusty
Norbert (nrbrtx) on 2014-02-04
description: updated
description: updated
Jonas Juodė (jonukas) on 2014-03-05
Changed in gnome-control-center (Baltix):
status: New → Confirmed
assignee: nobody → Mantas Kriaučiūnas (mantas)
description: updated
Norbert (nrbrtx) on 2014-03-07
description: updated
Changed in gnome-control-center (Baltix):
importance: Undecided → High
Norbert (nrbrtx) on 2014-03-29
description: updated
Norbert (nrbrtx) on 2014-03-30
description: updated
Norbert (nrbrtx) on 2014-04-21
description: updated
Norbert (nrbrtx) on 2014-04-21
description: updated
Tmin10 (tmin100) on 2014-04-21
information type: Public → Public Security
information type: Public Security → Public
437 comments hidden view all 517 comments

Yes, I can confirm that with more than 2 layouts the thing is even more broken.

I tried to get a shot to understand better what it's happening, but I suspect that the thing is **really** complex and we have a lot of interacting modules and things that (I suspect) no one really grasp --- the dconf thing, the IBus thing, etc.

I feel really represented by the Steve Taylor's quote at the top of http://www.charvolant.org/~doug/xkb/html/xkb.html --- go and read it.

At the end, I learned to edit KBD configuration to tailor a personal keyboard so that I can avoid switching. I imagine this is viable for me (just using three latin languages), not for people with more complex need.

William Hua (attente) wrote :

Hi Romano, just curious, so the PPA didn't improve your situation at all?

@William --- will try again this afternoon; sorry for the delay.

@William (sorry, got posted too early, a pity launchpad don't let you edit comments). I read wrongly your comment and thought it would have been of no use (I use only latin keyboards --- switch between US intl, US intl AltGr-dead keys, and Spanish), and the name of the PPA is for "non-latin"...

I think what is broken is just the program to configure these shortcuts.
Why? Because using workarounds I can configure my X to switch among layouts
when I press ALT+SHIFT. In my setup at least there is no inherent
limitation about the ability of using these special keys for switching.

To give an example of such a workaround in my Gnome Classic Flashback
(Metacity):
* If I right-click on the indicator icon, select "Text Entry Settings..."
then I will get a dialog window where I can define just shortcuts for
"Switch to next source using..." and "Switch to previous source using..."
and in this dialog box I CAN configure ALT+SHIFT. When I close the dialog
afterwards it works just fine, consistently, I can switch.
* In the "system settings" -> "keyboard" -> "shortcuts" dialog I can even
see ALT+SHIFT there, however if I delete this shortcut there is no way to
get it back in that dialog because it will not detect the key. I can always
set the shortcut using "Text Entry Settings".

Perhaps the problem is so trivial just for the case of Gnome Classic
Flashback (Metacity). But in Gnome Classic Flashback (Metacity) in my
opinion the only problem is the GUI in the system settings, and the problem
is that it does not detect the keypress. The dialog even displays this
shortcut correctly if it has been set using another tool, so the shortcut
storage and representation is working, just key press detection for setting
the shortcut is broken.

On Mon, May 12, 2014 at 7:09 PM, William Hua <email address hidden>wrote:

> Hi Romano, just curious, so the PPA didn't improve your situation at
> all?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1218322
>
> Title:
> Can't set keyboard layout change to alt+shift, ctrl+shift, etc.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/gnome-settings-daemon/+bug/1218322/+subscriptions
>

--
http://www.peterschueller.com/

@William: I tested the PPA. Remeber, Ubuntu Gnome 14.04; I have just two keyboard layouts (if you want I can check with three to).

With the PPA:

1. switching to next source works ok if I choose a normal key combo, for example, Super+Space. On pressing the combo, the layout switches, the indicator is synchronized, and I have a nice OSD display indicting the switch. I cannot set this option with modifiers only keys, as expected.

2. Setting "Modifiers only switch to next source" to Alt+Shift does not work. Nothing, no OSD, no switch in the indicator, no switch of layout.

3. Checking more, I discovered that setting "Modifiers only switch to next source" to for example Right-Ctrl + Right Shift or Compose *do* work, and the indicator follow the switch, but there is no OSD display about the switch. Also Left-Alt + Left-shift works, albeit without OSD display.

So basically the combination that doesn't work for me are the ones with plain Alt of Right-Alt involved. Could be because the Right Alt is mapped to AltGr?

In summary, it's clearly a step in the correct direction. Any idea about the OSD display not showing?

Could be this: https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1246272 (and maybe this: https://bugzilla.gnome.org/show_bug.cgi?id=729423 ) related too?

Seeing the workaround in http://askubuntu.com/questions/459617/keyboard-layout-isnt-kept-upon-reboot I have a feeling that we could have the normal `xsetkeyb` and IBUS fighting?

William Hua (attente) wrote :

Hi Romano, thanks for testing the PPA. I took the workaround and filed an SRU for it here: https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1318673. For anyone who is affected by this bug under GNOME Shell, please use that bug for SRU testing and verification.

I'm not sure about the bug you linked to, but I had the same experience with the OSD not appearing also. But I have to assume that they go through different code paths in GNOME Shell since modifier-only input switching is a completely separate option in the settings, so maybe it's intentional by design...

John (vanuan) wrote :

After setting modifier-only-shortcut to "disabled", I can at least change layout to the 3rd language using UI or Ctrl-Space. With modifier-only-shortcut set to something I can't switch layout to the 3rd language at all!

Horrible bug.

Vladimir Plotnikov (monomakh) wrote :

What about delay of switching layout? For example, I use caps lock for switching. If type quickly than some symbols can be in uppercase.
"fdfdАвававfdfdfdfавававfdfdfdавававfdfdfdFвавав "

Leonid Evdokimov (darkk) wrote :

I confirm Vladimir's words. Moreover, sometimes capslock is permanently turned on instead of layout switching:
gkjgkjgОлпорпорпролпОПОПОПРОПОРплопролпппполпJkghkjghjkghjhg
                    ^ I've not touched shift :)

Constantine (iamvfx) wrote :

WIll it ever be fixed? :D

Alexey Manukhin (axxapy) wrote :

Nope =)
Just use setxkbmap. Smth like that:
setxkbmap -layout 'us,ru' -option 'grp:caps_toggle,grp_led:caps'

Full name (j-launchpad-d) wrote :

The bug was already fixed in 12.04, now the same problems resurface again. I'm holding back several computers from upgrading to 14.04 and looking for an alternate distribution because of this, amongst other issues.

no longer affects: gnome-control-center (Fedora)
Changed in gnome-settings-daemon:
importance: High → Unknown
status: Invalid → Unknown
Dmitry Maruschenko (yojick) wrote :

I've described a workaround to the CapsLock layout switching problem (comments #487-#488 by monomakh and darkk) here: https://bugs.launchpad.net/ubuntu/+source/unity-control-center/+bug/1343327

denkin (ks-alexandr) wrote :

I just tried it once to turn off the input method ibus and now everything is OK

It work in 14.04 and 14.10 testing

The-mob (xarilaos-com) wrote :

For feedback...

After upgrade from 12.04 to 14.04 i had the same problem.

I also have the problem described here
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1247668

I try this solution to fix the problem with NumLock
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1247668/comments/22

and also fixed this bug with Alt+Shift etc.....

Kiko (wipkiko) wrote :

Tested on Ubuntu 14.04, works for me with Shift+Alt.
Thank You

tags: added: regression-release
removed: regression

Affects elementary OS Freya, bug inherited from Ubuntu 14.04

This is a game-breaker for non-English locales. Makes the OS hardly usable as far as typing goes.

Changed in elementaryos:
importance: Undecided → High
milestone: none → freya-rc1
status: New → Confirmed
Rolf Leggewie (r0lf) wrote :

saucy has seen the end of its life and is no longer receiving any updates. Marking the saucy task for this ticket as "Won't Fix".

Changed in gnome-settings-daemon (Ubuntu Saucy):
status: Triaged → Won't Fix
Bruce Pieterse (octoquad) wrote :

Possibly fixed in 3.14 ppa according to darkxst

Changed in ubuntu-gnome:
milestone: none → vivid
Bogdan Lisnenko (lem8r) wrote :

Still buggy here. Elementary OS Freya

Changed in ubuntu-gnome:
status: Confirmed → Triaged
wearecursed (xz) wrote :

Gallum ba galilla ma. This is more than anyone can bear, but we will persevere.

Bruce Pieterse (octoquad) wrote :

This has been fixed in Vivid Vervet (15.04) with the gnome 3.14 packages and should be available later today.

Changed in ubuntu-gnome:
status: Triaged → Fix Released
tags: removed: keyboard-layout-switching-related
tags: added: amd64
Mathew Hodson (mathew-hodson) wrote :

Cleaned up the description. You can use the tag keyboard-layout-switching-hotkeys to find related bugs.

https://bugs.launchpad.net/ubuntu/+bugs?field.tag=keyboard-layout-switching-hotkeys

description: updated
tags: removed: ubuntu-desktop-trusty
Norbert (nrbrtx) on 2015-01-17
tags: removed: amd64
description: updated
description: updated
description: updated
tags: added: gnome3 ubuntu-gnome
Cody Garver (codygarver) wrote :

Bug #1357895 has some more information relevant at least to elementary OS Freya

Jonathan (s-launchppd-y) wrote :

WORKAROUND.

This is just a very dirty workaround that I do not suggest you do. It will render "Geary" useless (but you can choose another app, your call):

1. Step 1:

[code]
echo (setxkbmap -query | grep -q "layout:\s\+us") && setxkbmap il || setxkbmap us > ~/geary
chmod +x ~/geary
sudo cp ~/geary /bin/geary
[/code]
this will override geary.

2. Step 2:
Go to system settings -> keyboard -> shortcuts -> applications.

Set keyboard shortcut for mail (super + shift), ALT-SHIFT doesn't work.

3. Step 3:
Collect underpants.

4. Step 4:
Profit!

Robert Orzanna (orschiro) wrote :

I find the recent solution provided by Santiago [1] very disadvantageous. Shift + Space are frequently used keys for normal typewriting. To me it now happens very frequently that I accidentally switch layouts due to my style of writing and use of Shift and Space.

Is someone else having that problem? Can't we use Shift + Ctrl + Space to change keyboard layouts?

[1] https://bugs.launchpad.net/switchboard-plug-keyboard/+bug/1357895/comments/29

Santiago (santileortiz) wrote :

Now that I hink of it, you are right, it's commonly used to enter a next line on facebook and stuff like that, luckily the code for switchboard was just merged, and you can get it on the next update, now you can go to Settings>Keyboard>Shortcuts>Universal Access and change the shotcut there.

tags: added: metabug
3 comments hidden view all 517 comments
Cody Garver (codygarver) wrote :

Tracked by elementary OS @ bug #1357895

no longer affects: elementaryos
Allan Deamon (rea-aft) wrote :

I can't type Esperanto. The option button that allows me turn on Esperanto Circumflexes is gone! Does Gnome project hates people that speaks Esperanto?

Norbert (nrbrtx) wrote :

Guys I'm sorry, but it seems that bug is returned in the newest Ubuntu 15.04 final.
I set Russian and English layouts while installing.

Now I can't use Alt+Shift in GNOME FlashBack session.

Gnome-control-center shows this shortcut as "Shift+Alt+Next Group", but language is switched because of /etc/default/keyboard
(
cat /etc/default/keyboard
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="us,ru"
XKBVARIANT=","
XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll"

BACKSPACE="guess"
)
but indicator-keyboard does not react on language change.
It is unbelievable.

akiyamka (akiyamka) wrote :

The exact same crap, before update everything was ok!

vadison (vadison) wrote :

I have this bug too in Ubuntu Gnome 15.04.

Artem (artemb) wrote :

The same at Lubuntu 15.04 vivid , all updates 05.27.2015

Onime (g-gatenashvili) wrote :

Still have same problem Ubuntu 14.04, Update 01.06.2015

Yotam Benshalom (benshalom) wrote :

Not working for me on Ubuntu 15.04. This breaks Gnome for me.
gnome-tweak-tool allows me to set alt+shift as a shortcut for layout switching, but it doesn't actually work.

Displaying first 40 and last 40 comments. View all 517 comments or add a comment.