gnome-shell doesn't give focus to fallback lock screen

Bug #1181632 reported by Jeremy Bicha on 2013-05-18
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Critical
Ubuntu GNOME
Undecided
Unassigned
gtk+3.0 (Ubuntu)
Medium
Unassigned

Bug Description

I tried running gnome-shell 3.8 with lightdm instead of gdm. I locked the screen with Ctrl+Alt+L. When I tried to enter my password to unlock, no characters showed up but it's still possible to blindly enter the password and unlock -- there just isn't any feedback that GNOME is accepting input.

An alternate workaround is to click Switch User from the unlock screen and enter my password from the login screen which unlocked my screen.

We should fix this bug before having gnome-shell depend solely on libgdm instead of gdm (LP: #1162849).

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: gnome-shell 3.8.2-1ubuntu1
ProcVersionSignature: Ubuntu 3.9.0-2.6-generic 3.9.2
Uname: Linux 3.9.0-2-generic x86_64
ApportVersion: 2.10.1-0ubuntu1
Architecture: amd64
CrashDB: ubuntu
Date: Sat May 18 19:26:23 2013
DisplayManager: lightdm
GsettingsChanges: b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
MarkForUpload: True
SourcePackage: gnome-shell
UpgradeStatus: Upgraded to saucy on 2013-05-07 (11 days ago)

Related branches

Jeremy Bicha (jbicha) wrote :
Tim Lunn (darkxst) wrote :

I think this is unrelated to the libgdm split. I can reproduce it even with the full gdm stack installed.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Tim Lunn (darkxst) wrote :

This is happening in saucy, which doesnt yet have the split gdm package.

summary: - gnome-shell doesn't give focus to fallback lock screen with libgdm
- without gdm
+ gnome-shell doesn't give focus to fallback lock screen
Jeremy Bicha (jbicha) on 2013-06-06
description: updated
Tim Lunn (darkxst) on 2013-06-07
affects: gnome-shell → mutter
Changed in mutter (Ubuntu):
status: New → Confirmed
Changed in mutter:
importance: Unknown → Critical
status: Unknown → New
Jeremy Bicha (jbicha) on 2013-07-05
affects: mutter → gtk
affects: mutter (Ubuntu) → gtk+3.0 (Ubuntu)
Tim Lunn (darkxst) wrote :

I tested the upstream patch and it fixes this issue.

Changed in gtk:
status: New → Fix Released
Jeremy Bicha (jbicha) on 2013-07-23
no longer affects: gnome-shell (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.8.2-3ubuntu4

---------------
gtk+3.0 (3.8.2-3ubuntu4) saucy; urgency=low

  * Add new symbol from last upload

gtk+3.0 (3.8.2-3ubuntu3) saucy; urgency=low

  * debian/patches: Cherrypick upstream git iconcache fixes (LP: #1186694)
    - git_iconcache_ref_GtkIconData.patch
    - git_icontheme_move_changed_emission.patch
  * debian/patches/git_disable_frame_sync_gtkplug.patch:
    - Fixes gnome-screensaver not redrawing when used with lightdm
      on gnome-shell (LP: #1181632)
 -- Jeremy Bicha <email address hidden> Mon, 22 Jul 2013 21:53:35 -0400

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2017-04-21
Changed in ubuntu-gnome:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.