"Location" auto-complete menu often offers duplicate suggestions

Bug #740884 reported by Matthew Paul Thomas
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
Undecided
Unassigned
Ubuntu Geonames
Undecided
Unassigned
indicator-datetime (Ubuntu)
Undecided
Michael Terry

Bug Description

Binary package hint: indicator-datetime

indicator-datetime 0.1.98-0ubuntu1, Ubuntu Natty

1. From the clock menu, choose "Time & Date Settings..."
2. Click "Unlock to change these settings".
3. In the "Location" field, enter "kuala lumpur", or "wellington", or "rio de janeiro " (with a trailing space).

What happens:
* "kuala lumpur" returns two suggestions with the exact text "Kuala Lumpur (Kuala Lumpur, Malaysia)".
* "wellington" returns two suggestions with the exact text "Wellington (Wellington, New Zealand)".
* "rio de janeiro " returns three suggestions with the exact text "Rio de Janeiro (State of Rio de Janeiro, Brazil)".

What should happen: No two suggestions should ever have exactly the same text, because you have no way of telling what the difference is.

Related branches

tags: added: sniffles
Michael Terry (mterry)
Changed in indicator-datetime (Ubuntu):
assignee: nobody → Michael Terry (mterry)
Revision history for this message
Michael Terry (mterry) wrote :

This also effects ubiquity, since this is coming from the server. Seems clients should filter for such duplicates. And they are duplicates. In Rio's case, the three locations have exact information, except longitude and latitude.

Ted Gould (ted)
Changed in indicator-datetime:
status: New → Fix Committed
Ted Gould (ted)
Changed in indicator-datetime:
milestone: none → 0.2.0
Ted Gould (ted)
Changed in indicator-datetime:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 0.2.0-0ubuntu1

---------------
indicator-datetime (0.2.0-0ubuntu1) natty; urgency=low

  * New upstream release.
    ∘ Remove unused liboobs
    ∘ Add translator comments and make strings translatable (LP: #737326)
    ∘ Remove password dialog for calendars not the keyring
    ∘ Use default matching when geonames aren't available (LP: #740870)
    ∘ UI Cleanups and naming fixes (LP: #740806, LP: #740819)
    ∘ Free JSON parser data
    ∘ Avoid duplicates in GeoNames data (LP: #740884)
    ∘ Make location completion more robust
  * debian/control: Dropping liboobs
 -- Ted Gould <email address hidden> Wed, 23 Mar 2011 16:22:50 -0500

Changed in indicator-datetime (Ubuntu):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Revision history for this message
Sergio Benjamim (sergio-br2) wrote :

Bug fixed? But it still happens on Ubuntu 12.04.1 (daily build from July 14). Take a look in this video, please:

http://www.youtube.com/watch?v=pWcpldr-_Z0

And there isn't Sao Paulo in Amazonas !!! Take in municipalities' list of Brazil:

http://pt.wikipedia.org/wiki/Anexo:Lista_de_munic%C3%ADpios_do_Brasil#S

Revision history for this message
Sergio Benjamim (sergio-br2) wrote :

http://geoname-lookup.ubuntu.com/?query=Sao%20Paulo returns:

[{"name" : "Sao Paulo", "admin1" : "São Paulo", "country" : "Brazil", "longitude" : "-46.636110", "latitude" : "-23.547500" }, {"name" : "Sao Paulo", "admin1" : "São Paulo", "country" : "Brazil", "longitude" : "-46.636110", "latitude" : "-23.547500" }, {"name" : "Sao Paulo", "admin1" : "São Paulo", "country" : "Brazil", "longitude" : "-46.636110", "latitude" : "-23.547500" }, {"name" : "Sao Paulo", "admin1" : "São Paulo", "country" : "Brazil", "longitude" : "-46.636110", "latitude" : "-23.547500" }, {"name" : "Sao Paulo", "admin1" : "Amazonas", "country" : "Brazil", "longitude" : "-62.900000", "latitude" : "-7.233330" }, {"name" : "Sao Vicente de Paulo", "admin1" : "Rio de Janeiro", "country" : "Brazil", "longitude" : "-42.259720", "latitude" : "-22.724440" }]

The correct could be:

[{"name" : "Sao Paulo", "admin1" : "São Paulo", "country" : "Brazil", "longitude" : "-46.636110", "latitude" : "-23.547500" } , {"name" : "Sao Vicente de Paulo", "admin1" : "Rio de Janeiro", "country" : "Brazil", "longitude" : "-42.259720", "latitude" : "-22.724440" }]

There isn't 4 Sao Paulo city, and neither Sao Paulo in Amazonas!!! take a look in municipalities' list of Brazil:

http://pt.wikipedia.org/wiki/Anexo:Lista_de_munic%C3%ADpios_do_Brasil#S

Changed in ubuntu-geonames:
status: New → Confirmed
Revision history for this message
Sergio Benjamim (sergio-br2) wrote :

http://geoname-lookup.ubuntu.com/?query=Rio%20de%20Janeiro returns:

[{"name" : "São Sebastião do Rio de Janeiro", "admin1" : "Rio de Janeiro", "country" : "Brazil", "longitude" : "-43.207500", "latitude" : "-22.902780" },
{"name" : "São Sebastião de Rio de Janeiro", "admin1" : "Rio de Janeiro", "country" : "Brazil", "longitude" : "-43.207500", "latitude" : "-22.902780" },
{"name" : "Ciutat de Rio de Janeiro", "admin1" : "Rio de Janeiro", "country" : "Brazil", "longitude" : "-43.207500", "latitude" : "-22.902780" },
 {"name" : "Río de Xaneiro - Rio de Janeiro", "admin1" : "Rio de Janeiro", "country" : "Brazil", "longitude" : "-43.207500", "latitude" : "-22.902780" },
{"name" : "Rio de Janeiro", "admin1" : "Rio de Janeiro", "country" : "Brazil", "longitude" : "-43.207500", "latitude" : "-22.902780" }, {"name" : "Vila Rio de Janeiro", "admin1" : "São Paulo", "country" : "Brazil", "longitude" : "-46.541940", "latitude" : "-23.446760" }]

There aren't "Ciutat de Rio de Janeiro", "Rio de Xaneiro" or "São Sebastião do Rio de Janeiro". See in http://pt.wikipedia.org/wiki/Anexo:Lista_de_munic%C3%ADpios_do_Brasil#R

"Vila Rio de Janeiro" is not a city, it is a neighborhood of Guarulhos City (near São Paulo). Take a look at "-23.446760, -46.541940" in Google maps. This does not need to be in the database.

Rio de Janeiro could be like this:

{"name" : "Rio de Janeiro", "admin1" : "Rio de Janeiro", "country" : "Brazil", "longitude" : "-43.207500", "latitude" : "-22.902780" }

Revision history for this message
Sergio Benjamim (sergio-br2) wrote :

There aren't any bug fix or Fix Released! Take a closer look at this problem

Revision history for this message
Sergio Benjamim (sergio-br2) wrote :

Try search in Google maps: "-7.233330,-62.900000". There's only forest there!

There isn't Sao Paulo in Amazonas! Please fix this error, it is a SHAME to any Brazilian who installs Ubuntu to their friends...

Revision history for this message
Sebastien Bacher (seb128) wrote :

@Segio: if you look again at the bugs table you will notice that the "Geonames" part of the bug is not set as fix released, only the indicator-datetime part is and that's because there is no bug in the indicator code, the issue is the geolocalization database datas not the code

Revision history for this message
Sebastien Bacher (seb128) wrote :

"@Sergio:..." (sorry for the typo in your name)

Revision history for this message
Sergio Benjamim (sergio-br2) wrote :

Ok, now I understood!

Is there the possibility of this bug to be fixed to the Ubuntu 12.04.1? The related problem about Amazonas is pretty ridiculous for us Brazilians...

Geolocalization database datas has many problems, will this be fixed, for every localization?

Revision history for this message
Andrea Corbellini (andrea.corbellini) wrote :

Ubiquity has its own task: bug 837054

no longer affects: ubiquity (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers