Boutons du formulaire pour poster un message totalement blancs avec un thème blanc sur noir

Bug #252366 reported by Jérôme Guelfucci on 2008-07-27
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu-fr.org
Undecided
Unassigned

Bug Description

Lorsque que l'on utilise un thème système avec une couleur de police blanche les boutons du formulaire pour poster les messages sont totalement blancs ce qui est plutôt embétant.

Pour corriger ce problème j'ai ajouté ceci à la css du forum:

input {
  color : black;
}

input:hover {
  color : black;
}

select {
  color : black;
}

Cela ne semble pas produire d'effets indésirables.

Ceci affecte aussi les champs qui permettent de se logguer et les champs en haut à droite pour faire une recherche.

Changed in ubuntu-fr-website:
status: New → Confirmed
Nizar Kerkeni (nizarus) wrote :

j'ai remarqué ce comportement avec le thème "new human" d'intrepid.

description: updated
description: updated
Didier Roche (didrocks) wrote :

Ok je comprends pourquoi je ne comprenais pas (oui, journées difficiles, on a le droit hein !)

En fait, c'est fixé sur le thème drupal mais pas sur le thème forum ou autre.
D'ici la fin de semaine, je demanderai à AlexandreP de merger tous les thèmes des différentes sections du site en sachant que le thème drupal est celui qui prime. Le fix sera donc automatiquement porté.

olive (olivier.fraysse) on 2009-09-23
Changed in ubuntu-fr-website:
assignee: nobody → olive (olivier.fraysse)
Brice Terzaghi (terzag) wrote :

Ça fait plus d'un an que le problème a été rapporté et il n'y a eu aucun changement. Ce serait pas mal de prendre 5 minutes pour enfin corriger cette feuille de style...

Accessoirement, pour éviter de corriger le problème à moitié, ce serait judicieux de mettre une couleur de fond aux formulaires et pas seulement une couleur pour le texte :
input,
textarea{
background-color: #fff;
color: #000;
}

Bonjour Brice,

C'est toujours agréable de voir avec quelle gentillesse les problèmes
nous sont remontés.

Puisque tu as l'air d'avoir beaucoup de temps et de talent je t'invite
à venir participer à aider ubuntu-fr...
Tu comprendras peut etre que nous avons des dizaines de choses à
faire... Beaucoup étant très simples et rapides mais à faire...

Nous serons donc ravi de te compter parmi notre équipe de bénévoles
qui font ubuntu-fr. Pour nous contacter passe sur #ubuntu-fr-meeting
et présente toi... Mais par contre si jamais tu ne viens pas, je
t'invite fortement à ne pas employer le ton excédé que tu utilises...

Merci !

2009/12/19 Brice Terzaghi <email address hidden>:
> Ça fait plus d'un an que le problème a été rapporté et il n'y a eu aucun
> changement. Ce serait pas mal de prendre 5 minutes pour enfin corriger
> cette feuille de style...
>
> Accessoirement, pour éviter de corriger le problème à moitié, ce serait judicieux de mettre une couleur de fond aux formulaires et pas seulement une couleur pour le texte :
> input,
> textarea{
> background-color: #fff;
> color: #000;
> }
>
> --
> Boutons du formulaire pour poster un message totalement blancs avec un thème blanc sur noir
> https://bugs.launchpad.net/bugs/252366
> You received this bug notification because you are a member of Ubuntu-
> fr-webteam, which is subscribed to Site Ubuntu-fr.
>

Brice Terzaghi (terzag) wrote :

J'ai beau me relire, je ne vois pas en quoi j'ai un ton "excédé". Je me borne à signaler qu'un problème très simple à régler traîne depuis longtemps et que le dernier message qui le concerne réellement dit qu'il sera corrigé "d'ici la fin de la semaine" en août 2008.

Changed in ubuntu-fr-website:
assignee: olive (olivier.fraysse) → nobody
Changed in ubuntu-fr-website:
status: Confirmed → Fix Committed
Mathieu Comandon (strycore) wrote :

Merci de valider le fix ( bzr branch lp:~strycore/+junk/forum.prod ) , oui j'ai la flemme d'installer FluxBB pour une ligne de CSS...
S'il est correct et que le problème se reproduit sur les autres thèmes je pourrais les corriger.

xabilon (xabilon) wrote :

Personne pour valider le changement mineur de CSS ?

Brice Terzaghi (terzag) wrote :

Le changement a été fait sur le forum et il faut valider que ça marche ? Parce que c'est toujours buggé...

Pour l'instant, j'utilise Stylish avec les CSS suivants :

#top input,
#post input,
#edit input,
#report input,
#brdfooter input{
background-color: #fff !important;
color: #000 !important;
}
#navWiki input:hover{
color: #fff !important;
}

(Il doit manquer des inputs si on les cible précisément, j'ai juste noté #top, #post, etc. en tombant dessus au fur et à mesure mais je n'ai pas la liste exhaustive des blocs, ne connaissant pas le système utilisé.)

Sultan Rahi (sultanrahi) wrote :

J'ai posté sur le forum une solution que je considère comme plus simple (tout les inputs sont pris en compte par exemple).

Faut-il faire quelque chose pour que cela soit pris en compte ? En cas de doute, il est possible de rajouter le style amélioré dans la liste de choix présent dans les options utilisateur.

Brice Terzaghi (terzag) wrote :

C'est plus simple mais ça cible trop large. Ça prend en compte le menu dans le wiki, par exemple. Et si on met une couleur de fond (ce qui est conseillé à mon avis, puisqu'avec certains thèmes on peut se retrouver avec le même problème que pour le texte), les liens du menu en question se retrouvent avec.

Sultan Rahi (sultanrahi) wrote :

Bizarre.
Le wiki n'utilise pas le même CSS pourtant:

http://www-static.ubuntu-fr.org/css/ubuntufr2.css
et
http://www-static.ubuntu-fr.org/lib/tpl/ubuntu/addedstyle-ubuntu.css

et pour le forum:
http://www-static.ubuntu-fr.org/style/Ubuntu.css

Quand bien même, le menu de gauche ne semble pas affecté pour moi. Voici un fichier CSS avec les liens vers les images modifiées et les couleurs de fond et de texte en rose et vert, plutôt que noir et blanc, pour bien voir ce qui est affecté. Quelle est le problème ?

Le seul problème qui peut être facilement réglé est le background-color: transparent; de http://www-static.ubuntu-fr.org/css/ubuntufr2.css
Il suffit de le changer en blanc.

Brice Terzaghi (terzag) wrote :

Ok. J'avais pas fait de tri : avec Stylish, j'appliquais mon style à *.ubuntu-fr.org, je n'avais pas vu qu'il y avait deux feuilles de styles.

Si j'applique mon style à la doc, en forçant les couleurs (avec le !important), je me retrouve avec du blanc en fond des liens du menu Actions. C'est d'ailleurs ce qui m'a fait remarquer que c'étaient des champs input et pas des liens.

YoBoY (yoboy-leguesh) on 2010-06-24
tags: added: forum
xabilon (xabilon) on 2010-10-24
Changed in ubuntu-fr-website:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments