Documentation francophone

La table des matières est "surnumérotée" dans certaines conditions

Reported by Mathieu Marquer on 2011-02-20
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Documentation Ubuntu-fr
Low
Unassigned
Static Ubuntu-fr
Low
Unassigned

Bug Description

Exemple trouvé avec http://doc.ubuntu-fr.org/ubuntu_64bits

Si j'accède directement à la page, la table des matières est normale. Si j'y accède via Google après avoir fait une recherche sur "doc ubuntu 64 bits", la table des matières est euh... C'est plus simple en image, voir le fichier attaché : à gauche la table normale, à droite la table pas normale.

Mathieu Marquer (slasher-fun) wrote :
Mathieu Marquer (slasher-fun) wrote :

Confirmé sous Chrome 11 et Firefox 4.

Changed in ubuntu-fr-doc:
status: New → Confirmed
McPeter (mcpeter) wrote :

Je viens de faire un test ... manifestement le soucis est spécifique à Google

code google --> <a onmousedown="return clk(this.href,'','','','1','','0CBgQFjAA')" class="l noline" href="http://doc.ubuntu-fr.org/ubuntu_64bits"><em>Ubuntu 64 bits</em> - Accueil | <em>Ubuntu</em>-fr</a>

apparemment la fonction JS de google envoi des trucs pas clair :\ ... car le soucis ne se rencontre pas si on utilise cette même ligne "ailleurs".

Ça ressemble fort aux soucis rencontrés fût un temps du forum vers la doc avec des caractères bizarres dans le flux

Pense à préciser le navigateur utilisé.

Pour ma part :
 - firefox 3.6.13
   -> depuis google --> pas ok
   -> direct --> ok
   -> depuis un autre site avec le code html de google --> ok

Curiosité :

Dans chromium .... je tape : www.google.com dans la barre d'adresse .. .qui se transforme en : www.google.fr
de là par copié collé je mets en champs recherche : doc ubuntu 64 bits
qui m'affiche dans la barre d'url : http://www.google.fr/#hl=fr&source=hp&q=doc+ubuntu+64+bits&aq=f&aqi=&aql=&oq=&fp=7746cb67390cec52
là curieusement pas de soucis.

Bref un truc bien tordu j'ai l'impression dans le flux envoyé par google :\

YoBoY (yoboy-leguesh) wrote :

J'ajouterai simplement que clicker sur un résultat google introduit des items dans notre code HTML

En venant d'une recherche :
<li class="level2"><div class="li"><span class="li"><a href="#utiliser_des_programmes_32_bits_sur_ubuntu_64_bits" class="toc">Utiliser des programmes 32 bits sur <span class="search_hit">Ubuntu</span> <span class="search_hit">64</span> bits</a></span></div></li>

En étant normal sur la doc :
<li class="level2"><div class="li"><span class="li"><a href="#migration_de_ubuntu_32_bits_a_64_bits" class="toc">Migration de Ubuntu 32 bits à 64 bits</a></span></div></li>

Ce sont ces <span class="search_hit"> qui foutent le bazar avec nos règles CSS actuelles. Après je pense qu'il faut plus incriminer les navigateurs que le moteur de recherche, du fait que même avec Bing.com ça me fait ça.

Aldian (aldian-gp) wrote :

le bug est lié aux propriétés CSS content associées aux éléments suivants:
#toc__inside li.level1 span:before
et
#toc__inside li.level2 span:before

Dans ces éléments, des propriétés "content" définissent le comportement de l'ajout de la numérotation automatique. Le problème vient du fait que les spans insérés pour indiquer le succès de la requête héritent aussi de ces propriétés, et les appliquent. La solution consiste donc à désactiver les propriétés content pour les spans de classe search_hit. Voit patch attaché.

Le patch est sous forme de script stylish, vu que c'est la manière la plus commode pour moi de tester ce genre de modification. L'ensemble du code à insérer dans doc-general.css pour régler le bug se résume à ceci:

span.search_hit:before{
    content: none !important;
}

Aldian (aldian-gp) wrote :

petite précision, le "!important" est à enlever, sinon ça ne marchera que sous Firefox

xapantu (xapantu) wrote :

Bon, sinon, je ne sais pas si c'est possible, mais le problème des items en trop vient forcément de DokuWiki. Je suggère de remonter à la source : soit on veux que les termes de la recherche soient mis en évidence, soit on vire tout ça.

http://bugs.dokuwiki.org/index.php?do=details&task_id=616 (pas en rapport avec notre bug, mais en rapport avec notre function)

http://xref.dokuwiki.org/reference/dokuwiki/nav.html?inc/html.php.html#html_hilight

Je ne sais pas si c'est désactivable, je n'ai jamais utilisé DokuWiki, mais si ça ne l'est pas, on pourrait peut-être juste court-circuiter cette partie du code à la main, c'est le plus simple et le plus performant.

mando (marcolivier-buob) wrote :

Bonjour,

Ci-joint une capture d'écran du bug,
http://img18.imageshack.us/img18/3347/bugmenu.png

... que j'ai rencontré en allant ici :
http://doc.ubuntu-fr.org/tutoriel/tout_savoir_sur_les_modules_linux

J'utilise iceweasel 3.5.18 (debian wheezy).
Le bug graphique a disparu dès que j'ai cliqué sur "Rafraîchir".

Tuxmouraille (ou Lahire Biette) a envoyé un message sur la ML <email address hidden> au sujet de ce bogue.

En gros, on peut reproduire ce bogue assez facilement (au moins avec Firefox) en visitant par exemple les URL suivants :
http://doc.ubuntu-fr.org/bind9?s[]=dns&s[]=furtifs&s[]=serveur
http://doc.dev.ubuntu-fr.org/bind9?s[]=dns&s[]=furtifs&s[]=serveur (donc sur le dev aussi)

Ça ne dépend apparemment pas de la page consultée, parce que ça marche aussi avec :
http://doc.ubuntu-fr.org/hugin?s[]=graphisme&s[]=ppa

Le simple fait de de rajouter un &s[]=xxx avec xxx qui est un mot qui se trouve dans la table des matières provoque le bogue.

J'ai aussi vu que ça fait boguer les tags. Cf pièce-jointe pour la page bind9 sur le serveur de prod.

Aldian (aldian-gp) wrote :

Pour information, il n'est plus nécessaire d'apporter des détails supplémentaires au niveau de la table des matières. Le problème est identifié, j'ai essayé une première fois de le corriger via ma branche lp:~aldian-gp/ubuntu-fr-static/ubuntu-fr-static-doc_bug_722234 mais en fait, la correction n'a pas fonctionné à cause d'un problème de priorité des css.

Ma deuxième branche tient compte de ce problème : lp:~aldian-gp/ubuntu-fr-static/bugfixe-doc-722234-v2 et a été testée avec succès sous Firefox, Chromium et Opéra. Mais par contre la correction n'est pas fonctionnelle sur des navigateurs moins populaires comme Epiphany ou Arora pour des raisons inconnues.

Par contre l'histoire du bogue des tags m'est inconnue. Des détails supplémentaires seraient les bienvenus si les deux bugs sont bien reliés (numerotation des tags?)

Bah, c'est pas une numérotation vu que les tags ne sont pas numérotés. En fait l'image (petite étiquette) qui se trouve normalement une seule fois devant tous les tags se trouve répétée devant chaque tag dont le nom est dans l'URL sous la forme &s[]=nom_du_tag.

Un bon exemple vaut mieux que de longues explications. La copie d'écran précédente en est un. Pour info l'URL était alors :
http://doc.ubuntu-fr.org/bind9?s[]=dns&s[]=furtifs&s[]=serveur

Je mets cette info dans ce bogue simplement parce que ce sont les mêmes causes qui les provoquent.

Aldian (aldian-gp) wrote :

Effectivement les bugs sont liés. Je n'avais pas fait attention à celui-ci, bravo pour l'observation!

Ici aussi le problème vient de l'insertion de spans additionnels qui héritent des mêmes propriétés que le span parent.
La correction est donc similaire, il faut ajouter ceci dans la feuille css:

div.dokuwiki div.tags span span {
    background: none repeat scroll 0 0 transparent;
    padding: 0;
}

Je l'intègrerai dans ma branche à l'occasion

YoBoY (yoboy-leguesh) wrote :

ça cause beaucoup sur ce bug... bon j'ai été jeté un oeil dans le html et le CSS, et quand je vois le niveau de complexité je ne m'étonne pas que ça coince. Est ce que quelqu'un pourrait tester plus en profondeur cette solution :

/* Début - Effet de numérotation */
#toc__inside li.level1{
    counter-reset:sousmenus;
}
#toc__inside li.level1:before {
    padding-right:0.2em;
    counter-increment:menus;
    content:counter(menus)".";
}
#toc__inside li.level2:before {
    counter-increment:sousmenus;
    content:counter(menus) "." counter(sousmenus) " ";
}
#toc__inside div.li {display:inline;}

à mettre à la place de notre solution actuelle dans doc-general.css. J'ai en effet viré les span car je ne comprend pas pourquoi on injecte du texte dans ces éléments alors que c'est les items des listes qu'on veut numéroter. J'ai testé vite fait chez moi, ça semble marcher, mais je n'ai pas le temps de tester plus avant cette solution.

Merci d'avance.

Changed in ubuntu-fr-static:
status: New → Triaged
importance: Undecided → Low
Changed in ubuntu-fr-doc:
status: Confirmed → Triaged
importance: Undecided → Low
milestone: none → 20102207-ufr-3
Changed in ubuntu-fr-static:
milestone: none → 2011-05
xapantu (xapantu) wrote :

Mais je ne comprends toujours pas pourquoi vous ne voulez pas désactiver ça dans DokuWiki ?

Yoboy, j'ai testé sur ma branche [1], liée au Bug #719652, qui contenait déjà des modifs sur l'organisation du CSS pour la numérotation. Désolé, ça peut foutre le bordel si on ne prend qu'une partie en compte : je joins donc toute la partie de mon CSS doc-general pour ce qui concerne la numérotation (titre et table des matières).

En fait, la solution que j'ai trouvé pour que toute la ligne (numérotation incluse) est le même style d'appliqué, c'est d'avoir quelque chose comme #toc__inside li.level1 a:before.
C'est la même chose pour la couleur des titres (déjà modifié aussi dans [1]) : #main h3 a:before. Ça évite d'avoir ce qu'on peut trouver en pièce-jointe : "3" en rouge, mais "3.1" et "3.2" en noir, avec le texte du titre en rouge.
Pour la table des matières, la différence de couleur entre numérotation et titre est moins flagrante, mais bien présente, dans ce que tu proposes Yoboy.

[1] : https://code.launchpad.net/~thibault.lemaitre/ubuntu-fr-static/ubuntu-fr-static-thibault

mando (marcolivier-buob) wrote :

Hello,

Ici aussi le bug survient : http://doc.ubuntu-fr.org/liste_portables_toshiba

[...]
<li class="level1"><div class="li"><span class="li"><a href="#portege" class="toc">Portégé</a></span></div></li>
<li class="level1"><div class="li"><span class="li"><a href="#qosmio" class="toc">Qosmio</a></span></div></li>
<li class="level1"><div class="li"><span class="li"><a href="#satellite_1xxx" class="toc"><span class="search_hit">Satellite</span> 1xxx</a></span></div></li>
<li class="level1"><div class="li"><span class="li"><a href="#satellite_3xxx" class="toc"><span class="search_hit">Satellite</span> 3xxx</a></span></div></li>
[...]

Bonne journée

YoBoY (yoboy-leguesh) on 2011-04-27
Changed in ubuntu-fr-doc:
milestone: 20102207-ufr-3 → none
Aldian (aldian-gp) wrote :

Je suis a peu près persuadé que ce bug avait été corrigé. On en avait discuté sur IRC, puis testé un patch et mis en prod (ou alors ma mémoire me joue des tours). Mais le correctif a du sauter lors d'un upgrade (MAJ Dokuwiki?) car le bug est revenu. Ex:

http://doc.ubuntu-fr.org/bind9?s[]=dns&s[]=furtifs&s[]=serveur

YoBoY (yoboy-leguesh) wrote :

La prochaine mise à jour de dokuwiki change le html de la table des matières ce qui règle ce problème.

Changed in ubuntu-fr-doc:
milestone: none → 20121013-ufr1
YoBoY (yoboy-leguesh) on 2012-10-24
Changed in ubuntu-fr-doc:
status: Triaged → Won't Fix
status: Won't Fix → Fix Committed
YoBoY (yoboy-leguesh) on 2012-11-13
Changed in ubuntu-fr-static:
status: Triaged → Fix Released
Changed in ubuntu-fr-doc:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers