Style: Ƴ ƴ (U+01B3) should both have hook on right

Bug #681026 reported by Denis Moyogo Jacquerye on 2010-11-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Font Family
Medium
Unassigned

Bug Description

The side of the hook on Ƴ (U+01B3 LATIN CAPITAL LETTER Y WITH HOOK) should be on the right, like for the lowercase ƴ (U+01B4 LATIN SMALL LETTER Y WITH HOOK). Currently the Ubuntu fonts have the hook on the left side.

The Unicode charts had the hook on the left, but this was changed for the right as that side is much more common. See http://std.dkuug.dk/JTC1/sc2/wg2/docs/N2859.pdf for rational.

Most people using the character are used to have the hook on the right. It is better to have it on that side.
The left-hook Ƴ could be available as a alternate glyph but should not be the default.

A left-hand hook was shown prior to Unicode 4.1, which fixed it and which is documented in the errata notes (search for "hook"):

  http://unicode.org/versions/Unicode4.1.0/erratafixed.html

Paul Sladen (sladen) wrote :

Based on the supporting defect documentation, mirroring the current glyph so that the hook is on the right would seem appropriate.

summary: - Default U+01B3 should have hook on the right
+ Style: Ƴ ƴ (U+01B3) should both have hook on right
Changed in ubuntu-font-family:
importance: Undecided → Medium
milestone: none → 1.00
status: New → Confirmed
Paul Sladen (sladen) on 2010-11-24
tags: added: uff-latin-b uff-unicode-4.1
description: updated
Paul Sladen (sladen) wrote :

Also applies to Monospace R17.

Changed in ubuntu-font-family:
milestone: 1.00 → 0.71
status: Confirmed → Triaged
Shiraaz Gabru (shiraaz) wrote :

This is a matter of preference, I'm not sure there is a need to change the direction of the hook, as this was a design decision.

Paul Sladen (sladen) wrote :

Shiraaz: it is a Unicode errata that was corrected six years, one month and two days ago. Please see the third entry down on:

  http://unicode.org/versions/Unicode4.1.0/erratafixed.html

Denis Moyogo Jacquerye (moyogo) wrote :

Shiraaz,
Why would a left hook on capital letter Y with hook be better?

Shiraaz Gabru (shiraaz) wrote :

Hi Paul, thanks for that. Yes, I see it was a mistake by Unicode, status changed to fix committed.

Changed in ubuntu-font-family:
status: Triaged → Fix Committed
Shiraaz Gabru (shiraaz) on 2010-12-22
Changed in ubuntu-font-family:
status: Fix Committed → In Progress
Shiraaz Gabru (shiraaz) on 2011-02-16
Changed in ubuntu-font-family:
status: In Progress → Fix Committed
Paul Sladen (sladen) wrote :

This a new upstream version of the Ubuntu Font Family. In addition to
the extensive bug fixes it doubles the number of .ttfs files, from four
to eight with the inclusion of Light, Medium and italics.

Upstream changelog:

2010-03-08 (Paul Sladen) Ubuntu Font Family version 0.71.2

* (Production) Adjust Medium WeightClass to 500 (Md, MdIt) (LP:
#730912)

2010-03-07 (Paul Sladen) Ubuntu Font Family version 0.71.1

* (Design) Add Capitalised version of glyphs and kern. (Lt, LtIt,
Md, MdIt) DM (LP: #677446)
* (Design) Re-space and tighen Regular and Italic by amount specified
by Mark Shuttleworth (minus 4 FUnits). (Rg, It) (LP: #677149)
* (Design) Design: Latin (U+0192) made straight more like l/c f with
tail (LP: #670768)
* (Design) (U+01B3) should have hook on right, as the lowercase
(U+01B4) (LP: #681026)
* (Design) Tail of Light Italic germandbls, longs and lowercase 'f'
to match Italic/BoldItalic (LP: #623925)
* (Production) Update <case> feature (Lt, LtIt, Md, MdIt). DM
(LP: #676538, #676539)
* (Production) Remove Bulgarian locl feature for Italics. (LP: #708578)
* (Production) Update Description information with new string:
"The Ubuntu Font Family are libre fonts funded by Canonical Ltd
on behalf of the Ubuntu project. The font design work and
technical implementation is being undertaken by Dalton Maag. The
typeface is sans-serif, uses OpenType features and is manually
hinted for clarity on desktop and mobile computing screens. The
scope of the Ubuntu Font Family includes all the languages used
by the various Ubuntu users around the world in tune with
Ubuntu's philosophy which states that every user should be able
to use their software in the language of their choice. The
project is ongoing, and we expect the family will be extended to
cover many written languages in the coming years."
(Rg, It, Bd, BdIt, Lt, LtIt, Md, MdIt) (LP: #690590)
* (Production) Pixel per em indicator added at U+F000 (Lt, LtIt, Md,
MdIt) (LP: #615787)
* (Production) Version number indicator added at U+EFFD (Lt, LtIt, Md,
MdIt) (LP: #640623)
* (Production) fstype bit set to 0 - Editable (Lt, LtIt, Md, MdIt)
(LP: #648406)
* (Production) Localisation of name table has been removed because
of problems with Mac OS/X interpretation of localisation. DM
(LP: #730785)
* (Hinting) Regular '?' dot non-circular (has incorrect control
value). (LP: #654336)
* (Hinting) Too much space after latin capital 'G' in 13pt
regular. Now reduced. (LP: #683437)
* (Hinting) Balance Indian Rupee at 18,19pt (LP: #662177)
* (Hinting) Make Regular '£' less ambiguous at 13-15 ppm (LP: #685562)
* (Hinting) Regular capital 'W' made symmetrical at 31 ppem (LP: #686168)

Changed in ubuntu-font-family:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers