Style: Latin ƒ (U+0192) should be straight not oblique slanted in Regular

Bug #670768 reported by Denis Moyogo Jacquerye on 2010-11-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Font Family
Medium
Unassigned

Bug Description

ƒ U+0192 should not be slanted in Regular. It is used in a straight form as an alphabet letter in the Ewe orthography and is a letter in the African Reference alphabet so other languages could use it.

If users want to use it for the florin symbol, they could slant it by using Italics.
Users who want to use it in a straight form just can't right now.

Paul Sladen (sladen) on 2010-11-04
summary: - ƒ U+0192 should not be slanted
+ Style: Latin ƒ (U+0192) should be straight not oblique slanted in
+ Regular
Paul Sladen (sladen) wrote :

I don't know that there is a clear, good answer here; in the Unicode charts, U+0192 (LATIN SMALL LETTER F WITH HOOK) is shown with an oblique angle:

  http://unicode.org/charts/PDF/U0180.pdf

although interestingly, the corresponding capital letter (U+0191) is shown straight.

tags: added: uff-latin uff-latin-extended-b uff-style
Changed in ubuntu-font-family:
importance: Undecided → Medium
milestone: none → 1.00
status: New → Triaged

Unicode does not list African languages - specifically Ewe, as being applicable to U+0192.

Denis, what is the status with the Unicode Consortium in regard to specific design requirements of characters for African languages? Are they looking at adding these African specific designs into Unicode?

Denis Moyogo Jacquerye (moyogo) wrote :

OK, I'll try to answer all the issues:

1. "in the Unicode charts, U+0192 (LATIN SMALL LETTER F WITH HOOK) is shown with an oblique angle"

In short, the glyphs used in the charts are not necessarily correct.

See http://unicode.org/standard/principles.html#Interpreting_Characters
"The Unicode Standard does not define glyph images. The standard defines how characters are interpreted, not how glyphs are rendered. The software or hardware-rendering engine of a computer is responsible for the appearance of the characters on the screen. The Unicode Standard does not specify the size, shape, nor style of on-screen characters."

Also read carefully the "Fonts" paragraph in http://unicode.org/charts/PDF/U0180.pdf
"The shapes of the reference glyphs used in these code charts are not prescriptive. Considerable variation is to be
expected in actual fonts. The particular fonts used in these charts were provided to the Unicode Consortium by a number of different font designers, who own the rights to the fonts."

Finally see the same charts in Unicode 5.0 http://www.unicode.org/charts/PDF/Unicode-5.0/U50-0180.pdf
The small letter f with hook is straight, it's just a different font than in the 6.0 charts.

2. "Unicode does not list African languages - specifically Ewe, as being applicable to U+0192."
Ewe uses U+0192.

See http://books.google.fr/books?id=a9v9gKCpFQwC&pg=PR6&#v=onepage&q&f=false for use of U+0192 and U+0191 in Ewe orthography, or at leasy glyph that match the characters descriptions.

You can find a few Ewe samples using U+0192:
http://en.wikipedia.org/wiki/Ewe_language
http://www.panafril10n.org/wikidoc/pmwiki.php/PanAfrLoc/Gbe
http://dictionary.kasahorow.com/all/ee
http://www.omniglot.com/babel/ewe.php

3. "What is the status with the Unicode Consortium in regard to specific design requirements of characters for African languages? Are they looking at adding these African specific designs into Unicode?"

In short, the status is that this is the correct character for the straight letter f with hook used in Ewe orthography, and it is the correct character for the historical florin currency symbol.

See http://unicode.org/alloc/nonapprovals.html
There's a proposal to disunify U+0192 into a florin currency symbol and a small letter f with hook.
The proposal was rejected because of existing data and implementations using it for both, and the fact that the florin currency symbol is only there for historical purposes nowdays. So we can agree this character is mainly a lowercase of U+0191 LATIN CAPITAL LETTER F WITH HOOK.

The character category is "Letter, Lowercase" not "Symbol, Currency".

See also http://www.pentzlin.com/Variation-Sequences-Latin-Cyrillic.pdf where the issue is given as a reason for both straight and oblique glyphs with variation sequences.

Denis, thank you for the research.

Paul, one other listed use of U+0192 is that of 'folder indetifier' in computing. Is this still relevent and if so would an upright version of this character be acceptable to the computing community? Computing people could use the italic version but then there may not always be an italic version available.

Paul Sladen (sladen) wrote :

Malcolm: Yes, I remember the use of the f-with-hook on Apple Macs during the Mac OS 7 era (15 years ago) but it is several years since I remember really seeing it in use (those with modern OS X Macs may be able to correct me). I think it /may/ have had an italic representation on those machines.

Speaking to a Dutch friend about their memories of the Dutch Guilder (gone since 2002 with the coming of the Euro), upright was perfectly acceptable, but it tended to be italic [especially] when handwritten for speed, up to the point that it could sometimes be nearly 'S' shaped.

It's entirely possible that with those two (now historical) uses that the graph might cross whereby the primary future use is going to be for written Ewe... if this is indeed the case, the decision becomes far more clear cut (and if going to an upright f-with-hook, then the italic is still available in the italics).

I regard this as another codepoint reuse issue in Unicode - the florin
should have been given its own codepoint in the currency symbols range
rather than reuse the superficially similar f-with-hook.

The vast majority of existing fonts have an italic glyph mapped to
U+0192, because that was the usual form of the florin character when
these fonts were designed, and the designer was intending compatibility
with pre-Unicode encodings which featured the florin character. I think
the way forward has to be to treat U+0192 as an f-with-hook, not as a
florin.

Having said that, the argument that if you need a clear florin character
you can use the italic font is not quite realistic. In many cases the
user won't have any control over the styling of the text that they are
seeing, and the creator of the text won't know they need to style the
character.

Dave

Shiraaz Gabru (shiraaz) on 2010-12-22
Changed in ubuntu-font-family:
milestone: 1.00 → 0.71
Shiraaz Gabru (shiraaz) on 2010-12-22
Changed in ubuntu-font-family:
status: Triaged → Fix Committed
Shiraaz Gabru (shiraaz) on 2010-12-22
Changed in ubuntu-font-family:
status: Fix Committed → In Progress
Shiraaz Gabru (shiraaz) on 2011-02-16
Changed in ubuntu-font-family:
status: In Progress → Fix Committed
Paul Sladen (sladen) wrote :

This a new upstream version of the Ubuntu Font Family. In addition to
the extensive bug fixes it doubles the number of .ttfs files, from four
to eight with the inclusion of Light, Medium and italics.

Upstream changelog:

2010-03-08 (Paul Sladen) Ubuntu Font Family version 0.71.2

* (Production) Adjust Medium WeightClass to 500 (Md, MdIt) (LP:
#730912)

2010-03-07 (Paul Sladen) Ubuntu Font Family version 0.71.1

* (Design) Add Capitalised version of glyphs and kern. (Lt, LtIt,
Md, MdIt) DM (LP: #677446)
* (Design) Re-space and tighen Regular and Italic by amount specified
by Mark Shuttleworth (minus 4 FUnits). (Rg, It) (LP: #677149)
* (Design) Design: Latin (U+0192) made straight more like l/c f with
tail (LP: #670768)
* (Design) (U+01B3) should have hook on right, as the lowercase
(U+01B4) (LP: #681026)
* (Design) Tail of Light Italic germandbls, longs and lowercase 'f'
to match Italic/BoldItalic (LP: #623925)
* (Production) Update <case> feature (Lt, LtIt, Md, MdIt). DM
(LP: #676538, #676539)
* (Production) Remove Bulgarian locl feature for Italics. (LP: #708578)
* (Production) Update Description information with new string:
"The Ubuntu Font Family are libre fonts funded by Canonical Ltd
on behalf of the Ubuntu project. The font design work and
technical implementation is being undertaken by Dalton Maag. The
typeface is sans-serif, uses OpenType features and is manually
hinted for clarity on desktop and mobile computing screens. The
scope of the Ubuntu Font Family includes all the languages used
by the various Ubuntu users around the world in tune with
Ubuntu's philosophy which states that every user should be able
to use their software in the language of their choice. The
project is ongoing, and we expect the family will be extended to
cover many written languages in the coming years."
(Rg, It, Bd, BdIt, Lt, LtIt, Md, MdIt) (LP: #690590)
* (Production) Pixel per em indicator added at U+F000 (Lt, LtIt, Md,
MdIt) (LP: #615787)
* (Production) Version number indicator added at U+EFFD (Lt, LtIt, Md,
MdIt) (LP: #640623)
* (Production) fstype bit set to 0 - Editable (Lt, LtIt, Md, MdIt)
(LP: #648406)
* (Production) Localisation of name table has been removed because
of problems with Mac OS/X interpretation of localisation. DM
(LP: #730785)
* (Hinting) Regular '?' dot non-circular (has incorrect control
value). (LP: #654336)
* (Hinting) Too much space after latin capital 'G' in 13pt
regular. Now reduced. (LP: #683437)
* (Hinting) Balance Indian Rupee at 18,19pt (LP: #662177)
* (Hinting) Make Regular '£' less ambiguous at 13-15 ppm (LP: #685562)
* (Hinting) Regular capital 'W' made symmetrical at 31 ppem (LP: #686168)

Changed in ubuntu-font-family:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers