Hinting: '?' dot non-circular (distortion, copy hinting from '!')

Bug #654336 reported by adoa on 2010-10-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Font Family
Medium
Malcolm Wooden

Bug Description

Rendered in 44pt Regular

Sample Glyphs:

!?

Description:

I have the impression, that the dot under the question mark is not consistently hinted, which only matters for sizes where the dot is bigger than a pixel.

UA String:

Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.2.10) Gecko/20100915 Ubuntu/10.04 (lucid) Firefox/3.6.10

adoa (adoa) wrote :
Paul Sladen (sladen) wrote :

The screen shot shown is with full (manual hinting), the dot forming the base of the ? question mark is getting squeezed up and distorted into a non-circular entity (height not equal to width).

The glyph in question is not a composite (although perhaps if could be made into one), so hinting is possibly not getting applied automatically.

summary: - Hinting: apply hinting from dot of ‘!’ to dot of ‘?’
+ Hinting: '?' dot non-circular (distortion, copy hinting from '!')
Changed in ubuntu-font-family:
importance: Undecided → Medium
milestone: none → 1.00
status: New → Confirmed
tags: added: uff-easy-fix uff-hinting uff-punctuation
Paul Sladen (sladen) on 2010-12-13
Changed in ubuntu-font-family:
milestone: 1.00 → 0.71
Shiraaz Gabru (shiraaz) on 2010-12-22
Changed in ubuntu-font-family:
status: Confirmed → Fix Committed
Shiraaz Gabru (shiraaz) on 2010-12-22
Changed in ubuntu-font-family:
status: Fix Committed → In Progress
Shiraaz Gabru (shiraaz) on 2011-02-16
Changed in ubuntu-font-family:
status: In Progress → Fix Committed
assignee: nobody → Malcolm Wooden (malcolm-daltonmaag)
Paul Sladen (sladen) wrote :

This a new upstream version of the Ubuntu Font Family. In addition to
the extensive bug fixes it doubles the number of .ttfs files, from four
to eight with the inclusion of Light, Medium and italics.

Upstream changelog:

2010-03-08 (Paul Sladen) Ubuntu Font Family version 0.71.2

* (Production) Adjust Medium WeightClass to 500 (Md, MdIt) (LP:
#730912)

2010-03-07 (Paul Sladen) Ubuntu Font Family version 0.71.1

* (Design) Add Capitalised version of glyphs and kern. (Lt, LtIt,
Md, MdIt) DM (LP: #677446)
* (Design) Re-space and tighen Regular and Italic by amount specified
by Mark Shuttleworth (minus 4 FUnits). (Rg, It) (LP: #677149)
* (Design) Design: Latin (U+0192) made straight more like l/c f with
tail (LP: #670768)
* (Design) (U+01B3) should have hook on right, as the lowercase
(U+01B4) (LP: #681026)
* (Design) Tail of Light Italic germandbls, longs and lowercase 'f'
to match Italic/BoldItalic (LP: #623925)
* (Production) Update <case> feature (Lt, LtIt, Md, MdIt). DM
(LP: #676538, #676539)
* (Production) Remove Bulgarian locl feature for Italics. (LP: #708578)
* (Production) Update Description information with new string:
"The Ubuntu Font Family are libre fonts funded by Canonical Ltd
on behalf of the Ubuntu project. The font design work and
technical implementation is being undertaken by Dalton Maag. The
typeface is sans-serif, uses OpenType features and is manually
hinted for clarity on desktop and mobile computing screens. The
scope of the Ubuntu Font Family includes all the languages used
by the various Ubuntu users around the world in tune with
Ubuntu's philosophy which states that every user should be able
to use their software in the language of their choice. The
project is ongoing, and we expect the family will be extended to
cover many written languages in the coming years."
(Rg, It, Bd, BdIt, Lt, LtIt, Md, MdIt) (LP: #690590)
* (Production) Pixel per em indicator added at U+F000 (Lt, LtIt, Md,
MdIt) (LP: #615787)
* (Production) Version number indicator added at U+EFFD (Lt, LtIt, Md,
MdIt) (LP: #640623)
* (Production) fstype bit set to 0 - Editable (Lt, LtIt, Md, MdIt)
(LP: #648406)
* (Production) Localisation of name table has been removed because
of problems with Mac OS/X interpretation of localisation. DM
(LP: #730785)
* (Hinting) Regular '?' dot non-circular (has incorrect control
value). (LP: #654336)
* (Hinting) Too much space after latin capital 'G' in 13pt
regular. Now reduced. (LP: #683437)
* (Hinting) Balance Indian Rupee at 18,19pt (LP: #662177)
* (Hinting) Make Regular '£' less ambiguous at 13-15 ppm (LP: #685562)
* (Hinting) Regular capital 'W' made symmetrical at 31 ppem (LP: #686168)

Changed in ubuntu-font-family:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers