Hinting: Cyrillic small "т" stem off-centre at 10pt

Bug #650636 reported by Serge Matveenko on 2010-09-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Font Family
Medium
Unassigned

Bug Description

Rendered in 10pt Regular

Sample Glyphs:

т

Description:

The "т" Cyrillic letter looks not centered.

UA String:

Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/534.9 (KHTML, like Gecko) Ubuntu/10.04 Chromium/7.0.535.0 Chrome/7.0.535.0 Safari/534.9

Serge Matveenko (lig) wrote :

Automatic Screenshot

Serge Matveenko (lig) wrote :
Paul Sladen (sladen) wrote :

The stem is off-center, although this may not be solvable. If the width of the character is 4 pixels at that particular size, the stem cannot be placed exactly in the middle; it must be placed on either the second, or third pixel across.

summary: - Cyrillic small "т" does not look very good
+ Hinting: Cyrillic small "т" stem off-centre at 10pt
Changed in ubuntu-font-family:
importance: Undecided → Medium
milestone: none → 1.00
status: New → Confirmed
tags: added: uff-cryillic uff-hinting
Paul Sladen (sladen) wrote :

Similar to bug #623990, but horizontal centreing, rather than vertical.

In this particular case, the "т" is 6 pixels wide. To fix the problem, it should be made 5 pixels wide. Similarly, if it was 4px wide, it'd be better to make it 3px and maintain symmetry. However, I can not reproduce this problem myself.

Serge Matveenko (lig) wrote :

Looks like this one is fixed already.

Matthew Paul Thomas (mpt) wrote :

Verified fixed in 0.80. A belated thanks for following up, Serge.

Changed in ubuntu-font-family:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers