Invalid use of palette apparent with new SDK

Bug #1554621 reported by Michał Sawicz on 2016-03-08
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Pat McGowan
Tagger
Undecided
Michael Zanetti
Telegram app
High
Jin
Ubuntu Clock App
High
Ken VanDine
Ubuntu File Manager App
High
Unassigned
Ubuntu Music App
High
Ken VanDine
address-book-app
High
Unassigned
camera-app (Ubuntu)
Undecided
Unassigned
content-hub (Ubuntu)
High
Ken VanDine
messaging-app (Ubuntu)
High
Unassigned
ubuntu-system-settings (Ubuntu)
High
Ken VanDine

Bug Description

The content hub uses the wrong palette values for text (which becomes apparent with new UITK), see screenshot.

The new UITK is landing here: https://requests.ci-train.ubuntu.com/#/ticket/905

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: content-hub 0.1+15.04.20160129.1-0ubuntu1 [origin: LP-PPA-ci-train-ppa-service-stable-phone-overlay]
Uname: Linux 3.4.67 armv7l
ApportVersion: 2.17.2-0ubuntu1.3touch1
Architecture: armhf
Date: Tue Mar 8 18:00:22 2016
InstallationDate: Installed on 2016-03-08 (0 days ago)
InstallationMedia: Ubuntu 15.04 - armhf (20160308-020304)
SourcePackage: content-hub
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Michał Sawicz (saviq) wrote :
Changed in canonical-devices-system-image:
assignee: nobody → Bill Filler (bfiller)
milestone: none → ww08-2016
tags: added: ota10-sdk
Changed in canonical-devices-system-image:
status: New → Confirmed
Bill Filler (bfiller) on 2016-03-09
Changed in content-hub (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → High
Jean-Baptiste Lallement (jibel) wrote :

I think it is fixed with last release of the toolkit. Please reopen if it is not.

Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
Jean-Baptiste Lallement (jibel) wrote :

I'm reopening, it is reproducible with tagger, when you share a QR code.

Changed in canonical-devices-system-image:
status: Fix Committed → Confirmed
importance: Undecided → High
tags: added: regression-proposed
summary: - Invalid use of palette apparent with new SDK
+ Invalid use of palette apparent with new SDK in content-hub
Changed in content-hub (Ubuntu):
status: New → Invalid
Changed in telegram-app:
importance: Undecided → High
status: New → Confirmed
Changed in ubuntu-clock-app:
importance: Undecided → High
status: New → Confirmed
Changed in ubuntu-filemanager-app:
importance: Undecided → High
status: New → Confirmed
Changed in address-book-app:
importance: Undecided → High
status: New → Confirmed
Changed in camera-app:
importance: Undecided → High
status: New → Confirmed
Changed in messaging-app:
importance: Undecided → High
status: New → Confirmed
Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
status: Confirmed → In Progress
Changed in music-app:
importance: Undecided → High
status: New → Confirmed
Changed in ubuntu-clock-app:
assignee: nobody → Ken VanDine (ken-vandine)
milestone: none → 3.8
status: Confirmed → In Progress
Andrew Hayzen (ahayzen) on 2016-03-16
Changed in music-app:
assignee: nobody → Ken VanDine (ken-vandine)
milestone: none → ota10
status: Confirmed → In Progress
Changed in camera-app (Ubuntu):
status: New → Fix Released
no longer affects: camera-app
summary: - Invalid use of palette apparent with new SDK in content-hub
+ Invalid use of palette apparent with new SDK
Changed in ubuntu-clock-app:
status: In Progress → Fix Committed

Fix committed into lp:music-app at revision 994, scheduled for release in music-app, milestone ota10

Changed in music-app:
status: In Progress → Fix Committed

Fix committed into lp:ubuntu-filemanager-app at revision None, scheduled for release in ubuntu-filemanager-app, milestone alpha-1

Changed in ubuntu-filemanager-app:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+16.04.20160325-0ubuntu1

---------------
ubuntu-system-settings (0.3+16.04.20160325-0ubuntu1) xenial; urgency=medium

  * Bump Ubuntu.Content import to 1.3 to prevent mixed version imports
    (LP: #1554621)
  * Only include the "any data connection" item when there is a modem
    present. (LP: #1560884)
  * Play haptic feedback when selecting About and Reset from the main
    view. (LP: #1560571)
  * Removed unnecessary mouse-plugin, it was intended for use with
    dynamic visibility, which is no longer needed.

 -- Ken VanDine <email address hidden> Fri, 25 Mar 2016 20:53:47 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
Bill Filler (bfiller) on 2016-03-28
Changed in address-book-app:
status: Confirmed → Fix Committed
Changed in messaging-app (Ubuntu):
importance: Undecided → High
status: New → Fix Committed
no longer affects: messaging-app
Changed in telegram-app:
assignee: nobody → Jin (jin.cth)
Changed in canonical-devices-system-image:
assignee: Bill Filler (bfiller) → Yuan-Chen Cheng (ycheng-twn)
status: Confirmed → In Progress
Jin (jindallo) on 2016-03-29
Changed in telegram-app:
status: Confirmed → Fix Committed
Jin (jindallo) on 2016-04-01
Changed in telegram-app:
milestone: none → m28
Changed in tagger:
assignee: nobody → Michael Zanetti (mzanetti)
status: New → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Jin (jindallo) on 2016-04-08
Changed in telegram-app:
status: Fix Committed → Fix Released
Yuan-Chen Cheng (ycheng-twn) wrote :

all work in team belongs to me are fix released. guess we can close this one ?

Changed in canonical-devices-system-image:
assignee: Yuan-Chen Cheng (ycheng-twn) → Pat McGowan (pat-mcgowan)
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Changed in music-app:
status: Fix Committed → Fix Released
Changed in address-book-app:
status: Fix Committed → Fix Released
Changed in ubuntu-clock-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers