Purple overflow panel in SuruGradient theme

Bug #1386208 reported by David Planella on 2014-10-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu File Manager App
Low
David Planella
Ubuntu UI Toolkit
Fix Released
High
Tim Peeters
Ubuntu UX
Low
Jouni Helminen
ubuntu-ui-toolkit (Ubuntu)
Undecided
Tim Peeters
Vivid
Undecided
Unassigned
ubuntu-ui-toolkit (Ubuntu RTM)
Undecided
Unassigned

Bug Description

While testing the new header on trunk, I noticed that the actions on the header are purple. They should be the same colour as the rest of the app.

Related branches

David Planella (dpm) wrote :
tags: added: bitesize
Zsombor Egri (zsombi) wrote :

This is a toolkit bug we must address in Palette.

Changed in ubuntu-ui-toolkit:
status: New → Confirmed
assignee: nobody → Tim Peeters (tpeeters)
importance: Undecided → Low
Tim Peeters (tpeeters) on 2014-10-28
summary: - Purple actions on the header
+ Purple overflow panel in SuruDark theme
tags: added: header palette
summary: - Purple overflow panel in SuruDark theme
+ Purple overflow panel in SuruGradient theme
Tim Peeters (tpeeters) wrote :

is the solution to never use the SuruGradient theme?

Zsombor Egri (zsombi) wrote :

Looking to the attached image seems the application has a gradient background by having a footer colour specified different from background colour. This means that the theme autoselection is choosing SuruGradient theme, which is a deprecated one not maintained at all.

So while this gets fixed in the toolkit, apps using gradients as background can force the theme loaded to be the SuruDark by adding the following block to MainView:

Component.onCompleted: Theme.name = "Ubuntu.Components.Themes.SuruDark"

Zsombor Egri (zsombi) on 2014-10-28
Changed in ubuntu-ui-toolkit:
importance: Low → High
David Planella (dpm) wrote :

So after having tried the workaround and having talked to Zsombor about why it fails, we'll have to go for setting no gradient until the toolkit bug is fixed.

Changed in ubuntu-filemanager-app:
assignee: nobody → David Planella (dpm)
status: Triaged → In Progress

Fix committed into lp:ubuntu-filemanager-app at revision 315, scheduled for release in ubuntu-filemanager-app, milestone alpha-1

Changed in ubuntu-filemanager-app:
status: In Progress → Fix Committed
Tim Peeters (tpeeters) wrote :

Discussed with Jounih, and we will make the default panel overflow 10% lighter than the header background color, and eventually make the panel color configurable (probably using a style).

Tim Peeters (tpeeters) on 2014-10-29
Changed in ubuntu-ui-toolkit:
status: Confirmed → In Progress
Tim Peeters (tpeeters) wrote :

Do these colors (Qt.lighter(headerColor), 1.1) make sense for the panels?

Tim Peeters (tpeeters) wrote :

Added ubuntu-ux project because they are involved in the discussion what the actual panel color should be.

Tim Peeters (tpeeters) wrote :

15:29:53 < jounih> timp: https://launchpadlibrarian.net/188995788/Screenshot%20from%202014-11-03%2015%3A14%3A55.png looks ok to me

I'm proceeding with these colors.

Changed in ubuntu-ux:
status: New → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit/staging at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Committed
Zoltan Balogh (bzoltan) on 2014-11-17
no longer affects: ubuntu-ui-toolkit (Ubuntu)
Zoltan Balogh (bzoltan) on 2014-11-21
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
Changed in ubuntu-ux:
assignee: nobody → Jouni Helminen (jounihelminen)
Changed in ubuntu-ux:
importance: Undecided → Low
Tim Peeters (tpeeters) on 2015-01-05
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Tim Peeters (tpeeters)
status: New → Fix Released
Niklas Wenzel (nikwen) on 2015-02-27
Changed in ubuntu-filemanager-app:
status: Fix Committed → Fix Released
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers