Viewing the root file system ("/") shows no files

Bug #1266114 reported by Victor Thompson
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu File Manager App
Fix Released
Medium
Unassigned
initramfs-tools (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

When navigating to the root file system the application shows no files on the device. Note, that this does work as expected on the desktop. The permissions on the files/folders in / are all 755 so the folders should be visible to the phablet user:

drwxr-xr-x 2 root root 4096 Jan 3 15:27 bin/

I would expect to be able to see the files/folders in "/" using the Filemanager.

Revision history for this message
Victor Thompson (vthompson) wrote :
Revision history for this message
Victor Thompson (vthompson) wrote :

Note, this seems to only affect the root directory. The user can go to /bin or some other directory with similar permissions and view the files that exist there.

Revision history for this message
Sam Bull (dreamsorcerer) wrote :

I remember something similar in the terminal app (obviously can't check as we still can't run any commands). Something like you couldn't cd into / or ls it. So, this might be something in the app confinement affecting all apps?

Changed in ubuntu-filemanager-app:
status: New → Confirmed
Revision history for this message
Victor Thompson (vthompson) wrote :

I have a terminal app work around for the "Enter and Backspace" bug, lp:1257791. And it seems you are right--there does appear to be a permissions issue. See the attached.

Revision history for this message
Victor Thompson (vthompson) wrote :

Also, if you SSH to the device and "ls /" the phablet use is allowed to read the contents.

Revision history for this message
Carlos Jose Mazieri (carlos-mazieri) wrote :

It works when running from QtCreator (I installed the plugin in the default directory)

Command launched by QtCreator on device:
/usr/lib/arm-linux-gnueabihf/qt5/bin/qmlscene /home/phablet/dev_tmp/ubuntu-filemanager-app/filemanager.qml --desktop_file_hint=/home/phablet/.local/share/applications/filemanager.desktop

The same command also works and reads "/" when launched from a terminal.

But I could not use the same command to start the the click filemanager.

It looks like this bug is related to the plaftform.

Revision history for this message
Alan Pope 🍺🐧🐱 🦄 (popey) wrote :

It works in the emulator...

Changed in ubuntu-filemanager-app:
importance: Undecided → Medium
Revision history for this message
Victor Thompson (vthompson) wrote :

This appears to have been fixed in a recent image. Utopic r53 no longer sees this issue. Marking as fixed until someone can confirm a fix was released.

Changed in ubuntu-filemanager-app:
status: Confirmed → Fix Committed
Revision history for this message
Brendan Donegan (brendan-donegan) wrote :

Definitely fixed - probably for a while

Changed in ubuntu-filemanager-app:
status: Fix Committed → Fix Released
Sam Bull (dreamsorcerer)
Changed in initramfs-tools (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers