test_filemanager.TestFolderListPage.test_open_directory

Bug #1256856 reported by Alan Pope 🍺🐧🐱 πŸ¦„ on 2013-12-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu File Manager App
Critical
Victor Thompson

Bug Description

Test test_filemanager.TestFolderListPage.test_open_directory fails on #40 on mako

http://ci.ubuntu.com/smokeng/trusty/touch/mako/40:20131130:20131129/5200/ubuntu-filemanager-app-autopilot/542039/

Related branches

Changed in ubuntu-filemanager-app:
status: New → Fix Released
Leo Arias (elopio) wrote :

It failed again on utopic#75.
http://ci.ubuntu.com/smokeng/utopic/touch/mako/75:20140609:20140530/8487/filemanager/1235390/

From the test log, it seems that the folder was not opened.

testtools.matchers._impl.MismatchError: After 10.0 seconds test failed: '/tmp/tmpnbrvrscb/tmpfmm_x8gu9s' != '/tmp/tmpnbrvrscb'

Changed in ubuntu-filemanager-app:
status: Fix Released → New
Leo Arias (elopio) wrote :

I can't reproduce it.

Changed in ubuntu-filemanager-app:
status: New → Incomplete
assignee: nobody → Leo Arias (elopio)
importance: Undecided → Medium
tags: added: qa-broken-test qa-daily-testing
Changed in ubuntu-filemanager-app:
importance: Medium → Critical
Victor Thompson (vthompson) wrote :

I think this goes hand in hand with the other flakey tests. I think starting and stoping maliit-server, aka the OSK, seems to be playing a large role in this. I did two runs of the complete tests and have thus far only had one fauilure with "test_copy_file"

Changed in ubuntu-filemanager-app:
assignee: Leo Arias (elopio) → Victor Thompson (vthompson)

Fix committed into lp:ubuntu-filemanager-app at revision 205, scheduled for release in ubuntu-filemanager-app, milestone alpha-1

Changed in ubuntu-filemanager-app:
status: Incomplete → Fix Committed
Changed in ubuntu-filemanager-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers