Autopilot sometimes fail to open the toolbar

Bug #1235060 reported by Leo Arias on 2013-10-04
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu File Manager App
Ubuntu UI Toolkit
Won't Fix
ubuntu-ui-toolkit (Ubuntu)

Bug Description

After some more weirds error by jenkins, we noticed that the failed tests tend to have in their log that they failed to open the toolbar.

I ran the toolbar test around 300 times on saucy with no error. Then I ran them on my mako phone and it failed like 1 out of 30 times. The failure is really weird. I set a breakpoint when the toolbar failed to open and I got something like this:

02:54:15.621 DEBUG _uinput:365 - Dragging from 384,1279 to 384,1218

(didn't open)

> /home/phablet/ubuntu-ui-toolkit/tests/autopilot/ubuntuuitoolkit/
-> return toolbar
(Pdb) self.pointing_device.drag(384, 1279, 384, 1218)
02:54:45.867 DEBUG _uinput:365 - Dragging from 384,1279 to 384,1218

(didn't open)

(Pdb) self.pointing_device.drag(384, 1279, 384, 1218)
02:54:48.701 DEBUG _uinput:365 - Dragging from 384,1279 to 384,1218

(didn't open)

(Pdb) self.pointing_device.drag(384, 1279, 384, 1218)
02:54:50.672 DEBUG _uinput:365 - Dragging from 384,1279 to 384,1218

(didn't open)

(Pdb) self.pointing_device.drag(384, 1279, 384, 1218)
02:54:52.139 DEBUG _uinput:365 - Dragging from 384,1279 to 384,1218


So, there's something non-deterministic happening. I repeated the same action a number of times, until it finally worked. And the required number of times was never the same.
The problem might be on the toolkit, on unity or on autopilot.

The test is deterministic, what is flaky is the environment.

Related branches

Leo Arias (elopio) on 2013-10-04
description: updated
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
Leo Arias (elopio) wrote :

I found a way to improve this, and now the failure is a lot less often on my device, and also the code looks more correct.

Still, the real problem is open and it will keep biting us at random times.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+14.04.20131105.1-0ubuntu1

ubuntu-ui-toolkit (0.1.46+14.04.20131105.1-0ubuntu1) trusty; urgency=low

  [ Albert Astals ]
  * Minor optimzations Add const & to foreach to save copies of
    "complex" types Remove initializations of QStrings to "" since they
    do nothing Return QString instead of "" since its faster Pass
    "complex" types as const & instead of copy to functions Not an
    optimization: Added const qualifier to two functions .

  [ Lars Uebernickel ]
  * Remove GIconProvider Use urls for file and data icons and the theme
    image provider (image://theme/) for themed icons.

  [ Kaleo ]
  * [visual design] Updated tabs chevron asset.

  [ Christian Dywan ]
  * Install translations for UI toolkit and gallery. (LP: #1239627)
  * Support checkbox used with an action.
  * Install autopilot modules in qmake not debian packaging.
  * Drop the $$ from system calls where output isn't needed.
  * Look for locale folder as per XDG basedir spec and rewrite test The
    new test case covers the whole range of changing languages, checking
    the strings from both QML and C++ and binding to a folder. (LP:
    #1175726, #1233071)
  * Define window within OrientationHelper to avoid a race condition.
    (LP: #1239760)

  [ Zsombor Egri ]
  * Support for taking themes from XDG_DATA_DIRS as well as from
    ~/.local/share. These paths are also added as import paths.
    UBUNTU_UI_TOOLKIT_THEMES_PATH overrules these import paths, and can
    have more than one path specified, each separated with column. (LP:
  * Warnings treated as errors in all types of builds (debug or
    release). (LP: #1246290)
  * Introducing topmostItem property to drive whether InverseMouseArea
    should filter sensingArea events or to stay in the normal z-
    order/stack order of its parent. (LP: #1240460)

  [ Leo Arias ]
  * Added the go back method to the autopilot emulators. (LP: #1239751)
  * On the autopilot emulator, drag the toolbar to its full height. (LP:
  * Initially show toolbar, but automatically hide after timeout. (LP:
  * Added the change_state method to the CheckBox autopilot emulator.
    Cleaned up the autopilot gallery toggles tests.
  * Added the objectNames to the ComposerSheet buttons. (LP: #1244518)

  [ tpeeters ]
  * Update CrossFadeImage API so that sourceSize can be set by the
    applications. CHANGED in CrossFadeImage: readonly property size
    sourceSize TO property size sourceSize. (LP: #1227783)
  * Initially show toolbar, but automatically hide after timeout. (LP:
  * Put tab bar in selection mode when apps are launched. (LP: #1223597)
  * Close tabbar and toolbar when user interacts with app contents. (LP:

  [ Nicolas d'Offay ]
  * Added multiSelection bool and supporting code to OptionSelector and
    ItemSelector. This turns either component into a multiple choice
    selector. Fixed linked bugs. (LP: #1231936)

  [ Renato Araujo Oliveira Filho ]
  * Implemented emulator for swipe to remove. (LP: #1236464)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 820
 -- Ubu...


Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
Leo Arias (elopio) on 2014-06-10
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Confirmed
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Released → Confirmed
David Planella (dpm) on 2014-10-08
Changed in ubuntu-filemanager-app:
status: New → Incomplete
Zoltan Balogh (bzoltan) on 2014-11-14
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → Won't Fix
Changed in ubuntu-ui-toolkit:
status: Confirmed → Won't Fix
Rolf Leggewie (r0lf) wrote :

saucy has seen the end of its life and is no longer receiving any updates. Marking the saucy task for this ticket as "Won't Fix".

Changed in ubuntu-ui-toolkit (Ubuntu Saucy):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers