YAML parsing error during filemanager-app tests

Bug #1208494 reported by Para Siva on 2013-08-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu File Manager App
Undecided
Nicholas Skaggs
touch-preview-images
Fix Released
Undecided
Unassigned

Bug Description

The following error is being reported in all the filemanager-app tests:

Aug 2 20:31:42 ubuntu-phablet utah: YAML parsing error at line 1, column 27: /var/lib/utah/testsuites/ubuntu-filemanager-app-autopilot/ubuntu-filemanager-app-autopilot/__init__.py", line 16, in <module>/tc_control
Aug 2 20:31:43 ubuntu-phablet utah: completed /etc/utah/autorun/01_run-utah rc=6
Aug 2 20:31:43 ubuntu-phablet utah: exiting autorun due to failure
Aug 2 20:31:43 ubuntu-phablet kernel: [ 54.515243] init: run_utah main process (3490) terminated with status 1

The impacted jobs are:
http://reports.qa.ubuntu.com/smokeng/saucy/image/3366/ubuntu-filemanager-app-autopilot/
http://reports.qa.ubuntu.com/smokeng/saucy/image/3365/ubuntu-filemanager-app-autopilot/
http://reports.qa.ubuntu.com/smokeng/saucy/image/3364/ubuntu-filemanager-app-autopilot/

Related branches

Para Siva (psivaa) wrote :
Andy Doan (doanac) wrote :

This is a bug in the ubuntu-filemanager-app's testing. The issue is the test discovery command is failing:

root@ubuntu-phablet:/# autopilot list ubuntu_filemanager_app
Loading tests from: /usr/lib/python2.7/dist-packages

Failed to import test module: ubuntu_filemanager_app.tests.test_filemanager
Traceback (most recent call last):
  File "/usr/lib/python2.7/unittest/loader.py", line 252, in _find_tests
    module = self._get_module_from_name(name)
  File "/usr/lib/python2.7/unittest/loader.py", line 230, in _get_module_from_name
    __import__(name)
  File "/usr/lib/python2.7/dist-packages/ubuntu_filemanager_app/tests/__init__.py", line 16, in <module>
    from ubuntuuitoolkit import emulators as toolkit_emulators
ImportError: No module named ubuntuuitoolkit

    unittest.loader.ModuleImportFailure.ubuntu_filemanager_app.tests.test_filemanager

 1 total tests.

affects: utah → ubuntu-filemanager-app
Paul Larson (pwlars) on 2013-08-06
tags: added: autopilot qa-touch
Nicholas Skaggs (nskaggs) wrote :

This is a dependency issue, working on fixing it now.

Changed in ubuntu-filemanager-app:
assignee: nobody → Nicholas Skaggs (nskaggs)
Changed in ubuntu-filemanager-app:
status: New → Fix Committed

Fix committed into lp:ubuntu-filemanager-app at revision 55, scheduled for release in ubuntu-filemanager-app, milestone alpha-1

Gema Gomez (gema) on 2013-08-07
summary: - utah: YAML parsing error during filemanager-app tests
+ YAML parsing error during filemanager-app tests
David Planella (dpm) on 2013-09-07
Changed in ubuntu-filemanager-app:
status: Fix Committed → Fix Released
Changed in touch-preview-images:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments