Hide the toolbar by default

Bug #1198861 reported by David Planella on 2013-07-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu File Manager App
Medium
Michael Spencer

Bug Description

In order to be consistent with the rest of the apps and with the App Design Guides, the toolbar should be hidden by default and revealed by swiping the bottom edge

http://design.ubuntu.com/apps/building-blocks/toolbar

Related branches

Changed in ubuntu-filemanager-app:
status: New → Confirmed
Changed in ubuntu-filemanager-app:
assignee: nobody → Michael Spencer (mdspencer)
Changed in ubuntu-filemanager-app:
status: Confirmed → In Progress
Arto Jalkanen (ajalkane) wrote :

I'd think it will be mighty annoying to navigate filesystem if you can go up in hierarchy only by swiping the bottom toolbar open each time before going up. This is why I originally on purpose made the toolbar always visible, despite the design guidelines.

If there is an alternative way to go up, or one is proposed, then hiding the toolbar will not matter.

Omer Akram (om26er) wrote :

My suggestion is that the toolbar should not hide immediately(after 5seconds is fine?) if we tap the back item and there is also a 'back' item on the upper level. It might actually make sense to have that implemented inside the UI toolkit (tm)

It might be worth discussing this with the SDK guys if there needs to be
any change in the SDK. For me, the motivation for filing this bug was to
ensure there is consistency throughout the core apps behaviour and that
we're not special-casing it for certain apps.

On Tue, Jul 9, 2013 at 10:26 PM, Omer Akram <email address hidden> wrote:

> My suggestion is that the toolbar should not hide immediately(after
> 5seconds is fine?) if we tap the back item and there is also a 'back'
> item on the upper level. It might actually make sense to have that
> implemented inside the UI toolkit (tm)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> Matching subscriptions: File Manager App Bugmail
> https://bugs.launchpad.net/bugs/1198861
>
> Title:
> Hide the toolbar by default
>
> Status in File Manager application for Ubuntu devices:
> In Progress
>
> Bug description:
> In order to be consistent with the rest of the apps and with the App
> Design Guides, the toolbar should be hidden by default and revealed by
> swiping the bottom edge
>
> http://design.ubuntu.com/apps/building-blocks/toolbar
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu-filemanager-app/+bug/1198861/+subscriptions
>

Arto Jalkanen (ajalkane) wrote :

At yesterdays File Manager app meet, we heard that what to do about this is being discussed in design team. So we'll wait until a proposal emerges.

Leo Arias (elopio) wrote :

I would like to be able to swipe from right to left on the path label in order to go one level up. This would be a hard-to-find feature, though.

David Planella (dpm) on 2013-09-07
Changed in ubuntu-filemanager-app:
importance: Undecided → Medium

Fix committed into lp:ubuntu-filemanager-app at revision 63, scheduled for release in ubuntu-filemanager-app, milestone alpha-1

Changed in ubuntu-filemanager-app:
status: In Progress → Fix Committed
David Planella (dpm) on 2013-10-14
Changed in ubuntu-filemanager-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers