Ubuntu EeePC-optimized Kernel

webcam does not capture image

Reported by Lopo Lencastre de Almeida on 2009-03-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu EeePC Kernel
Undecided
Unassigned

Bug Description

I don't have an eeePC but my notebook is almost the same stuff in it:

- Microsoft Windows® XP Home Portuguese;
- Linux Mint 6 (Felicia) Universal;
- Array.org kernel 2.6.27-8-eeepc (I removed the original Ubuntu one);

- Intel Atom N270 1.60Ghz;
- TFT 10" Wide WSVGA (1024X600);
- 1GB DDR2;
- Intel UMA Share System Memory and Intel 945CMS + ICH7M.
- 160GB SATA;
- LAN 10/100Mb, Wireless 802.11bg (I suspect its the Intel ABG 3945);
- Bluetooth
- 1 VGA;
- 3 USB, 1 RJ45, 1 mic, 1 stereo;
- 4 in 1 Card Reader (SD/MMC/MS/MSpro)
- WebCam 1.3Mpx (this is a BisonCam NB Pro)
- Li-Ion battery, 3 Cells 2200mAh, (max auton. 180min.)
- 260(W) x 180(L) x 19~31.5(H)mm, 1Kg (with battery)

My webcam is recognized as BisonCam NB Pro but it does not capture any image at all and I don't have the possibility to access it via Bios setup (not an option there).

Light show up when using Cheese but nothing is captured.
Cam is recognized in Skype but does not capture in tests and sometimes even frozes Skype.
Screenshots attached.

It works flawlessly in MS Windows XP...

roland schaeling (rschaeling) wrote :

On a eeePC901 with all worked fine under easypeasy.
I updated to 9.04 / netbook remix.

cheese gives no response just stops.
Manual start of cheese in a console gives this information for a bug:

The program 'cheese' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 70 error_code 11 request_code 132 minor_code 19)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Skype sends, receives video, but my own picture is not shown.

i did not try to change the kernel (i am using eeePC-kernel)

roland schaeling (rschaeling) wrote :

Now i gave the linux-image 2.6.28.11.15 a chance - same effect,
so i switched back to linux-image 2.6.27.6.12eeePC0 which has the described effect.
 even without netbook remix no chance.
also try to uninstall cheese and reinstall it - same.

Seems it is really in X

roland schaeling (rschaeling) wrote :

Sorry: I just read in FAQ Webcam that this Bug is known... and they are workin hard on it.
Just had not thought that it is mentioned in a FAQ..
So i will wait till next kernel
Roland

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments