Ubuntu EeePC-optimized Kernel

Low maximum volume on eee 1000

Reported by Sindri on 2008-11-20
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ubuntu EeePC Kernel
Undecided
Adam McDaniel

Bug Description

The maximum volume level seems very low after installing kubuntu (I'm using linux-eeepc 2.6.27.7.8.eeepc0 on a EEE 1000H). The speakers are definitely able to produce a higher volume, they did when I had the original Xandros distro it came with.

Dario Ruellan (druellan) wrote :

Can confirm this on Ubuntu 8.10 and eeePC 1000H. Using Pulseaudio or Alsa the sound plays very low. Using OSS seems fine, but you loose multiapplication sound. On Hardy it worked just fine.

@Sindri did you tried using pavucontrol?

Sindri (sindrit) wrote :

I am not using PulseAudio, just the KDE mixer program.

Dario Ruellan (druellan) wrote :

Aha, as soon as I can backup the entire partition I will try to update Alsa drivers to see if there is any improvement on this issue and the hight CPU usage of Ubuntu 8.10. Sound is the last thing I need to solve to get Intrepid fully supported on my 1000h ;)

sungo (sungo) wrote :

I can confirm this on a 1000HD running intrepid + 2.6.27-8-eeepc. neither pulse nor alsa see the master or front audio channels. they see PCM, LineOut and iSpeaker.

Dario Ruellan (druellan) wrote :

Updated Alsa to 1.0.18a on Intrepid using kernel 2.6.27-8-eeepc and running this script: http://ubuntuforums.org/showthread.php?t=962695

Sound seems a bit loud, but the big deal is the gain on the internal mic: no more hissing backsound, boost control now available and good sound quality on Skype (HUGE quality improve).
Check the attached screen.

The script did not work on the lean kernel 2.6.27-8-eeepc-lean.

Adam, could be possible to upgrade the Intrepid 2.6.27-8-eeepc* to Alsa 1.0.18a on a future revision? The script

Dario Ruellan (druellan) wrote :

Check this thread for a final solution: http://ubuntuforums.org/showthread.php?t=962695&page=10#99

Adam McDaniel (adamrmcd) wrote :

Will have a look into it :)

Changed in ubuntu-eeepc-kernel:
assignee: nobody → adam.mcdaniel
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers