Verify theme works with new nice_menu module version

Bug #710214 reported by Michael Lustfield
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
UD Theme
Fix Committed
Undecided
Unassigned

Bug Description

Hi everyone

I'm not good at css or theming at all, and the theme was working perfectly on 6.19 but with upgrade I noticed this error

-------
warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'theme_nice_menu_primary_links' was given in /home/ubuntu/public_html/includes/theme.inc on line 656.
-------

and the administration menue is not available too.

how to get over that !!?

Thanks in advance,

Regards.

Revision history for this message
Mohammad (hyperzahranism) wrote :

I'm looking for an answer too.

Revision history for this message
Pierre Buyle (mongolito404) wrote :

I think the issue is that Drupal theme registry contains an entry for the ''nice_menu_primary_links'' linking it to the theme_nice_menu_primary_links. But this function (perhaps because it has been removed/renamed/moved in the latests nice_menu or because the nice_menu is not enabled) is not available when theme('nice_menu_primary_links', $primary_links) is called in template.php.

Did you try to clear the cache ?

Revision history for this message
Mohammad (hyperzahranism) wrote :

Actually that what exactly what I've read when I tried to update Nice menu module ,, the functions were renames to match the drupal functions .. I did clear the cache but I still have the same problem

Revision history for this message
LeDucDuBleuet (eleduc) wrote :

I had the same warning but it went away when I cleared the cache.

Changed in ubuntu-drupal-theme:
status: New → Fix Committed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers