Can't use Wysiwyg editors if footer is disabled

Bug #660773 reported by costales on 2010-10-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
UD Theme
Low
Michael Lustfield

Bug Description

Hi! I updated the Ubuntu theme 2010 from the previous version and now, I can't use (show?) Wysiwyg editors if I check not show footer.

I have installed: Drupal, Ubuntu Drupal Theme - 2010, Wysiwyg. and these editors: CKEditor, NicEdit, jWYSIWYG.

Best regards and thanks in advance!

Related branches

costales (costales) wrote :

One test:
If I set another theme (by example the default theme), I see the editor: http://flic.kr/p/8K4fgX
If I change the theme and refresh the "new page" the editor is hide: http://flic.kr/p/8K4fh2
Best regards.

costales (costales) wrote :

Uhm...
In a new fresh install appear the Editor.
Any idea about why not appear with an theme update?
Thanks!

costales (costales) wrote :

Well... I get it! If I hide the section: Ubuntu Community Footer in the theme config, I will not see the editor.

costales (costales) on 2010-10-15
Changed in ubuntu-drupal-theme:
status: New → Incomplete
status: Incomplete → Invalid

Thanks for figuring out what the cause of this is. I'll get a fix out asap. I'm swamped right now, I expect to be able to fix this on Monday or over the weekend.

Changed in ubuntu-drupal-theme:
assignee: nobody → Michael Lustfield (mtecknology)
importance: Undecided → Low
status: Invalid → Triaged
costales (costales) on 2010-10-20
description: updated
summary: - Can't use Wysiwyg editors
+ Can't use Wysiwyg editors if footer is disabled

Could you please let me know if this is still an issue at r74?

Changed in ubuntu-drupal-theme:
status: Triaged → Fix Committed
costales (costales) wrote :

Hi Michael!
I confirm that this bug is fixed :D
Thanks very much!!!

costales (costales) wrote :

@Michael: The editor works, but appears these error messages in the theme section:

    * warning: Missing argument 2 for variable_get(), called in /var/www/d/themes/udtheme-2010/template.php on line 20 and defined in /var/www/d/includes/bootstrap.inc on line 584.
    * warning: Missing argument 2 for variable_get(), called in /var/www/d/themes/udtheme-2010/template.php on line 33 and defined in /var/www/d/includes/bootstrap.inc on line 584.
    * warning: array_merge() [function.array-merge]: Argument #2 is not an array in /var/www/d/themes/udtheme-2010/template.php on line 43.
    * warning: Missing argument 2 for variable_get(), called in /var/www/d/themes/udtheme-2010/template.php on line 20 and defined in /var/www/d/includes/bootstrap.inc on line 584.
    * warning: Missing argument 2 for variable_get(), called in /var/www/d/themes/udtheme-2010/template.php on line 33 and defined in /var/www/d/includes/bootstrap.inc on line 584.
    * warning: array_merge() [function.array-merge]: Argument #2 is not an array in /var/www/d/themes/udtheme-2010/template.php on line 43.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers