Fatal error: Unsupported operand types in /[...]/includes/common.inc

Bug #517753 reported by Anthony Hook on 2010-02-05
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
UD Header
Medium
Michael Lustfield

Bug Description

When I load the UD Header 6.x-6.0 Module onto Drupal 6.15, I head over to put the Block in the Header section, click Configure, and get a white page that says:

Fatal error: Unsupported operand types in /home/anthonyrhook/ubuntu-wisconsin/includes/common.inc on line 2876

Also, when I go back to modules to check the version/disable it, I get a box that says:

warning: Cannot use a scalar value as an array in /home/anthonyrhook/ubuntu-wisconsin/includes/form.inc on line 892.
warning: Cannot use a scalar value as an array in /home/anthonyrhook/ubuntu-wisconsin/includes/form.inc on line 893.
warning: Cannot use a scalar value as an array in /home/anthonyrhook/ubuntu-wisconsin/includes/form.inc on line 896.
warning: Cannot use a scalar value as an array in /home/anthonyrhook/ubuntu-wisconsin/includes/form.inc on line 908.
warning: Cannot use a scalar value as an array in /home/anthonyrhook/ubuntu-wisconsin/includes/form.inc on line 911.
warning: Cannot use a scalar value as an array in /home/anthonyrhook/ubuntu-wisconsin/includes/form.inc on line 916.
warning: Cannot use a scalar value as an array in /home/anthonyrhook/ubuntu-wisconsin/includes/form.inc on line 865.
warning: Cannot use a scalar value as an array in /home/anthonyrhook/ubuntu-wisconsin/includes/form.inc on line 884.
warning: Cannot use a scalar value as an array in /home/anthonyrhook/ubuntu-wisconsin/includes/form.inc on line 887.
warning: Cannot use a scalar value as an array in /home/anthonyrhook/ubuntu-wisconsin/includes/form.inc on line 892.
warning: Cannot use a scalar value as an array in /home/anthonyrhook/ubuntu-wisconsin/includes/form.inc on line 893.
warning: Cannot use a scalar value as an array in /home/anthonyrhook/ubuntu-wisconsin/includes/form.inc on line 896.
warning: Cannot use a scalar value as an array in /home/anthonyrhook/ubuntu-wisconsin/includes/form.inc on line 908.
warning: Cannot use a scalar value as an array in /home/anthonyrhook/ubuntu-wisconsin/includes/form.inc on line 911.
warning: Cannot use a scalar value as an array in /home/anthonyrhook/ubuntu-wisconsin/includes/form.inc on line 916.
warning: Cannot use a scalar value as an array in /home/anthonyrhook/ubuntu-wisconsin/includes/form.inc on line 923.
warning: uasort() [function.uasort]: The argument should be an array in /home/anthonyrhook/ubuntu-wisconsin/includes/common.inc on line 2874.

Related branches

Anthony Hook (anthonyhook) wrote :

The current project is hosted at http://ubuntu-wisconsin.org

I'm still not able to reproduce this. Could you give me any more information so I can figure out how to force this to happen?

Changed in ubuntu-drupal-header:
status: New → Incomplete
Anthony Hook (anthonyhook) wrote :

I'm not what else I can explain, I'm fairly new to Drupal. The server is a Dreamhost server, it's a fairly fresh install of Drupal. I did load the other Ubuntu modules, but this one is what is giving me problems.

This module makes use of several command line options: rm, wget, cd, tar
It also requires a php modules: php5-curl

The module and commands must be available in order to use this module. If there is a way to get around this I would gladly accept patches.

Dvoynic (dvoynic) wrote :

Drupal 6.15 and udheader 6.x-6.x-dev (January 21, 2010 - 00:17), php5-curl enable on hosting.

Fatal error: Unsupported operand types in /home/docs/includes/common.inc on line 2876

warning: Cannot use a scalar value as an array in /home/includes/form.inc on line 892.
warning: Cannot use a scalar value as an array in /home/docs/includes/form.inc on line 893.
warning: Cannot use a scalar value as an array in /home/docs/includes/form.inc on line 896.
warning: Cannot use a scalar value as an array in /home/docs/includes/form.inc on line 908.
warning: Cannot use a scalar value as an array in /home/docs/includes/form.inc on line 911.
warning: Cannot use a scalar value as an array in /home/docs/includes/form.inc on line 916.
warning: Cannot use a scalar value as an array in /home/docs/includes/form.inc on line 865.
warning: Cannot use a scalar value as an array in /home/docs/includes/form.inc on line 884.
warning: Cannot use a scalar value as an array in /home/docs/includes/form.inc on line 887.
warning: Cannot use a scalar value as an array in /home/docs/includes/form.inc on line 892.
warning: Cannot use a scalar value as an array in /home/docs/includes/form.inc on line 893.
warning: Cannot use a scalar value as an array in /home/docs/includes/form.inc on line 896.
warning: Cannot use a scalar value as an array in /home/docs/includes/form.inc on line 908.
warning: Cannot use a scalar value as an array in /home/docs/includes/form.inc on line 911.
warning: Cannot use a scalar value as an array in /home/docs/includes/form.inc on line 916.
warning: Cannot use a scalar value as an array in /home/docs/includes/form.inc on line 923.
warning: Cannot use a scalar value as an array in /home/docs/modules/wysiwyg/wysiwyg.module on line 119.
warning: uasort() [function.uasort]: The argument should be an array in /home/docs/includes/common.inc on line 2874.

Dvoynic: What are you using to host this website? Anthony is using Dreamhost iirc.

Also.. are you guys hosing in a multi-site or single site setup?

Changed in ubuntu-drupal-header:
assignee: nobody → Michael Lustfield (mtecknology)
status: Incomplete → Confirmed
Håkan Sörensson (hakans) wrote :

I can confirm this bug.
I host my site at www.oderland.se as a single site setup.

I wiped my stuff clean. Added the block to the top header. Went to /admin/settings/udheader. Added a default header.

I'm not able to reproduce your issue. I need some more information to reproduce before I can fix this.

Changed in ubuntu-drupal-header:
status: Confirmed → Incomplete
Dvoynic (dvoynic) wrote :

Drupal 6.16, phpinfo in attachment

I see shell is enabled. That is the only thing I can think of that would hinder the ability for this module to function.

Mehdi Hassanpour (mehdi) wrote :

I can see the UD header but when I want to configure it in "Administer > Site Building > Blocks" (admin/build/block/configure/udheader/0) I see a blank page with this error:

"Fatal error: Unsupported operand types in /home/ubuntu-ir/public_html/includes/common.inc on line 2886"
And I can't change the configuration...

then when I refresh the blocks page I get following errors:

    * warning: Cannot use a scalar value as an array in /home/ubuntu-ir/public_html/includes/form.inc on line 893.
    * warning: Cannot use a scalar value as an array in /home/ubuntu-ir/public_html/includes/form.inc on line 894.
    * warning: Cannot use a scalar value as an array in /home/ubuntu-ir/public_html/includes/form.inc on line 897.
    * warning: Cannot use a scalar value as an array in /home/ubuntu-ir/public_html/includes/form.inc on line 909.
    * warning: Cannot use a scalar value as an array in /home/ubuntu-ir/public_html/includes/form.inc on line 912.
    * warning: Cannot use a scalar value as an array in /home/ubuntu-ir/public_html/includes/form.inc on line 917.
    * warning: Cannot use a scalar value as an array in /home/ubuntu-ir/public_html/includes/form.inc on line 866.
    * warning: Cannot use a scalar value as an array in /home/ubuntu-ir/public_html/includes/form.inc on line 885.
    * warning: Cannot use a scalar value as an array in /home/ubuntu-ir/public_html/includes/form.inc on line 888.
    * warning: Cannot use a scalar value as an array in /home/ubuntu-ir/public_html/includes/form.inc on line 893.
    * warning: Cannot use a scalar value as an array in /home/ubuntu-ir/public_html/includes/form.inc on line 894.
    * warning: Cannot use a scalar value as an array in /home/ubuntu-ir/public_html/includes/form.inc on line 897.
    * warning: Cannot use a scalar value as an array in /home/ubuntu-ir/public_html/includes/form.inc on line 909.
    * warning: Cannot use a scalar value as an array in /home/ubuntu-ir/public_html/includes/form.inc on line 912.
    * warning: Cannot use a scalar value as an array in /home/ubuntu-ir/public_html/includes/form.inc on line 917.
    * warning: Cannot use a scalar value as an array in /home/ubuntu-ir/public_html/includes/form.inc on line 924.
    * warning: uasort() [function.uasort]: The argument should be an array in /home/ubuntu-ir/public_html/includes/common.inc on line 2884.

Alrighty, now I get where you guys are seeing this. I can happily fix it when I have some time.

Changed in ubuntu-drupal-header:
importance: Undecided → Low
status: Incomplete → Confirmed

With the new theme will this module be used anymore?

Anthony Hook (anthonyhook) wrote :

That's a good question, if it isn't, I could understand leaving as-is.

Ya, but if people are going to keep using it I definitely want to fix it. I
just want to figure out if I should put my effort in here or on the other bugs.

On Wed, 28 Apr 2010 13:15:13 -0000
Anthony Hook <email address hidden> wrote:

> That's a good question, if it isn't, I could understand leaving as-is.
>

--
Michael Lustfield
Kalliki Software, LLC

Network and Systems Administrator

Changed in ubuntu-drupal-header:
importance: Low → Medium

This has been fixed in r32.

Changed in ubuntu-drupal-header:
status: Confirmed → Fix Committed

Pushed to Drupal

Changed in ubuntu-drupal-header:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments