Loviewer doesn't support documents protected by a password

Bug #1522167 reported by Chloe Johnson on 2015-12-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Document Viewer App
Wishlist
Unassigned

Bug Description

Trying to open a LibreOffice document protected by a password, the app says that the document may be corrupt.

SOLUTION:
Add support for protected documents as this feature will be available in LibreOfficeKit. Progress on this will be tracked on this report.

See bug #1524712 , which is related to the wrong error string.

Hi and thanks for reporting the issue you found in Document Viewer!

Could you please tell me which version are you using?
In the version 2.0.193-beta (the one released for testing a few weeks ago), there's no error detection and/or recovery, so the app crashes when an exception is raised.

This has been already fixed, and a dialog is shown when something unexpected happens.

Anyway, we don't handle documents with password yet, so I can already confirm your report.

LibreOfficeKit doesn't seem to provide any explicit interface for loading documents protected by a password.
However, the library is under an heavy development and some part of the library is partially undocumented, so I need to check if my assumption is right.

Also, the error detection we have already implemented doesn't consider the scenario you described.

I suspect I'll have to split your report in two parts:
1) Add support for documents protected by a password
2) Properly detect when the loading failed because of the file being protected.

I'll be back again as soon as I have further informations.

Thank you again for taking the time to report this bug!

Changed in ubuntu-docviewer-app:
status: New → Confirmed
tags: added: loviewer

I had a deeper look at it.
It seems there's no reasonable way for loading documents protected by a password yet.
This is anyway something we will want to support, so I'm going to mark this report as "Wishlist".

From my previous reply (#1):
> 1) Add support for documents protected by a password
It will be tracked here.

> 2) Properly detect when the loading failed because of the file being protected.
See bug #1524712

Changed in ubuntu-docviewer-app:
importance: Undecided → Wishlist
summary: - documents with passwords crashes and quits apps
+ Loviewer doesn't support documents protected by a password
description: updated

Recently it has been committed a change in the development version of LibreOffice which adds the support for protected documents in LibreOfficeKit.
https://github.com/LibreOffice/core/commit/2b63e576a5cf06f4af877d63403ad7955ac71b72

It should be released with LibreOffice 5.2 (August, 2016).
For the DocViewer this would mean Sep/Oct 2016

tags: added: lo5.2
Changed in ubuntu-docviewer-app:
milestone: none → ota-11
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers