Invalid docs for Internet modem connection (dialup) in 8.10 intrepid

Bug #310331 reported by Robert Donan on 2008-12-21
40
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Documentation
Hardy
Undecided
Unassigned
ubuntu-docs (Ubuntu)
Medium
Dougie Richardson

Bug Description

Documentation for Internet Modem setup in 8.10 Intrepid Ibex is invalid. There is no Network tab available in System->Administration.
As a result, those of us who are unable to connect to the internet through a DSL or Cable Modem are unable to access the internet. Additionally, previous releases do not allow upgrading with the 8.10 Intrepid Ibex distribution or alternate distribution CDs so I was unable to determine if the Network tab would remain available after upgrading the system.

Installing Gnome-system-tools does not fix the missing tab problem in the operating system. And, the missing tab problem is not isolated to a single distribution. I have done clean installs of all available distributions of 8.10 Intrepid and none provide the necessary System->Administration->Network tab to enable users to configure a modem.

Related branches

Hi,

Network manager replaced this feature in 8.10 however as I have no modem to test with I have been unable to update the documentation. I would be glad to incorporate any suggestions you have.

Changed in ubuntu-doc:
assignee: nobody → ddrichardson
importance: Undecided → High
status: New → Incomplete
Robert Donan (donanr) wrote :

Dougie;
My installation of Gusty had both a Network tab and Network Manager tab under System Administration.
The Network tab allowed setup for dial-up modems to connect to the internet. Network Manager allowed configuration of all forms of ethernet configurations (wired and wireless, high and low speed) for use with servers, wireless routers, and DSL modems. In that I do not have high-speed i-net capability where I live, I am forced to use a dial-up connection. If Network Manager contained the capability of configuring an internal dial-up modem I could offer a workable change to the documentation.
It seems that the programmers have developed an IBM mentality--Yo will use what we offer and you will like it even if it doesn't do what you need it to do. And, if you want it to do what you need it to do, you will have to upgrade to a more costly system that still won't do what you need it to do!
As it stands, untill the programmers realize that 40% of the users do not have DSL, or Cable modems and, are willing to modify their programs to provide a means to configure dial-up modems for automatic connection to an ISP (as in previous versions), I believe that you should change the documentation to reflect "This option is not currently supported" and add the limitation to the list of caveats for the "New" operating system.

Hi,

Network manager is an upstream project for which I don't have a contact. I'll look into this further before making any changes. Hopefully someone on our team is more familiar with dialup.

Matthew East (mdke) on 2009-01-04
Changed in ubuntu-doc:
importance: High → Medium
status: Incomplete → Confirmed
Dave Rohde (drohde-lanset) wrote :

You could try and use pppconfig but it is having some of the same issues.
I tried it with both a static and dynamic IP setup and the static holds but does very little other than open a line. Both NetTools and the Network monitor show a ppp0 connection but other than a couple of exchanged packets it seems there is no real contact. Synaptic fails to make a contact for reload as well as apt-get. I tried to do the "apt-get update" to see if the repositories had changed and to no avail along with trying several stable gnome applets.

Using a US5610B modem which is functioning on all versions from Hoary through Hardy and seems to partially work with Intrepid Ibex but does not have the same solid connectivity.

The dynamic setup holds for a moment and then breaks contact.

This is written with Hardy on the 5610B modem.

It seems using gnome-ppp or kppp directly is the only option in Intrepid.

For gnome-ppp, see:
https://help.ubuntu.com/community/DialupModemHowto/SetUpDialer#For%20Ubuntu,%20alternative%20approach%20(using%20gnome-ppp)

Proper dialup support is apparently planned for a future version of NM. From the upstream's mailing list [1]:

"> 3) Dialup support is gone now? Dialup is so 90's now, but unfortunately
> bluetooth DUN is still alive and kicking. However, I couldn't seem to
> find a way to use this in NM currently, nor could I find any way to
> enable it. Am I missing something here to enable it, or was it just
> simply (finally) removed and to be considered legacy? Seems there'd
> still be a lot of people stuck using traditional dialup to abandon them
> entirely...

The "dialup" support in NM was simply a menu shortcut for the distro
native scripts to ifup / ifdown the connection, and was in no way
integrated into NetworkManager itself. Hence one of *the* most
requested features was for integrated 3G support so that people could
use the NM VPN plugins with mobile broadband."

[1] http://mail.gnome.org/archives/networkmanager-list/2008-December/msg00022.html

Is Gnome-PPP included on the Ubuntu distribution DVD/CD? I am unable to use apt-get over internet as I can't access my modem since the upgrade to Intrepid, and I have aproximately 136 hours of downloaded programs installed under Gusty and Hardy distributions that I do not want to loose with a reinstall of Hardy.
It seems the programmers have left a few of us (aproximately 40% in the U.S. and 60-80% worldwide) in the dust...
https://bugs.launchpad.net/bugs/314827 (a related incident responding to the missing tab) states that "There is no such item [Network tab] in Intrepid. It's rather under Systerm > Preferences > Network Configuration" however, this only seems to allow configuration of NICs, I have not been able to find any dial-up configuration related functionality available there either.

Coty Colson (dariastom) wrote :

I'm having the same problem. I run Intrepid Ibex in dual boot with Vista, and I have Dial-Up because I live so far from town. I haven't been able to try Gnome-PPP, or anything else because I only have dial up. I really like Ubuntu, but without internet acess, I'm forced to use Vista, which I really don't like. I would rather have high speed internet, but it's not availible where I live.

JaceK (gothrelic) wrote :

Alright, I just recently got my first taste of Linux since, well forever ago..now there are ways of getting the modem to work.. but.. it seems whenever I get the first steps down, like using scanModem to aquire the correct information about my modem, the rest of the details slowly slip from the walkthrough.. like, wvdial.conf doesn't work correctly, and scanModem doesn't put the Modem folder under /dev. It puts it whereever it is dpkg'd to. Like right now my desktop. Which in itself is a pain in the lower part of my body from which feces emerges... So, I got rid of my Ubuntu 8.10, and got myself a copy of Ubuntu UE 2.. which, by the way still has the same problem. I am pretty sure that most people who aren't having problems with thier Dial-up connections don't bother to read this post.. so it is going to be a stretch to ask.. But if you know how to work with ubuntu using wvdial and scanModem to get a conxant or linmodem to work a post here would be highly appreciated. Thanks.

Dave Rohde (drohde-lanset) wrote :

While it may seem that some of the information leads to the use of Gnome-ppp it is not available in package form outside of any Intrepid repository, at least I have yet to find it. Since I tried the pppconfig for setting up the dial up I don't see how Gnome-ppp is going to resolve the issue.
Also it may seem "so passe'" to use dial up but some folks have no real options, in spite of what some providers say and do. Also the difference in costs are substantial. Internet access costs me $120 a year on dial up and almost that much a month for cable or Fiber optic systems.

There also seem to be some reports that Gnome-ppp does not function either.

Robert Donan (donanr) wrote :

The only free driver I have been able to find for a Conextant (HP, Compaq, etc.) modem is only capable of 14.4 Kbps. The 56K version is $19.95 "due to proprietary information." Even with the appropriate driver installed the unfortunate result is that I have been unable to get wvdial to accept any changes when I try to manually write a configuration file. Every time I try to save the configuration, the system tells me I don't have authorization to do so.
As a result, I recently transported my 45# tower 35 miles to the city in order to gain access to a DSL connection. I and tried to use the sudo apt-get Gnome-ppp command in terminal mode but received the "unable to locate" error. Other than being able to get updates for the installed programs I was still unable to get my modem working so it was pretty much a wasted trip.
The software side of the house states that they gave up modem support (limited as it already was) in favor of wireless G3 support. Heck, if I turn my head while talking on my cell phone I get a dropped connection on the second floor of my house. On the bottom floor I have to go outside so G3 will be of no use to me either.
I will keep you all informed what I find out from the software people so that we might be able to get our Ubuntu systems accessing the internet.

Dave Rohde (drohde-lanset) wrote :

This appears to be more than a Conextant driver issue.
The USR5610B has functioned for both Gateway and Dell computers with little or no issues since Breezy Badger and has been splendid thru Feisty, Gutsy and Hardy.

Lastly there seems to be more to this inability to connect or handshake properly which is what it appears to be doing. I was able to run a traceroute with output once connected but for some reason individual site connection is limited or removed out side ot recording the trace.

I made an effort to try both the Debian Gnome-ppp and the latest Gnome-ppp available and it would not make contact with wv and wvdial. pppconfig does dial out and you can hear the normal tones however there is a break of some kind in the system. It appears all the necessary packages are in the Intrepid installation.

Also there needs to be a way for the download of the repaired packages at issue from a general site which can then be placed in the apt cache for Gdebi or dpkg installation. If this is going to be foresaken and not included in Intrepid I would like to know so I can remove Intrepid.

earther (earther) wrote :

I am still on Gutsy (with a Hardy kernel for hibernation issues). Since I have an 'if it works don't fix it' mentality, I don't upgrade until the newest release becomes stable (though I do have Hardy and Intrepid installed in Virtual Box).

I am a dialup user with a USR5610B modem. If is very shortsighted to assume that everyone has access to or can afford DSL or cable or even wants a high speed connection. I connect either via pon/poff or GNOME PPP. Since I have now become aware of this issue when upgrade time does come, it will be to Hardy for the duration of the LTS support.

Please don't forget about us dialup users!!! I would not be happy to have to search for another distro after so many years with Ubuntu.

Dave Rohde (drohde-lanset) wrote :

While the first posting of this bug is indicating documentation. That is leading to the failure of dialup services in Intrepid. The remarks following the initial posting indicate this failure.
bug addressed in thread is not a dupicate bug of 314827. Documentation.

The initial bug 314827 has lead, along with a failure of the service, discovery of a deprecation of ppp connect function (dial up) modems.
Dial up is only partial in nature and lacks the full service, does not perform as previous version Hardy Heron.

This is not a "documentation" issue it is a function failure of former successful internet connection capability.

Robert Donan (donanr) wrote :

Dave;
I believe what happened is that I originally found an error in the documentation while seeking a way to be able to connect to the internet through my internal modem after upgrading to Intrepid from Hardy. I had taken my system to a different location where I could connect through a DSL connection to perform the upgrade and didn't realize that I had a problem until I returned home and tried to go on-line.
Fortunately, I was able to connect through a Windows machine and consulted the documentation associated with Intrepid. It was there that I discovered the discrepancy in the documentation which referred to the Network tab under System -> Administration (where I had configured my modem originally). Unfortunately, that feature had been removed.
Then, while searching for other ways to connect, I discovered that: 1) Intrepid would not save configuration data for my modem (a bug?)...I received an error that I didn't have authorization (a bug?); 2) I received an error trying to manually dial my ISP stating that my modem was improperly configured (a bug or catch 22?).
As a result, I submitted a software bug report. When I did so I provided background as to how I discovered the bug (as stated above) and what I had done when I attempted to work around it (futile attempt).
As I don't have a clue as to which program module was associated with the Network tab that existed in previous releases I wouldn't have recognized the code even if I were an expert programmer with the knoledge to fix it.
I just find it amazing that, contrary to the original intent of Ubuntu, the programming community has gone the way of RedHat, Suse, etc., and, other than providing an open system, has decided to abandon 40% of us in the United States of America and Canada, and between 60%-80% worldwide who don't have DSL or Cable Modem capability in favor of those living in urban and suburban America. In abandoning dial-up even those who are fortunate to be able to afford satellite downlink capability have been abandoned because they still need their dial-up modem as an up-link. Finnally, as I get off my soap box, for those of us in rural (85% of the land mass) America, and don't reside within15 miles of an Interstate, wireless is only sience fiction.
As a result of the problems (Bugs?) associated with Intrepid, I had to do a bare system reinstall of Hardy, cart my system 35 miles to a location where I was able to connect through a DSL odem to download and install all of the security updates and, then download and install all of the additional programs previously installed on my system as they do not available as bundled software on any of the distributions.

Dave Rohde (drohde-lanset) wrote :

I tried to force the dialup modem functions and went into WVDIAL and tried to use a Debian gnomeppp and also the standard pppconfig. I show a connection but for some reason some thing is missing and it may be in the kernel itself. Ping works, traceroute works but there seems to be a lack of "hand shaking" for connection to any sites, including the repositories.
I doubt the removal of Dial up capability was intentional and would think it was more an oversight.

What I would like to see is a fix which could be downloaded as a .deb package from either sourceforge or some other reliable source to place in Intrepid using either Gdebi or Dpkg, both have worked fairly well on my system or an additonal mailing of interpid with the fix.

Tim O'Neil (timoneil) wrote :

 I am using my standard AT modem (jumpers) with Ubuntu 8.10 to write this message. I set pppconfig to defaults except my username, password and modem port. Chat mode would connect for a few seconds and then disconnect. After disabling chat it works fine.

Modem set to comm port 3 (tty2) with port 1 disabled in bios to avoid interrupt conflict.

I haven't found a way to disconnect yet without rebooting so if someone finds a way I hope they will post it.

TLO

Dave Rohde (drohde-lanset) wrote :

Tim
Try "poff" or "poff -a" in a terminal window.
If the connect/disconnect needs admin privilege try "sudo poff" or "sudo poff -a"
Using poff -a disconnects "all" Tcp/ip connections normally.
Best guess unless you pull the phone jack, then loss of signal will in a short time close the program.

Tim O'Neil (timoneil) wrote :

Dave,

 sudo poff works great. Thanks.

Dave Rohde (drohde-lanset) wrote :

Tried several other com ports to no avail.
Tried sudo pon to see if it needed administration to work, it did not work.
Connection is made but something is wrong with the handshaking protocol.
Tried removing possible conflict packages like Blue tooth and DSL support packages.
May be some other conflict.
Still shows a connection but no transfer after the intitial connect to provider script.
Chat was off as well, before and this attempt.

Dave Rohde (drohde-lanset) wrote :

Possible resolution on this for the dialup connection.

Solution posted in the Ubuntu Forums by lkreamer:
To use wvdial for a dial-up connection

"sudo wvdialconfig" This will find and configure the modem.
You must then add your personal info to the /etc/wvdial.conf file.
(user name, phone number and password)

Note with Intrepid (for those not able to update gedit due to the lack of connection)
Gedit had some issues with "sudo" and some comments were in the terminal when performing an administration editing of the wvdial,conf file when closing and expecting the usual auto save actions, SAVE before closing after edit. Also watch syntax including spaces, leave a space between the equalls for each field (user name, number and password)

Once you gain access go directly to the repositories and get the "ppp" and other base file updates.
This allows a return of the pppconfig provider dial-in, handshaking and changing between dynamic and static and the tagged (pon <provider>) pon, poff and pogg commands plus the -a option
This for the USR 5610b modem.

PS: some of the above information is not available in wvdial docs mainly the wvdialconfig, leastwise not in mine. Also Wvdial has some issues with the pap, chat and pap-secrets files, shakey connection.

Fabián Rodríguez (magicfab) wrote :

People this bug report is about the documentation being wrong.

Missing DUN is another issue. Please file a separate bug report or if it already exists, comment on it.

This thread appears to become confused.

References to gnome-network-utils (not gnome-system-tools) are no longer in the current development trunk for Jaunty, so from that point of view the bug is addressed.

However I am concerned that this leaves no viable help for those using dial up, which is a sizeable community. What I need for the documentation is a coherent solution which is agreed upon and can be documented - wvdial seems sensible and would get my vote.

Changed in ubuntu-doc:
status: Confirmed → Incomplete
Matthew East (mdke) on 2009-02-22
Changed in ubuntu-doc:
status: Incomplete → Confirmed

I was planning to document the following steps:

Install the network-manager-gnome package (sudo apt-get install network-manager-gnome
Open System->Administration->Network
Click Unlock
Enter your password and click authenticate
In the connections tab, click point to point connection and click properties
Tick "Enable this connection"
Choose Serial Modem from the connection type drop down
Under internet service provider data, enter the phone number and dial prefix
Under account data enter your password and username
Click the modem tab
Choose the modem settings you require
Click OK
Click Close

Can someone confirm these steps?

OK, I got hold of a external Hayes compatible serial modem and gave it a bash with network-manager-gnome. These revised steps worked for me so I've pushed them as a patch in the Jaunty branch.

Changed in ubuntu-doc:
status: Confirmed → Fix Committed
Jesse Weinstein (jesse-wefu) wrote :

(I wish Launchpad wouldn't silently lose your comments if you change anything else on the page, and even disrupt the browser history so they don't even show up there... This is only my first time using Launchpad, and that's a rather painful bug... Now, to rewrite my comment...)

I'm sorry to have to say this, but your proposed steps do not work on a fresh Live install of 8.10-desktop-i386.

Here are the problems I saw, when I attempted to follow your instructions:

There is no "Network" entry on the System->Administration menu.

network-manager-gnome is already installed by default.

When I ran it, there was no "connections tab", or "point ot point connection", or "Serial Modem" choices visible anywhere in the program.

I don't know what version you tested your instructions on, but it certainly wasn't a clean install of 8.10... Please re-open the bug.

Jesse Weinstein (jesse-wefu) wrote :

Re-opening as Confirmed. As I said, I just tested it on a fresh install of 8.10.

Changed in ubuntu-doc:
status: Fix Committed → Confirmed

I'm running 8.10 network-manager-gnome was not installed. I followed the steps I listed and it worked. It may have been removed during the first system update though.

The Administration -> Network entry _is_ network-manager-gnome so I cannot understand how you haven't got it yet have the package.

Without appearing rude - are you absolutely sure that you are running network-manager-gnome and not NetworkManager, because NM _is_ installed by default and doesn't have the options you list.

Need confirmation, my install of 8.10 might be different to Vanilla.

Changed in ubuntu-doc:
status: Confirmed → Incomplete
Jesse Weinstein (jesse-wefu) wrote :

OK, I'm now looking at my copy of Ubuntu as I type this. It is a (verified) copy of ubuntu-8.10-desktop-i386.iso which I downloaded earlier today, running in LiveCD mode, immediately after being started up. On the System->Administration menu there is only one entry that contains the word: "Network". It is called "Network Tools". It runs the command: gnome-nettool.

When I run it (gnome-nettool), it shows various sorts of information, but provides no opportunity to make any changes whatsoever.

So, that hopefully clarifies my claim that asking someone to click on System->Administration->Network is impossible.

Next, when I do "dpkg-query -W network-manager-gnome" it prints out:
"network-manager-gnome 0.7~~svn20081020t000444-0ubuntu1" i.e. yes, network-manager-gnome *is* installed.

There are only two executable files in the network-manager-gnome package: nm-connection-editior, and nm-applet. When I run nm-connection-editor (which is also run by the menu item: System->Preferences->Network Configuration ), it has no menu bar, and 5 tabs: "Wired", "Wireless", "Mobile Broadband", "VPN" and "DSL". There is no "Connections" tab, and there is no "Point to point connection" entry on any of the tabs. And there is no "Serial Modem" choice in any of the dialog boxes reachable from any of the tabs.

When I try to run nm-applet, it crashes on startup, complaining that the NetworkManagerUserSettings is already taken.

As I said at the top, this is straight off of a fresh LiveCD version of 8.10. Please let me know if there is any further clarifications I can provide. I have re-opened the bug.

Changed in ubuntu-doc:
status: Incomplete → Confirmed

My mistake - the package is gnome-network-admin. This is what happens when you try to do a half dozen bugs at once.

Patch pushed - can you try the above steps replacing gnome-network-manager with gnome-network-admin?

Jesse Weinstein (jesse-wefu) wrote :

You should clarify that gnome-network-admin is available only in the universe repository, not on the CD, an so requires downloading the package on another computer and bringing it over to the target computer. I presume there's some documentation on how to do that; it would be good to link to it. I haven't been able to try your revised steps because yet because I haven't had time to surmount this hurdle. I'll try sometime next week.

Changing to In Progress as it is awaiting confirmation it works.

Changed in ubuntu-doc:
status: Confirmed → In Progress
Dave Rohde (drohde-lanset) wrote :

The purpose of trying to find an access method for dialup was to help alleviate the lack of documentation and the failure of anyone to recognize there was no support for dial up in the mailed out Intrepid disc.
This is in concurrence with remarks by Jessie Weinstein.

That said the ppp package and any other package which securely supports dial up needs to be added to the future versions of the mailed out CD if you wish to retain dial up users. Also there was a lack of information in the way of work-arounds to get Intrepid on line to begin with, as noted above for the configuration of wvdial "sudo wvdialconfig" was not in the documentation and the additional adding of personal information, maybe that was forgotton on the mail out disc as well.

Also the network administrator seems to have no bearing or purpose on connecting to the internet via dial up and once removed has no effect on the ability to make the connection. This should either be noted or corrected.
It would be nice if all could access through the updated technology but it seems highly questionable to lose so many Linux users in an effort to be "modern."

I appreciate your frustration and am not trying to lose users, rather to provide a suitable documentation solution for people out of the box. There are many subscribers here and I had hoped to come to some sort of consensus.

The lack of a suitable DUN support is best addressed by opening another bug, not least of which because those who can affect a change are not necessarily reading a Documentation bug.

Fabián Rodríguez (magicfab) wrote :

@Dougie: Precisely, this is about updating the documentation, NOT about finding a workaround specially one based on universe packages.

Having packages from Universe on the CD would most probably mean moving them to main, which is yet another separate process.

Changed in ubuntu-doc:
assignee: dougierichardson → nobody
assignee: nobody → dougierichardson
al (al-planetwave) wrote :

IF all you want is dial-up access, here is a solution:
            get a copy of SimplyMepis Linux.
It has a neat little menu that asks if you want "noauth" or not.
I get dial-up internet access even using the CD without installing.
I have tried the latest kubuntus and Ubuntus and keep coming back
to this little SimpleMepis proggie.

Matthew East (mdke) wrote :

Moving to ubuntu-docs package as per new bugs policy.

Changed in ubuntu-doc:
status: In Progress → Invalid
Changed in ubuntu-docs (Ubuntu):
assignee: nobody → dougierichardson
importance: Undecided → Medium
status: New → Confirmed

String freeze is tomorrow, I'm more than happy to use a better solution than mine (I especially don't like the need to manually install a package). I'm also happy to ask for string freeze exception if someone has a solution.

Its a same because this package is very well integrated into Netbook Remix.

Changed in ubuntu-docs:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 9.04.5

---------------
ubuntu-docs (9.04.5) jaunty; urgency=low

  * String freeze release

  * [Matthew East]
    - Updating logout and shutdown instructions for Jaunty (User Switcher, not System menu)
    - musicvideophotos.xml - use consistent language for extracting audio cds (LP: #346245)
    - musicvideophotos.xml - use direct link to brasero manual
    - Make titles of documents in yelp indexes match the title of the documents themselves (LP: #345852)
    - Refresh pot templates

  * [Dougie Richardson]
    - basic-commands.xml - paste instructions correction (LP: #341534)
    - internet/troubleshooting.xml - changing bad wording
    - video.xml - dvd support requires gstreamer-ugly (LP: #338321)
    - connecting.xml - modem instructions (LP: #310331)

  * [Adam Sommer] - Server Guide
    - Updated OpenLDAP section for new /etc/default/slapd configuration.
    - Added instructions for setting correct ACL for the Kerberos keys.
    - virtualization.xml - new Eucalyptus and OpenNebula sections
    - installation.xml:
      * rewrite of Extending Volume Groups section (LP: #347201, LP: #346862, and LP: #346859)
      * Updates for Jaunty.
    - security.xml:
      * Updated Firewall section for Jaunty.
      * Corrected "sudo ufw app info Samba" command (LP: #346327).
    - dns.xml - fixing grammar and spelling mistakes (LP: #348032, LP: #348023, LP: #348094).
    - windows-networking - Updated Likewise Open section for Jaunty (feedback from Thierry Carrez).

  * [Phil Bull]
    - about-ubuntu.xml - minor edits and updates, simplify a few sentences
    - add-applications.xml:
      * Add new entity for Software Sources, with sensible name
      * Simplify structure
      * Reduce verbosity, concentrate on the instructions
      * Separate-out conceptual information into dedicated sections

  * [Nathan Handler]
    - virtualization.xml - typo (LP: #343633)

  * [Dean Sas]
    - music.xml - volume control preferences fix (LP: #346957)

  * [Tim Bosse]
    - connecting.xml - add basic VPN instructions

 -- Matthew East <email address hidden> Wed, 25 Mar 2009 22:03:21 +0000

Changed in ubuntu-docs:
status: Fix Committed → Fix Released

Pl. help me in installing BSNL EVDO USB data card on ubuntu 8.10 which I've installed on my HP pavilion laptop. I've downloaded zte driver from www.ztemt.com. But, unfortunately the ztemt software doesn't detect the modem though it is attached. During installation of the software it gives an error "insmod: error inserting 'ztemt.ko': -1 invalid module format". I've tried the to install the software using "dpkg -i ztemt..... .deb".

        my email <email address hidden>

Hi,

I found a couple of pages on the net that might help....

http://tekguru.wordpress.com/2008/07/26/howto-setup-bsnl-data-card-in-linux/
http://fingergeeks.wordpress.com/2009/06/17/configure-bsnl-evdo-datacard-on-ubuntu/

If neither of those two sort you out, then let us know and we'll put you in touch with the Support Forums and IRC channels.

Cheers,

Alistair

________________________________
From: "<email address hidden>" <email address hidden>
To: <email address hidden>
Sent: Sunday, 3 January, 2010 14:20:19
Subject: [Ubuntu-manual] [Bug 310331] Re: Invalid docs for Internet modem connection (dialup) in 8.10 intrepid

Pl. help me in installing BSNL EVDO USB data card on ubuntu 8.10 which I've installed on my HP pavilion laptop. I've downloaded zte driver from www.ztemt.com. But, unfortunately the ztemt software doesn't detect the modem though it is attached. During installation of the software it gives an error "insmod: error inserting 'ztemt.ko': -1 invalid module format". I've tried the to install the software using "dpkg -i ztemt..... .deb".

        my email <email address hidden>

--
Invalid docs for Internet modem connection (dialup) in 8.10 intrepid
https://bugs.launchpad.net/bugs/310331
You received this bug notification because you are a member of Ubuntu
Documentation Project Team, which is a direct subscriber.

Status in Ubuntu Documentation hardy series: New
Status in “ubuntu-docs” package in Ubuntu: Fix Released

Bug description:
Documentation for Internet Modem setup in 8.10 Intrepid Ibex is invalid. There is no Network tab available in System->Administration.
As a result, those of us who are unable to connect to the internet through a DSL or Cable Modem are unable to access the internet. Additionally, previous releases do not allow upgrading with the 8.10 Intrepid Ibex distribution or alternate distribution CDs so I was unable to determine if the Network tab would remain available after upgrading the system.

Installing Gnome-system-tools does not fix the missing tab problem in the operating system. And, the missing tab problem is not isolated to a single distribution. I have done clean installs of all available distributions of 8.10 Intrepid and none provide the necessary System->Administration->Network tab to enable users to configure a modem.

_______________________________________________
Mailing list: https://launchpad.net/~ubuntu-manual
Post to : <email address hidden>
Unsubscribe : https://launchpad.net/~ubuntu-manual
More help : https://help.launchpad.net/ListHelp

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions