Please, remove es_ES and es_PR locales from the ubuntu-docs templates

Bug #348855 reported by Ricardo Pérez López on 2009-03-26
6
Affects Status Importance Assigned to Milestone
Launchpad itself
Undecided
Unassigned
Ubuntu Documentation
Undecided
Unassigned
Nominated for Jaunty by Ricardo Pérez López
ubuntu-docs (Ubuntu)
Medium
Matthew East

Bug Description

According to

  https://translations.launchpad.net/ubuntu/jaunty/+source/ubuntu-docs/+pots/about-ubuntu

there're templates created for Spanish (Spain) and Spanish (Puerto Rico), in addition to the generic Spanish.

Please, can anybody remove these "es_ES" and "es_PR" locales from the ubuntu-docs templates? They are buggy and unnecessary, since the only locale for Spanish language must be "es" (without the country part).

The existence of the es_ES and es_PR locales is only a source for troubles.

Thanks in advance,

Ricardo Perez
Ubuntu Spanish Translators Team Coordinator

Related branches

Matthew East (mdke) wrote :

These can be removed, but it's necessary to look into why these exist in the first place. Why has Rosetta permitted these templates to be created if the locales are not appropriate? I assume this should be fixed in Rosetta or it will continue to occur in ubuntu-docs?

Changed in ubuntu-doc:
status: New → Invalid
Changed in ubuntu-docs (Ubuntu):
assignee: nobody → mdke
importance: Undecided → Medium
milestone: none → ubuntu-9.04
status: New → Confirmed
Ricardo Pérez López (ricardo) wrote :

Thanks for the response, Matthew.

The "countryfied" locales could be useful on several applications, but I think ubuntu-docs should have only a generic locale without the country part (i.e. "es" instead of "es_ES" or "es_PR"). There's no need to have separate documentation localizations according to the user's country.

Anyway, I just went into "es_ES" and "es_PR" locales for the "about-ubuntu" template and removed all the translations inside them, leaving them blank, so I hope this action minimizes the issue.

Matthew East (mdke) wrote :

I am uploading a fixed ubuntu-docs package but I'm not sure whether fixing this permanently requires removing the templates from Rosetta too. Can a Rosetta developer confirm? Also, please ensure this issue doesn't happen again by preventing es_ES and es_PR translations from appearing.

Ricardo Pérez López (ricardo) wrote :

Thank you very much, Matthew. Will it be another ubuntu-docs update before Jaunty release? I hope so, because there're some translation typos and strings which aren't translated yet.

On Sat, Apr 4, 2009 at 9:34 AM, Ricardo Pérez López <email address hidden> wrote:
> Will it be another ubuntu-docs update
> before Jaunty release? I hope so, because there're some translation
> typos and strings which aren't translated yet.

Yes, there will.

--
Matthew East
http://www.mdke.org
gnupg pub 1024D/0E6B06FF

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 9.04.8

---------------
ubuntu-docs (9.04.8) jaunty; urgency=low

  * [Jordan Mantha]
    - Add Conflicts on edubuntu-docs (<< 9.04.1ubuntu1) LP: #353288

  * [Matthew East]
    - Remove es_ES and es_PR locales (LP: #348855)
    - Removing strings about totem not being able to support DVD menus (LP: #354777)

 -- Matthew East <email address hidden> Fri, 03 Apr 2009 21:19:27 +0100

Changed in ubuntu-docs (Ubuntu):
status: Confirmed → Fix Released

Since our languages set-up is global, and some applications depend on having things like es_ES (which are hidden if they don't exist already, but people can still hack URLs to get there), we can't easily disallow creation of such translations (i.e. libgweather sets different default locations for es_ES, es_AR, es_MX...).

We also don't remove translations when they disappear from imports for many different reasons (i.e. LP might have a good translation for what used to be a bad PO file in import).

If you want a translation removed, please ask for it on https://answers.launchpad.net/rosetta and give us exact details of what you want removed. Also, please talk to people doing the translation beforehand, so they don't start doing it again, and so we make sure we are all on the same page.

Changed in rosetta:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers