please remove completely inapplicable Legal footer link from published installation-guide

Bug #314941 reported by Colin Watson on 2009-01-08
4
Affects Status Importance Assigned to Milestone
Ubuntu Documentation
Medium
Matthew East

Bug Description

A user posted to the debian-boot mailing list recently in the belief that Ubuntu was infringing copyright on and removing attribution from the Debian installation-guide:

  http://lists.debian.org/debian-boot/2009/01/msg00050.html

I followed up to his mail explaining the mistake in his reading. Nevertheless, it's clear to me that help.ubuntu.com's presentation of the Ubuntu installation-guide (derived from Debian's) should be improved.

The bottom of each page of the installation-guide has the following two lines:

  The material in this document is available under a free license, see Legal for details
  For information on contributing or to report a problem, visit the Ubuntu Documentation Project

Legal says:

  The documents on this website are maintained by the Ubuntu documentation team. For a list of contributors, see the contributors page

  Unless stated otherwise on the front page of the document, the documents are made available under the Creative Commons ShareAlike 3.0 License (CC-BY-SA).

  You are free to modify, extend, and improve the Ubuntu documentation source code under the terms of this license. All derivative works must be released under this license.

  An explanation and copy of the license are available.

Every single point in Legal is untrue for the installation-guide:

  1) The installation-guide is maintained by the installer team, not the documentation team, and has a different list of contributors mentioned in the "Major Contributors" section of the guide itself.
  2) The document is licensed under the GPLv2, not under CC-BY-SA (and must remain so since the vast majority of its content is owned by non-Ubuntu contributors who have not given permission to relicense). Yes, I know Legal says "unless stated otherwise", but I can entirely understand casual readers failing to notice that the guide is in fact under the GPL given this statement.
  3) While you are free to modify, extend, and improve the documentation, it's not under the licence stated on Legal, and derivative works may explicitly not be under CC-BY-SA.
  4) The links to the licence are not appropriate.

If Legal contained information that was relevant to the installation-guide, then it would make sense to retain this footer link and just make sure we flagged the bits that didn't apply. However, *none* of it applies. We should kill the link; the document already describes its own legal status perfectly well.

(The link to contributing isn't terribly applicable either, to be honest. I think it would be better to say "To report a problem, file a bug on the <a href="https://bugs.launchpad.net/ubuntu/+source/installation-guide/+filebug">Ubuntu installation-guide package</a>.")

Matthew East (mdke) wrote :

You're right, and thank you for posting to the Debian mailing list to clarify the position.

The "unless stated otherwise" was a fudge which arises out of the fact that in order to have a separate footer for just the installation-guide on help.ubuntu.com, quite a lot of extra fiddling is required.

I'll take care of it.

Changed in ubuntu-website:
assignee: nobody → mdke
importance: Undecided → Medium
status: New → Confirmed
Colin Watson (cjwatson) wrote :

Much appreciated, thanks!

Matthew East (mdke) wrote :

A fix has been committed to our help.ubuntu.com bzr branch. All that remains now is for the sysadmins to sync the server with the branch, I have an outstanding ticket for that.

The fix is at revisions 18 and 19 here:

https://code.launchpad.net/~mdke/ubuntu-doc/help.ubuntu.com

Changed in ubuntu-doc:
status: Confirmed → Fix Committed
Matthew East (mdke) wrote :

The fix has now been rolled out.

Changed in ubuntu-doc:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers