Broken link in hardware document

Bug #293842 reported by Matthew East on 2008-11-04
6
Affects Status Importance Assigned to Milestone
Ubuntu Documentation
Undecided
Unassigned
ubuntu-docs (Ubuntu)
Low
Unassigned

Bug Description

In the hardware document, there is a link to "ghelp:gnome-access-guide#sysadmin-37", which does not exist as a section in the current version of the gnome-access-guide. The link should be amended, or, if there is no appropriate target in the gnome-access-guide, removed.

Thomas M (thomas-r-martin) wrote :

I just wanted to make sure that everyone is looking at the same page. Where you are seeing the error, is it this page

https://help.ubuntu.com/8.04/hardware/C/input-devices.html#input-mice

The "Accessibility - Configuring Alternative Pointing Devices" link?

Matthew East (mdke) wrote :

thomas - that's correct.

Mark (mtod1) wrote :

I believe this bug is in the actual help documentation provided with the Ubuntu 8.10 installation. Not the website documentation. I have replicated this bug.

The section:
Accessibility - Configuring Alternative Pointing Devices

Clicking on this link results in the Ubuntu help file 'Ubuntu, Get Help with Ubuntu' closing with no warning.

Changed in ubuntu-doc:
status: New → Confirmed

On Tue, Feb 17, 2009 at 09:53, Mark <email address hidden> wrote:
> I believe this bug is in the actual help documentation provided with the
> Ubuntu 8.10 installation. Not the website documentation. I have
> replicated this bug.

Mark, the website documentation is generated from the help documentation.

Thomas M (thomas-r-martin) wrote :

Is there documentation about how the gnome documentation reference is stored
or how it is used? Are there config values that are stored somewhere? I've
tried altering the links, but have not been successful locally. Any
information would help.

Thanks,

Thomas M

On Tue, Feb 17, 2009 at 3:53 AM, Mark <email address hidden> wrote:

> I believe this bug is in the actual help documentation provided with the
> Ubuntu 8.10 installation. Not the website documentation. I have
> replicated this bug.
>
> The section:
> Accessibility - Configuring Alternative Pointing Devices
>
> Clicking on this link results in the Ubuntu help file 'Ubuntu, Get Help
> with Ubuntu' closing with no warning.
>
>
> ** Changed in: ubuntu-doc
> Status: New => Confirmed
>
> --
> Broken link in hardware document
> https://bugs.launchpad.net/bugs/293842
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Matthew East (mdke) wrote :

On Tue, Feb 17, 2009 at 3:20 PM, Thomas M <email address hidden> wrote:
> Is there documentation about how the gnome documentation reference is stored
> or how it is used? Are there config values that are stored somewhere? I've
> tried altering the links, but have not been successful locally. Any
> information would help.

I don't think there is any documentation of this, but the format is:

ghelp:documentname#section-id

You get the documentname bit from the directory name applicable to the
document which you see in /usr/share/gnome/help/

You get the section-id bit from the id of the section in the xml code.

--
Matthew East
http://www.mdke.org
gnupg pub 1024D/0E6B06FF

Thomas M (thomas-r-martin) wrote :

I've been doing some research in the gnome-docs around this issue and I think that this page needs to updated in general. So I am going to take it on, if there are any other bits of information that needs to be added or would like to be added send me an email or log it in the bug.

Changed in ubuntu-doc:
assignee: nobody → thomas-r-martin
Changed in ubuntu-doc:
assignee: thomas-r-martin → nobody
Artur Szymanski (arteek) wrote :

I think we should remove "Accessibility - Configuring Alternative Pointing Device" section from hardware.xml doc. This bug exist very long time, the changes in gnome-access-guide were made in 10.2007 (see http://bugzilla.gnome.org/show_bug.cgi?id=475110) and since then we still points to the obsoleted section.

I'm attaching proposed patch.

Matthew East (mdke) on 2009-05-07
tags: added: patch
Matthew East (mdke) wrote :

Moving bug to ubuntu-docs package as per our current policy.

Changed in ubuntu-docs (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in ubuntu-docs:
status: Confirmed → Invalid
Matthew East (mdke) wrote :

I've removed the relevant section entirely in our karmic branch, revision 349

Changed in ubuntu-docs (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 9.10.8

---------------
ubuntu-docs (9.10.8) karmic; urgency=low

  * General:
    - Refresh pot files
  * hardware.xml:
    - Update jockey instructions to reflect UI changes from some time ago (LP: #281143)
    - Remove link to deprecated section in accessibility guide (LP: #293842)
  * internet.xml:
    - Network manager network list no longer has radio buttons, Dean Sas
  * keeping-safe.xml:
    - Update firewall section, Connor Imes / bodhi.zazen (LP: #377039)
  * usb-creator.xml:
    - Add manual for usb-creator, new document by Augustina Blair
  * serverguide.xml:
    - Add additional information for configuring TLS with OpenLDAP and gnutls, PeterNSteinmetz (LP: #437483)

 -- Matthew East <email address hidden> Sun, 27 Sep 2009 17:26:16 +0100

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.