"build-essential" package documentation maybe partially wrong

Bug #1824740 reported by Néstor Llamas Llopis on 2019-04-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Documentation
Undecided
Unassigned

Bug Description

As I can see in the official documentation (https://help.ubuntu.com/community/InstallingCompilers), in order to install the package "build-essential" the execution of the commands below are needed:
$ sudo apt update
$ sudo apt upgrade
But I am wondering if the second one is in fact needed or not, as I think it is not related with the installation of this package. Or maybe the installation of the package updates ("upgrade" command) are needed because "build-essential" package depends on some of these other packages?

Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your report.

Yes, while the second command not may be *needed*, it's wise (in order to prevent dependency issues) to run it before installing new packages.

Please note that this is the bug tracker for the desktop documentation, not a support forum. If you have more question, please use one of the resources for the purpose.

https://community.ubuntu.com/t/finding-help/712

Changed in ubuntu-docs:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers