Hibernate option is missing from menu in 13.10 even after trying to re-enable

Bug #1232814 reported by Benjamin Tegge on 2013-09-29
468
This bug affects 95 people
Affects Status Importance Assigned to Milestone
Ubuntu Documentation
Undecided
Kevin Godby

Bug Description

Summary:

The issues stopped appearing from 2013-11-07 onwards. The menu is built correctly now, but it is unknown which version of an updated package from that timeframe actually fixed the menu issue.

The documentation needs to be updated with the instructions from the solution below to reenable hibernation in 13.10.

-----

Solution to reenable to hibernate menuentry:

File /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla needs to contain:

    [Re-enable hibernate by default in upower]
    Identity=unix-user:*
    Action=org.freedesktop.upower.hibernate
    ResultActive=yes

    [Re-enable hibernate by default in logind]
    Identity=unix-user:*
    Action=org.freedesktop.login1.hibernate
    ResultActive=yes

-----

I upgraded from raring to saucy on my notebook, where hibernate was enabled and working fine. Now the hibernate option is missing. I followed the instructions on how to reenable hibernate (https://help.ubuntu.com/13.10/ubuntu-help/power-hibernate.html) but the option is still missing. Hibernating from terminal via s2disk works.

File exists with proper content and permissions:
$ sudo ls -l /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla
-rw-r--r-- 1 root root 111 Sep 29 18:52 /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

$ sudo cat /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla
[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-session (Ubuntu):
status: New → Confirmed
Benjamin Tegge (livewirebt) wrote :

Dirty workaround:
1. install and configure uswsusp if you haven't already
2. backup pm-suspend (it's just a symlink to ../lib/pm-utils/bin/pm-action)
cp /usr/sbin/pm-suspend /usr/sbin/pm-suspend-bak
3. replace it with s2disk
cp /usr/sbin/s2disk /usr/sbin/pm-suspend

You can now hibernate with s2disk from the menu via suspend entry, but have no entry for actually bringing the system into suspend mode.

Shiraz Dindar (shiraz-v) wrote :

Wow, are there really only 5 of us?

Sergio Callegari (callegar) wrote :

No, we are six. But I do not think that it make much sense to report this as a bug. It is certainly a feature thought of by a usability committee.
In any case do not despair. Shortly they will realize that there are people like me with a stupid laptop that drains the battery in suspend mode and cannot hold it for more than a few hours. As soon as they see that there are cases where suspending instead of hibernating is a sure path to loose data, suspend will also be removed from the menus and any way to try to reactivate it will be made ineffective.
By the way, have you noticed how difficult it is to create issues to your hardware and OS when the machine is powered off? One wonders why users are still getting the possibility to switch it on... seems a silly way to allow them to look for trouble.

Igor (igor-iurkov) wrote :

Same problem with ubuntu 13.10, now hibernate option in menu is missing, but before in 13.04 it was.

Benjamin Tegge (livewirebt) wrote :

I tried to look through the source of the package last week, they moved some code around, but they didn't deliberately remove the hibernate option. It's still in the code but must be deactivated somewhere on lower levels. As far as I understood, without the polkit rule you wouldn't have permissions to do hibernation.

Benjamin Tegge (livewirebt) wrote :

I submitted a AskUbuntu question (http://askubuntu.com/questions/361734/hibernation-is-still-missing-from-menu-in-13-10-after-enabling-via-polkit-how-t). May be that will bring us closer to a solution. Remember hibernation is still working, it's just not displayed in the menu. This is not a conspiracy, calm down. If you need hibernate desperately and it has been working for you before try the workaround posted earlier.

Timo Palomaa (timppis) wrote :

I have also made a Askubuntu entry: http://askubuntu.com/questions/361058/

Alias for 'sudo pm-hibernate' is good enough for me now.

Pablo180 (paultait22) wrote :

Well it has taken, what 3 years, to get percentage displayed on the battery in the panel, so I am guessing that by 17.10 Ascetic Ass we'll have hibernate back, but we won't be able to Restart, Save Documents or connect to WiFi networks. But I am sure Ubuntu Touch will be approaching usable by then.

Timo Palomaa (timppis) wrote :

#9: I understand hiding the hibernate by default because there are simply so many hardware related problems with it. But this bug is not about that and this bug is most likely not intentional.

Sergio Callegari (callegar) wrote :

They just do not realize that there are exactly as many hardware related problems without hibernate.

Many machines use way to much power in suspend mode and drain the batteries. When the battery goes off, say after 8-20 hours, you loose data.

Pablo180 (paultait22) wrote :

#10 I can't understand how this isn't intentional, it was purposely removed before 12.04 was released, but there was a workaround to get it back in the menu, now oddly the ability to use that workaround has also been removed. Windows 8 also by default removes the hibernate option, but it is simple to add back.

As Sergio says, suspend is also problematic, I have lost count of the amount of times I have opened my bag to find my laptop has awakened from suspend in my bag and toasted away, not to mention the times when it flatly refuses to suspend at all and just resumes before I get out of my seat. Forcing me to either close down every application, make sure everything is saved and then shutdown, or hibernate. Then there is also the all too frequent problems of Compiz hanging or crashing when resuming from suspend, forcing a hard reset. Not to mention the problem Sergio points out of the device inexplicably losing power whilst in suspend mode.

I've always found suspend a far riskier option than hibernate.

Jeffery To (jefferyto) wrote :

For Saucy, indicator-session was updated to use logind (org.freedesktop.login1) instead of upower.

If you check /var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla, you'll see that hibernate is disabled by default in both upower and logind.

So the first step to re-enable the Hibernate option is to edit /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla to something like:

    [Re-enable hibernate by default in upower]
    Identity=unix-user:*
    Action=org.freedesktop.upower.hibernate
    ResultActive=yes

    [Re-enable hibernate by default in logind]
    Identity=unix-user:*
    Action=org.freedesktop.login1.hibernate
    ResultActive=yes

After rebooting, the login screen session menu should have a Hibernate option.

After logging in, the desktop session menu still doesn't have the Hibernate option. If I kill the indicator-session-service process and wait for it to be respawned, the menu will be updated with Hibernate.

I don't see anything obviously wrong in the indicator-session code, so I suspect this is a timing issue. My guess is the hibernate dbus (async) query hasn't returned a result yet when it first builds the desktop session menu.

(Another clue to indicator-session building menus too early: I have a Reboot option in my desktop session menu, even though I'm using Unity and the code should have hidden it. The Reboot option is gone after indicator-session-service is killed and respawned.)

I'll try to investigate more as time permits.

Benjamin Tegge (livewirebt) wrote :

Thank you Jeffrey! I just tried it on my laptop and it works fine. I have already put your solution as an answer to my AskUbuntu question, but if you want, you can add your answer and I will remove mine.

I think the only thing left now is an update to the official documentation.

affects: indicator-session (Ubuntu) → ubuntu-docs
description: updated
Changed in indicator-session (Ubuntu):
status: New → Invalid
Jeffery To (jefferyto) wrote :

Thanks Benjamin, though I don't think doing a killall on every login is a valid solution. I still consider this a bug in indicator-session.

Changed in indicator-session (Ubuntu):
status: Invalid → Confirmed
Sergio Callegari (callegar) wrote :

Not working here.

Cannot say if the lightdm login screen proposes hibernate since it proposes so many useless things (nexus 7 sessions????? On a laptop??? what for????) that the useful stuff goes out of the screen (and there is no way to scroll)

Certainly the normal user menu keeps not proposing hibernate.

killing indicator-session-service makes it respawn immediately, but still no hibernate option.

It is sad that this adds to tons of issues I've found with saucy in just 3 minutes:

- No hibernate
- Wifi not working most of the time unless you rfkill it and re-enable it (I think that it has to do with the window trying to bring it up in lightdm)
- When any indicator menu is open the application bar on the left does not stay open
- Bluetooth does not work anymore

...looks like going back 8 years with respect to the usual ubuntu standards.

Benjamin Tegge (livewirebt) wrote :

@Jeffery Sorry I thought it was persistent, now I see that it's not persistent across reboots.

description: updated
Sergio Callegari (callegar) wrote :

Also tried erasing the hibernate prevention stuff in /var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla.

Still cannot see the hibernate option in the user menu.

Sergio Callegari (callegar) wrote :

Weird querying CanHibernate with gdbus returns 'challenge' and not 'yes' as CanSuspend does. Any clue?

Shiraz Dindar (shiraz-v) wrote :

on a related note, to Sergio and anyone with heavy suspend battery use -- the not-actually-hybrid-suspend-mode is actually better than real-hybrid-suspend, and is easy to make work: http://www.webupd8.org/2012/11/how-to-use-hybrid-suspend-in-ubuntu.html.

It works in 13.10 regardless of the missing hibernate from indicator-session issue of this thread. I would consider it the best workaround for this bug in fact.

Sergio Callegari (callegar) wrote :

Hi,

1) Weird enough the method by Jeffery To, namely the editing of /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla to include the logind polkit authorization works in a kubuntu machine and is persistent here... So it fails on my ubuntu laptop but it works on my kubuntu laptop.

Here

gdbus call --system --dest org.freedesktop.login1 --object-path /org/freedesktop/login1 --method org.freedesktop.login1.Manager.CanHibernate

returns 'Yes', not 'Challenge' as on the Ubuntu machine.

2) to Shiraz Dindar. Thanks to the pointer to the not-actually-hybrid-suspend-mode. That's quite interesting! However, I'm a bit scared by it. I wonder what happens if I suspend and the laptop decides to switch on to hibernate, doing tons of disk activity, when I am on my Vespa on the infamous 'pavé' (sort of quite irregular stone surface) present in many Italian roads...

Shiraz Dindar (shiraz-v) wrote :

Ha, Sergio, something like that would never be a concern for me because I'm on an SSD (as everyone should be, by the way... nudge nudge), and though my impression is that vibrations on disk heads are generally an overstated concern, if it actually happened on a scooter on bumpy roads, well that would be an issue yes. If that's a realistic possibility of happening, yes, that's not much of a workaround for you -- unless of course you switched to an SSD.

Sean (scott-seanc) wrote :

jefferyto's workaround in #13 works on my Xubuntu system. Hibernate is avaible from the Session Menu without needing to kill indicator-session-service.

Hibernation is also availbale in the lightdm login screen ON FIRST BOOT only. If I return to the lighdm login screen when I log out of my session so that there are no active users then hibernate is not listed in the lightdm menu.

Benjamin Xiao (ben-r-xiao) wrote :

After applying the logind fix to /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla and doing a killall indicator-session-service, it still doesn't work. Hibernate does not appear and in fact the restart option goes away as well.

gdbus call --system --dest org.freedesktop.login1 --object-path /org/freedesktop/login1 --method org.freedesktop.login1.Manager.CanHibernate

returns

('challenge',)

Changed in ubuntu-docs:
status: Confirmed → In Progress
assignee: nobody → Svetlana Belkin (belkinsa)
Shiraz Dindar (shiraz-v) wrote :

Thank you Svetlana!

Daniel Fancsali (fancsali) wrote :

The same annoying bug here. Updated ta 13.10 yesterday, and previous .pkla has no effect anymore. Editing it, and restarting indicator-session-service fixes it. But doesn't persist between reboots...

The same that #26....

Raoul (raoul-29) wrote :

I agree with #15, the workaroung is not useable due to the killall. I have no issue with disabling hibernate by default but there should be a easy and permanent way of enabling it again.

Karma Dorje (taaroa) wrote :

the same that #26. please fix it.

Svetlana Belkin (belkinsa) wrote :

Are we talking about what to add in the wiki docs or this for the program itself? Can you guys please tell me what you are refering too. Thank you. If it's a doc thing, please tell me what to add to the page.

Benjamin Tegge (livewirebt) wrote :

Hello Svetlana, /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla needs to contain the following:

    [Re-enable hibernate by default in upower]
    Identity=unix-user:*
    Action=org.freedesktop.upower.hibernate
    ResultActive=yes

    [Re-enable hibernate by default in logind]
    Identity=unix-user:*
    Action=org.freedesktop.login1.hibernate
    ResultActive=yes

That's the part that should be updated on https://help.ubuntu.com/13.10/ubuntu-help/power-hibernate.html. I'm sorry that I didn't made myself more clear when I added the Ubuntu Documentation project to this bug.

You can safely ignore the other comments.

Paul Loughman (snowhog) wrote :

This 'bug' also affects me. Kubuntu 13.10 64-bit, kernel 3.11.0-13-generic, KDE 4.11.2.

The problem, as I see it, is that the files:

org.freedesktop.upower.hibernate
org.freedesktop.login1.hibernate

don't exist in /usr/share/polkit-1/actions/ and in fact, don't exist anywhere on my laptop, so how can /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla work without them? I'd think not, but...

I've followed the instructions in #13 and I have the Suspend to Disk in Leave options. I'm going to open several apps and use Suspend to Disk and then reboot afterwards and see if it works. I'm suspecting it wont. I'll report back.

Paul Loughman (snowhog) wrote :

Nope. I get Grub and KDM login. Once logged in to KDM, my desktop is empty -- it doesn't repopulate "as I had it" when I hibernated. What is interesting though, is that launching my browser (Chromium) it reports that it wasn't closed properly and do I want to restore the session. I ignore the message and click on the Home icon and I'm still logged into the forum (my Home page is a forum). Also, returning here via History, I'm also still logged in. That would tell me that the cookies were retained by the hibernate, but nothing else.

Changed in ubuntu-docs:
assignee: Svetlana Belkin (belkinsa) → nobody
status: In Progress → Confirmed
Raoul (raoul-29) wrote :

Hi Svetlana.

It is not a doc issue, but there seems to be an issue with indicator-session-service as pointed out in #13.

Benjamin Tegge (livewirebt) wrote :

@Raoul there is a documentation issue! Stop confusing people if you have nothing valuable to add and just hit the "affects me to" button. Thank you.

Donarsson (benjamin-schwarz) wrote :

Can someone confirm this bug still exists on a fully up-to date installation?

I just added the .pkla as described in comment #13 and rebooted the system. After that, I have the hibernate option available in the session-indicator menu both on the login screen and in the user session. The confirmation dialog for the power button also shows the option and in the power settings it is selectable as low battery action.
I did NOT have to kill indicator-session-service, everything just works. I rebooted and hibernated several times and everything works just fine.

So to me the bug seems to have resolved itself somehow, maybe a recent update fixed it.

Hi, I can confirm what was described in comment #36: after editing the .pkla file and rebooting I get a "Hibernate" option in the menu. However, I do not see this option in the login screen...

The updates I applied today are the following:
-liblightdm-gobject-1-0
-lightdm
-python-cupshelpers
-system-config-printer-common
-system-config-printer-gnome
-system-config-printer-udev

I guess the lightdm ones had something to do with this, although I am not sure why the hibernate option does not appear in the login screen, it only appears in the user session.
As said in #36, I did NOT have to kill indicator-session-service.

Bruno Nova (brunonova) wrote :

I also confirm that the hibernate option reappeared again after updating lightdm and liblightdm-gobject-1-0, and rebooting.
Haven't rebooted again though, so I don't know if it's permanent.

Shiraz Dindar (shiraz-v) wrote :

Confirmed #31 works without any kill indicator required after reboot.

Mika Laari (laari) wrote :

I too have now hibernate in the desktop session without killing any process. I had modified the .pkla file earlier as described in #13 and today after a reboot it finally works without any further tricks. I had used pm-hibernate successfully for the last 5 days, and at least yesterday I installed some updates.

After some updates yesterday I have the hibernate option after a reboot, too. That didn't work a few days ago.
But I'm missing in the system properties - power properties the option in the drop down menu "What happend when top [of the notebook] closed". There are still the options "standby" and "nothing". (Sorry, I have the German version, so may be there are other descriptions).
In 13.04. it was very comfortable just to close the top and the notebook goes to hibernate. I hope in 13.10. this would by possible again.

The hibernate option appear in the power menu, but after two or three times that hibernate my ultrabook (Asus Zenbook ux51vz) when i turn on the pc, the pc restart and i lose the previuos state of the hibrenation. This problem is very irritating and i hope that can be fix soon. Thanks

Benjamin Tegge (livewirebt) wrote :

To Bernd Kirchgäßner (kraemer1504) and Emiliano Fernández (fernandez-emiliano-r): Please file separate bug reports for your issues.

kashchey (in4pashchenko) wrote :

Guys, Just give up that stupid distro! All nnormal distros have hibernate that work fine!

erik (zierka) wrote :

So why is that documentation not updated after 2 months?

Shiraz Dindar (shiraz-v) wrote :

maybe because it's a free OS where people volunteer their time to work on it?

Benjamin Tegge (livewirebt) wrote :

@Shiraz You're suggesting that one of us should do the edit? I would have loved to do so, but I found out that I can't.

The status of this bug really gives the impression that no one cares about such bugs. This bug could have been closed a long time ago by just adding a few lines to the documentation and leave a note which commit or version already fixed the issue. I would love to see this bug closed, because that's why I spend time filing them: getting these issues resolved. If anyone knows how I can help, please let me know.

Shiraz Dindar (shiraz-v) wrote :

@Benjamin -- No that's not actually what I was suggesting, but if you want commit access to the documentation, and have demonstrated consistent support in the forums, then I suspect it wouldn't be hard to get if you go through the proper channels -- I don't know this for sure, as I'm not a Ubuntu developer in any way, but that's how open source projects of this magnitude typically work.

I appreciate that you filed this bug -- I was the first to sign on, and it was great to see other people sign on and eventually us all see a solution. I agree it would be good to see the documentation updated since it's such a minor job that remains for such a significant piece. I was just pointing out why this happens, and implying that it's better to encourage people that offer their time rather than criticize them, whenever possible.

Sebastien Bacher (seb128) wrote :

> The status of this bug really gives the impression that no one cares about such bugs.

Well, we do care but:

- there is a lot to do

- that bug concerns a non default option/a technical one, so it's not the most important item on the todolist

- the number of comments make it difficult to read (one needs to spend like an hour trying to understand what's going on)

What would be useful:

- update the bug description to be an accurate summary of the situation (it seems from recent comments that only the documentation needs updating? if the summary was reflecting what needs to be done and sparing people to have to read 48 verbose comments to figure that out it would help to get the item picked up and resolved)

- if you want to update the documentation and submit a merge request that would probably help to get the change in (https://code.launchpad.net/ubuntu-docs)

description: updated
Jeffery To (jefferyto) wrote :

I've submitted a merge request: https://code.launchpad.net/~jefferyto/ubuntu-docs/lp1232814/+merge/197782

Would it be helpful to submit one for Saucy as well, even though it's already released? I imagine any Saucy users wanting to enable hibernate will need to find this information somehow.

Sebastien Bacher (seb128) wrote :

> I've submitted a merge request: https://code.launchpad.net/~jefferyto/ubuntu-docs/lp1232814/+merge/197782

Thanks!

> Would it be helpful to submit one for Saucy as well

It can hurt, saucy is not a LTS and I'm not sure if we are going to have SRU updates of the documentation, but if we have that means the change would be rolled out (we can also make the case of doing a SRU for that change if it's judged important enough)

Donarsson (benjamin-schwarz) wrote :

Guys, can't we close this bug now that an update fixed it? No need for further discussion as I see it.

Shiraz Dindar (shiraz-v) wrote :

No, the update fixed it so that certain steps documented earlier in this ticket provides the hibernate option, but those steps need to be incorporated into the documentation before this ticket is closed.

Omkar Ekbote (dotbugfix) wrote :

I'm just curious here (and grinning after reading most of these comments) - I'm using the Gnome Shell and the TweakTool does show 'Hibernate' as an option in the 'Laptop lid close action' dropdown, but has the same behavior as suspend! What exactly did these guys do to brutally circumvent all attempts to Hibernate?!

Benjamin Tegge (livewirebt) wrote :

That looks like a bug in the corresponding gnome component. Please file a new bug report for that.

Timo Palomaa (timppis) wrote :

@54: Or hardware problem? Just guessing. Before filing a new bug, check what happens when you 'sudo pm-hibernate'.

Karma Dorje (taaroa) wrote :

@54: wow, I have another problem: on my laptop hibernate works in KDE, but does not work in Unity. 0_o

I found a workaround on ubuntu gnome 13.10: just install hibernate:

sudo apt-get install hibernate

The only problem is that apport will issue three errors when starting up after normal Power Off. For this you can disable apport:

sudo gedit /etc/default/apport

Then change enabled=0.

To change settings from hibernate edit files in /etc/hibernate.

Kevin Godby (godbyk) wrote :

I appreciate the patch, but I don't think this is suitable for the system documentation. In my view, the system documentation should document the software as it exists and not provide workarounds for design decisions.

If the Hibernate menu option appears in the future, I'll happily document it.

I'm going to mark this bug as invalid for the documentation project. If the menu option is added in the future, feel free to reopen this bug against the docs project.

Thanks!

Changed in ubuntu-docs:
status: Confirmed → Invalid
assignee: nobody → Kevin Godby (godbyk)
Marc Deslauriers (mdeslaur) wrote :

Kevin,

This patch is required to make the documented workaround work with newer releases. Either this change gets accepted, or the whole section needs to be taken out, but we shouldn't have it present and broken as it currently stands.

Kevin Godby (godbyk) wrote :

I've merged the patch to update the instructions in the documentation. Thanks!

Changed in ubuntu-docs:
status: Invalid → Fix Committed
Adolfo Jayme (fitojb) on 2014-01-19
no longer affects: indicator-session (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-docs (Ubuntu):
status: New → Confirmed
Adolfo Jayme (fitojb) on 2014-01-19
affects: indicator-session → ubuntu-docs (Ubuntu)
no longer affects: ubuntu-docs (Ubuntu)
Changed in ubuntu-docs:
status: Fix Committed → Fix Released

This issue is affecting also my ubuntu 14.04. I've tried some workarounds without luck (only on closing lid the computer hibernates).

The option in the menu have a appeared and disappeared after a couple of reboots.

Sorry for double posting. I have found a workaround for my machine. Adding all this content to the file /etc/polkit-1/localauthority/90-mandatory.d/com.ubuntu.enable-hibernate.pkla

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

[Re-enable hibernate multiple by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate-multiple-sessions
ResultActive=yes

Fixes my issue (apparently, having multiple users available on same machine needs to hibernate them even if they have not logged in)

Gunnar Hjalmarsson (gunnarhj) wrote :

Hi Cruz!

Please note that this bug report has been closed. Could you please file a new bug which suggests that addition?

Hello Gunnar!

I believe that the documentation issue is reported on this bug instead

https://bugs.launchpad.net/ubuntu/+source/ubuntu-docs/+bug/1279349

Should I file a new bug for this problem?

Thanks

Gunnar Hjalmarsson (gunnarhj) wrote :

2014-06-09 19:55, Cruz Fernandez skrev:
> I believe that the documentation issue is reported on this bug instead
>
> https://bugs.launchpad.net/ubuntu/+source/ubuntu-docs/+bug/1279349

That bug is marked as a duplicate of this one, and with that closed as well.

> Should I file a new bug for this problem?

Yes, it would be great if you could do that. As far as I understand, you now bring up a new aspect of the issue.

Done!

https://bugs.launchpad.net/ubuntu/+source/ubuntu-docs/+bug/1328227

hopefully it´s explained correctly

On Mon, Jun 9, 2014 at 3:24 PM, Gunnar Hjalmarsson <
<email address hidden>> wrote:

> 2014-06-09 19:55, Cruz Fernandez skrev:
> > I believe that the documentation issue is reported on this bug instead
> >
> > https://bugs.launchpad.net/ubuntu/+source/ubuntu-docs/+bug/1279349
>
> That bug is marked as a duplicate of this one, and with that closed as
> well.
>
> > Should I file a new bug for this problem?
>
> Yes, it would be great if you could do that. As far as I understand, you
> now bring up a new aspect of the issue.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1232814
>
> Title:
> Hibernate option is missing from menu in 13.10 even after trying to
> re-enable
>
> Status in Ubuntu Documentation:
> Fix Released
>
> Bug description:
> Summary:
>
> The issues stopped appearing from 2013-11-07 onwards. The menu is
> built correctly now, but it is unknown which version of an updated
> package from that timeframe actually fixed the menu issue.
>
> The documentation needs to be updated with the instructions from the
> solution below to reenable hibernation in 13.10.
>
> -----
>
> Solution to reenable to hibernate menuentry:
>
> File /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-
> hibernate.pkla needs to contain:
>
> [Re-enable hibernate by default in upower]
> Identity=unix-user:*
> Action=org.freedesktop.upower.hibernate
> ResultActive=yes
>
> [Re-enable hibernate by default in logind]
> Identity=unix-user:*
> Action=org.freedesktop.login1.hibernate
> ResultActive=yes
>
> -----
>
>
> I upgraded from raring to saucy on my notebook, where hibernate was
> enabled and working fine. Now the hibernate option is missing. I followed
> the instructions on how to reenable hibernate (
> https://help.ubuntu.com/13.10/ubuntu-help/power-hibernate.html) but the
> option is still missing. Hibernating from terminal via s2disk works.
>
> File exists with proper content and permissions:
> $ sudo ls -l
> /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla
> -rw-r--r-- 1 root root 111 Sep 29 18:52
> /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla
>
> $ sudo cat
> /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla
> [Re-enable hibernate by default]
> Identity=unix-user:*
> Action=org.freedesktop.upower.hibernate
> ResultActive=yes
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-docs/+bug/1232814/+subscriptions
>

--
X

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers