"Official Installation Guide" should be included to h.u.c.

Bug #114266 reported by towsonu2003
6
Affects Status Importance Assigned to Milestone
Ubuntu Documentation
Fix Released
Medium
Unassigned

Bug Description

The h.u.c. main page shows the following:

* New to Ubuntu 7.04?
* Adding and Removing Software
* Files, Folders and Documents
* Customising Your Desktop
* Internet
* Music, Video and Photos
* Keeping Your Computer Safe
* Printing and Faxing
* Advanced Topics

A new item: * Installation
should be included.This page can say the following:

1. Obtain Ubuntu (link to https://help.ubuntu.com/community/GettingUbuntu )
2. If you downloaded a CD image, burn it to a CD (links to https://help.ubuntu.com/community/BurningIsoHowto and https://help.ubuntu.com/community/BootFromCD )
3. Install Ubuntu by booting from the installation CD ( link to https://help.ubuntu.com/community/GraphicalInstall )
For more information, see: https://help.ubuntu.com/community/Installation

I took the text from https://help.ubuntu.com/community/Installation . It's weird that h.u.c isn't giving a direct link to any installation help files :) I reported this after reading this email https://lists.ubuntu.com/archives/ubuntu-doc/2007-May/008513.html

thanks

Revision history for this message
Matthew Paul Thomas (mpt) wrote :

<https://help.ubuntu.com/> currently reflects the front page of the offline Ubuntu Help Center, which doesn't include installation instructions because it's targeted at people who have already installed Ubuntu. This is an example of a case where help.ubuntu.com and the Ubuntu Help Center should be different.

Changed in ubuntu-doc:
status: Unconfirmed → Confirmed
Revision history for this message
Matthew East (mdke) wrote :

This would be easy to fix if we integrated the online version of the system documents with the help wiki, which contains installation instructions. I really hope that we can do that within a release cycle or so.

Changed in ubuntu-doc:
importance: Undecided → Medium
Revision history for this message
Phil Bull (philbull) wrote :

How were you thinking of doing the integration? Wiki-fying the system docs?

Revision history for this message
Matthew East (mdke) wrote : Re: [Bug 114266] Re: "Installing" should be included to h.u.c.

On 21/08/07, Phil Bull <email address hidden> wrote:
> How were you thinking of doing the integration? Wiki-fying the system
> docs?

Yes: but we need to have a clear way of telling people how reliable
different pages and what versions they apply to
(https://wiki.ubuntu.com/HelpWikiQualityAssurance), as well as
technology for wikifying the docs and a clear idea of where to put
them structure wise!
--
Matthew East
http://www.mdke.org
gnupg pub 1024D/0E6B06FF

Revision history for this message
Phil Bull (philbull) wrote : Re: "Installing" should be included to h.u.c.

We could probably implement most of this *today* using includes. While not ideal, it should work OK and I concede that it'll be less work than writing our own macros...

 1. Create a new 'Tag' wiki page and have the following sub-pages: Tag/SystemDoc, Tag/CommunityDoc, Tag/Unreviewed, Tag/Cleanup
 2. Create a new 'Version' wiki page and have these sub-pages: Version/Feisty, Version/Gutsy etc.
 3. Include these Tag and Version pages where appropriate (see https://wiki.ubuntu.com/Philbull/Test for an example)

An upshot of this approach is that we should be able to search for '[[Include(Tag/SystemDoc' and have all of the pages with that tag appear. Note that we have to miss off the last bracket of the search string because of the way Moin parses it. See https://wiki.ubuntu.com/Philbull, section 'Testing' at the bottom, for an example. We'd need to protect the Tag and Version pages from edits, too.

As for structure, just stick the whole ubuntu-doc tree under Official/$RELEASE or maybe just $RELEASE/. For example, internet.xml would be found at https://help.ubuntu.com/community/Official/Gutsy/Internet. This has the advantage of fully containing all of the system docs and handling different versions gracefully, which should make it easier to maintain or push updates. The path is also quite meaningful, so a Dapper user stumbling on Official/Gutsy/Internet could just edit the URL to be Official/Dapper/Internet.

What do you think?

Revision history for this message
Matthew East (mdke) wrote : Re: [Bug 114266] Re: "Installing" should be included to h.u.c.

Hiya,

On 21/08/07, Phil Bull <email address hidden> wrote:
> We could probably implement most of this *today* using includes. While
> not ideal, it should work OK and I concede that it'll be less work than
> writing our own macros...

Sure, even if we need to slightly modify the behaviour of the Include
macro we can easily do so.

> An upshot of this approach is that we should be able to search for
> '[[Include(Tag/SystemDoc' and have all of the pages with that tag
> appear. Note that we have to miss off the last bracket of the search
> string because of the way Moin parses it. See
> https://wiki.ubuntu.com/Philbull, section 'Testing' at the bottom, for
> an example. We'd need to protect the Tag and Version pages from edits,
> too.

Cool, thanks for investigating this. We should consider carefully the
various categories, and then maybe we can start implementing some of
this.

> As for structure, just stick the whole ubuntu-doc tree under
> Official/$RELEASE or maybe just $RELEASE/. For example, internet.xml
> would be found at
> https://help.ubuntu.com/community/Official/Gutsy/Internet.

I don't think that is going to work. Apart from anything else, the
whole point of merging the two is so that the user doesn't have to do
battle with different information on the same topic; if we are going
to move the system docs into the wikispace I really think we need to
make an effort to eliminate overlap and do a proper merge.

However, as you point out, that may be hell to maintain unless we
elaborate a good way to do that.

We'll also have to overcome the technical issue of converting the
material to the wiki markup (in particular, the main problem there is
going to be how to control chunking so that it's possible to convert a
single docbook document to a number of wiki pages or a single wiki
page as appropriate).

--
Matthew East
http://www.mdke.org
gnupg pub 1024D/0E6B06FF

Revision history for this message
Phil Bull (philbull) wrote : Re: "Installing" should be included to h.u.c.

I see your point. However, I think it will be difficult to merge the wiki and system docs and still handle different releases nicely. These are the options, as I see it:

 1. Have separate root directories for each release (Gutsy/Internet)
 2. Have sub-pages off each topic for older releases (Internet/Gutsy)
 3. Merge each release's version of a document into one big document and somehow allow the user to filter out other releases
 4. Have a separate wiki for each release (!)

Other than that, we could have a sort of hybrid system - a different wiki homepage for each release, then have release-specific category pages off that homepage which link to release-specific and non-release-specific information as appropriate, e.g.:

GutsyHome
    GutsyHome/Internet
        UsingNetworkManagerInGutsy
        InstallingFirewallInAnyRelease
    GutsyHome/Blah
DapperHome
    DapperHome/Internet
        UsingNetworkSettingsInDapper
        InstallingFirewallInAnyRelease
    DapperHome/Blah

(hope this makes sense)

Revision history for this message
Duncan Lithgow (duncan-lithgow) wrote :

I don't know when this was released or why we didn't find it - but here is the official installation guide for Ubuntu 8.04 LTS: https://help.ubuntu.com/8.04/installation-guide/i386/index.html

Revision history for this message
Matthew East (mdke) wrote : Re: [Bug 114266] Re: "Official Installation Guide" should be included to h.u.c.

On Wed, Jul 23, 2008 at 11:05 AM, Duncan Lithgow <email address hidden> wrote:
> I don't know when this was released or why we didn't find it - but here
> is the official installation guide for Ubuntu 8.04 LTS:
> https://help.ubuntu.com/8.04/installation-guide/i386/index.html

Right, but that is only for the alternative cd, not the desktop cd.

--
Matthew East
http://www.mdke.org
gnupg pub 1024D/0E6B06FF

Revision history for this message
jscc88 (jscc88-deactivatedaccount) wrote :

in the new version this problem dont be

Changed in ubuntu-doc:
assignee: nobody → sebastiancobaleda
status: Confirmed → Fix Released
Revision history for this message
Julian Alarcon (julian-alarcon) wrote :

The user Juan Sebastian Cobaleda Cano is a troll, or something. We, in the Ubuntu-Co Team are checking all his changes in Launchpad. Sorry for the problems.

Changed in ubuntu-doc:
assignee: sebastiancobaleda → nobody
status: Fix Released → Confirmed
Revision history for this message
Matthew East (mdke) wrote :

In the latest version of help.ubuntu.com this problem is fixed by the inclusion of an "Installing Ubuntu" page which links both to the desktop and alternate CD installation documents.

Changed in ubuntu-doc:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers