help.ubuntu.com search returns no results in Chrome

Bug #1044714 reported by Matthew Paul Thomas
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Documentation
Invalid
Undecided
Unassigned
ubuntu-docs (Ubuntu)
Fix Released
High
Unassigned

Bug Description

1. In Chrome, go to <http://help.ubuntu.com/>.
2. Search for anything that has results (e.g. "grub").

What happens: You get a page saying "Search Results", but no results.

What should happen: Search results.

The same problem does not happen in Firefox or other browsers.

Related branches

Revision history for this message
Matthew Paul Thomas (mpt) wrote :
visibility: private → public
Revision history for this message
Anthony Dillon (ya-bo-ng) wrote :

I believe this is due to importing a insecure JavaScript file onto the search page. Chrome has recently been updated to block insecure content loading on a https site.

I will talk to the guy that runs the site to get the import changed to a secure import.

Thank you for bring this to our attention.
Ant.

Changed in ubuntu-website-content:
assignee: nobody → Anthony Dillon (ya-bo-ng)
status: New → In Progress
affects: ubuntu-website-content → ubuntu-docs
Changed in ubuntu-docs:
assignee: Anthony Dillon (ya-bo-ng) → nobody
status: In Progress → Confirmed
Revision history for this message
Matthew East (mdke) wrote :

The ubuntu-docs project is not configured for bugs so I am moving the bug to the correct task and closing this task.

Changed in ubuntu-docs (Ubuntu):
status: New → Confirmed
assignee: nobody → Matthew East (mdke)
importance: Undecided → High
Changed in ubuntu-docs:
status: Confirmed → Invalid
Revision history for this message
Matthew East (mdke) wrote :

This has been fixed in revision 78 of the help.ubuntu.com branch by Jeremy Bicha:

https://code.launchpad.net/~ubuntu-core-doc/ubuntu-docs/help.ubuntu.com

I'm closing the bug but please do test and report back if there are any issues.

Thanks

Changed in ubuntu-docs (Ubuntu):
status: Confirmed → Fix Released
assignee: Matthew East (mdke) → nobody
Revision history for this message
Jeremy Bicha (jbicha) wrote :

I think this code might be problematic:

http://git.gnome.org/browse/yelp-xsl/tree/js/jquery.syntax.core.js#n221

GNOME's online help at library.gnome.org is only accessible via http not https. I just added a line to our html build script to change http://www.google.com URLS to https. Anyone who is duplicating our help on their site (LoCo's for instance) on non-https sites will likely want to remove that line from html/fix-urls.sed.

Revision history for this message
Doug Smythies (dsmythies) wrote :

See also bug 1211375

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.