Cyrillic font issues

Bug #494569 reported by Kyle Nitzsche
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Desktop Course
Fix Released
Undecided
Kyle Nitzsche

Bug Description

Native Russian speakers report inadequate Cyrillic in the ttf-liberation font.

Russian speakers: please provide details.

Related branches

Changed in ubuntu-desktop-course:
assignee: nobody → Kyle Nitzsche (knitzsche)
Revision history for this message
Anton Gladky (gladky-anton) wrote :

Hello, Kyle.

All those letters are really Cyrillic. But the problem is that they are not in a correct order. It is impossible to read any word. For example, the first large word on an attached screenshot should look like 'Содержание'.

Also interesting fact is, that when I copy text from PDF-file into the buffer and then paste it somewhere, I get the normal Russian text.

Thank you for fixing that.

Revision history for this message
Anton Gladky (gladky-anton) wrote :
Revision history for this message
Kyle Nitzsche (knitzsche) wrote :

Hi Anton,

Does the problem exist throughout the whole pdf, or is it just in the table of contents?

Revision history for this message
Anton Gladky (gladky-anton) wrote : Re: [Bug 494569] Re: Cyrillic font issues

The problem is in the whole text, the content is just like an example.
______________________________
[ENG] Best Regards
[GER] Mit freundlichen Grüßen
[RUS] С наилучшими пожеланиями
[UKR] З найкращими побажаннями

Anton Gladkyy

2009/12/9 Kyle Nitzsche <email address hidden>

> Hi Anton,
>
> Does the problem exist throughout the whole pdf, or is it just in the
> table of contents?
>
> --
> Cyrillic font issues
> https://bugs.launchpad.net/bugs/494569
> You received this bug notification because you are a member of Russian
> Translators Ubuntu Desktop Course, which is subscribed to Ubuntu Desktop
> Course.
>
> Status in Ubuntu Desktop Course: New
>
> Bug description:
> Native Russian speakers report inadequate Cyrillic in the ttf-liberation
> font.
>
> Russian speakers: please provide details.
>
>
>

Revision history for this message
Kyle Nitzsche (knitzsche) wrote :

This points to a probable error in the apache font configuration xml files for liberation. I've tried a fix locally, but since I cannot read Russian, I am not sure if it is correct Anton, can you please review the attachment and comment here whether it is correct?

Revision history for this message
Anton Gladky (gladky-anton) wrote :

Yes, that is excellent!
I did not check all the text, but I think it is ok!

Thank you

2009/12/9 Kyle Nitzsche <email address hidden>

> This points to a probable error in the apache font configuration xml
> files for liberation. I've tried a fix locally, but since I cannot read
> Russian, I am not sure if it is correct Anton, can you please review the
> attachment and comment here whether it is correct?
>
> ** Attachment added: "desktop-course-book.pdf"
> http://launchpadlibrarian.net/36638198/desktop-course-book.pdf
>
> --
> Cyrillic font issues
> https://bugs.launchpad.net/bugs/494569
> You received this bug notification because you are a member of Russian
> Translators Ubuntu Desktop Course, which is subscribed to Ubuntu Desktop
> Course.
>
> Status in Ubuntu Desktop Course: New
>
> Bug description:
> Native Russian speakers report inadequate Cyrillic in the ttf-liberation
> font.
>
> Russian speakers: please provide details.
>
>
>

Revision history for this message
Ivan Shakuta (tyler-ivan) wrote :

at the first look - it seems all is ok now - characters are correct
and words too, I'm native Russian speaker.
but it's better for someone else to review it like Anton, for confirmation.

2009/12/9 Kyle Nitzsche <email address hidden>:
> This points to a probable error in the apache font configuration xml
> files for liberation. I've tried a fix locally, but since I cannot read
> Russian, I am not sure if it is correct Anton, can you please review the
> attachment and comment here whether it is correct?
>
> ** Attachment added: "desktop-course-book.pdf"
>   http://launchpadlibrarian.net/36638198/desktop-course-book.pdf
>
> --
> Cyrillic font issues
> https://bugs.launchpad.net/bugs/494569
> You received this bug notification because you are a member of Russian
> Translators Ubuntu Desktop Course, which is subscribed to Ubuntu Desktop
> Course.
>
> Status in Ubuntu Desktop Course: New
>
> Bug description:
> Native Russian speakers report inadequate Cyrillic in the ttf-liberation font.
>
> Russian speakers: please provide details.
>
>
>

Revision history for this message
Kyle Nitzsche (knitzsche) wrote :

I pushed lp:ubuntu-desktop-course/fixes-cyrillic-bug-494569
to fix this bug. will now do merge proposal.

Revision history for this message
Vladimir Sharshov (vsharshov) wrote :

Thank you, Kyle. We made a merge proposal.

2009/12/10 Kyle Nitzsche <email address hidden>

> I pushed lp:ubuntu-desktop-course/fixes-cyrillic-bug-494569
> to fix this bug. will now do merge proposal.
>
> --
> Cyrillic font issues
> https://bugs.launchpad.net/bugs/494569
> You received this bug notification because you are a member of Russian
> Translators Ubuntu Desktop Course, which is subscribed to Ubuntu Desktop
> Course.
>

Revision history for this message
Torsten Spindler (tspindler) wrote :

On Wed, 2009-12-09 at 22:00 +0000, Kyle Nitzsche wrote:
> I pushed lp:ubuntu-desktop-course/fixes-cyrillic-bug-494569
> to fix this bug. will now do merge proposal.

Merged to lp:ubuntu-desktop-course, revision 184.

Changed in ubuntu-desktop-course:
status: New → Fix Released
Revision history for this message
Anton Gladky (gladky-anton) wrote :

Thank you!

I have just tested, the russian PDF builds excellently!

Will try to import Russian screenshots soon.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers