Ubuntu community unknowingly endorses proprietary development methods

Bug #393596 reported by Feathertail on 2009-06-29
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-community
Undecided
Karl Fogel

Bug Description

Many people in the Ubuntu community are passionate about the benefits of Free / Open-Source Software. Ubuntu itself is an almost completely free operating system, which de-emphasizes the proprietary software packages that it redistributes and clearly labels them as such. The Ubuntu.com homepage contains outreach information which claims that "Our work is driven by a philosophy on software freedom." And individual Ubuntu CDs distributed via ShipIt also promote the benefits of Free / Open-Source Software, and encourage people to "Pass it on!"

Ubuntu itself, however, is developed using proprietary technologies. While Launchpad components are becoming licensed under Free / Open-Source licenses, the Soyuz and Codehosting components remain proprietary, and Mark Shuttleworth has explained that there is "a line beyond which we will not publish code." ( http://blog.launchpad.net/podcast/launchpod-15-launchpads-going-open-source#comment-26049 ) In other words, the tools used to develop Ubuntu will never be free for others to use and improve on, whether other Free / Open-Source Software projects (which could benefit from Launchpad tools) or Ubuntu Community members (who could help to improve the tools used).

This becomes a problem for the Ubuntu Community, because of the outreach materials that promote sharing and using Free / Open-Source Software. An Ubuntu Community member who finds out about the proprietary development tools that are used might reasonably ask "If Free / Open-Source Software has so many practical benefits, and is a part of the Ubuntu Philosophy, then why is Canonical using proprietary development tools?" She might also reasonably ask "What are the long-term consequences of promoting technologies which only benefit one distro and its derivatives?" and "Why wasn't it made clear to me sooner that spreading Ubuntu enriches one group of people at the expense of others -- a group which does not plan on sharing its tools even with its own community members?"

These questions, and the corresponding emotional distress and internal conflict, could be alleviated with one simple bugfix.

Current behavior:

1. Ubuntu is developed using proprietary, closed-source development tools.

2. The Ubuntu.com home page, and other marketing material, explains the benefits of Free / Open-Source Software in both practical and philosophical terms.

3. Ubuntu Community members are unaware that they are supporting a community operating system which is developed using proprietary technologies, in contradiction of the spirit of point 1 of the Ubuntu Philosophy, because nobody is telling them up-front.

Expected behavior:

1. All Launchpad components are licensed under the GPL or a compatible Free / Open-Source license, thus bringing Canonical's actual behavior in line with its expected behavior.

2. Failing that, Canonical's expeced behavior is brought in line with their actual behavior. The statements of philosophy on Ubuntu.com reflect Canonical's unwillingness to license the tools used to make Ubuntu under a Free / Open-Source license. The statements explain the reasoning behind this unwillingness, and the reason why it was not already clearly and publicly announced within its own marketing material.

3. An announcement is made of this statement, and is publicized in the Ubuntu Weekly News and on the Ubuntu Forums.

4. Ubuntu Community members are aware that Ubuntu evangelism is less about sharing Free Software with others, and more about promoting Canonical, Ltd.'s commercial ventures, which cannot be duplicated by others due to their reliance on non-free software.

5. Ubuntu Community members (and potential new users of Ubuntu) who are displeased by this situation are helped to find other Free Software operating systems, which are more in line with their practical and philosophical requirements.

description: updated
description: updated
Karl Fogel (kfogel) wrote :

Canonical is a business and can't be expected to openly discuss all the factors behind the decision it makes; I wish it were otherwise, but it simply cannot be. We can explain the results of those discussions in general terms, of course, and have done so, at http://dev.launchpad.net/OpenSourcing and on the aforementioned blog post. Filing this bug report doesn't materially change that discussion (which was already going on in those other forums); it just changes the format :-). Ubuntu is just as Free as it has always been.

I think that it would be useful to the Ubuntu Community if more of its members were aware of the discussion. As it is, many of them feel they are part of a social movement which promotes equality and benefits everyone, as opposed to an exclusive profit-making endeavor.

I recall Mr. Shuttleworth saying he felt that the ascendancy of Free / Open-Source Software was inevitable, and that he wanted Canonical to be best positioned to take advantage of that. Perhaps a bug should be filed against Canonical's methods as well as their portrayal to the Community.

Randall Ross (randall) wrote :

Other possible approaches to address this issue (not necessarily mutually exclusive or practical, but rather as a thought experiment):

1) Defer this bug and fix it later, only after Bug #1 has been fixed,

2) Change the charter of Canonical to that of "non-profit", all surplus funds (after salaries and expenses) being reinvested in the Free Software Foundation (or similar organization, or group of organizations),

3) Publish a clear road-map and timeline on when/how tools will be GPL'd, easing community concerns about the "end-game",

4) Divestment. Canonical turns all of Ubuntu (technologies, trademarks, etc.) over to the community and sole focus becomes business (for profit).

I personally think Bug #1 should be marked non-critical, invalid or the equivalent. Either way, though, the time for a discussion is now, not later on when the new Bug #1 is that a certain _other_ proprietary software company has a majority market share.

Whatever solution is implemented, there should be more community awareness and discussion of this matter. That's actually what this bug is -- not that Canonical uses questionable methods / duplicitous advertising, but that fewer people are aware of it. rrnwexec's proposed fixes may be very good solutions to the former, but they cannot be implemented until the latter is fixed ... preferably by Canonical itself, since they're in the best position to do so, but I understand that they have other bugs to fix as well. So this may be a problem that's best tackled by the Ubuntu Community itself.

I proposed a few ideas for how Canonical could fix this bug, but any suggestions for what the Ubuntu Community could do might help as well.

jaduncan (jaduncan) wrote :

http://blog.launchpad.net/general/launchpad-is-now-open-source

This is fixed, complete with Soyuz and Codehosting components.

Changed in ubuntu-community:
assignee: nobody → jaduncan (jaduncan)
status: New → Fix Released
Matt Zimmerman (mdz) wrote :

Well done, Karl!

Changed in ubuntu-community:
assignee: jaduncan (jaduncan) → Karl Fogel (kfogel)
Paul Sladen (sladen) wrote :

Time-based releases rock. Congratulations on hitting the date to the day!

Wow. I'm pretty sure I didn't expect this! Congrats to all!

Maybe I should file a bug against Ubuntu One when it comes out later this year? I'll do it if it gets us the same results!

vamega (vamega) on 2010-08-12
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers