Ubuntu Community Web Themes

light-drupal-theme contains hardcoded resources

Reported by Chris Jones on 2010-11-25
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Community Web Themes
Undecided
Unassigned
Light-drupal-theme
Undecided
Michael Lustfield
Ubuntu Website
Undecided
Richard Henry Lee
ubuntu-website-content
Medium
Richard Henry Lee

Bug Description

The theme in light-drupal-theme contains several resource references to static external URLs:

template.php: $css = '<link rel="stylesheet" type="text/css" href="http://edge.launchpad.net/ubuntu-drupal-theme/trademark/6.7.0/+download/trademark.css" />' . PHP_EOL;
template.php: $css = '<link rel="stylesheet" type="text/css" href="http://edge.launchpad.net/ubuntu-drupal-theme/trademark/6.7.0/+download/trademark-rtl.css" />' . PHP_EOL;

Andrew Glen-Young (aglenyoung) wrote :

I think what Chris is saying:

There should not be any links in this theme pointing to external resources. The resources should all be included within the theme. This is particularly important when a server is behind a firewall with restricted access to external networks.

Changed in ubuntu-website:
assignee: nobody → Richard Henry Lee (rhlee)
Changed in ubuntu-website-content:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Richard Henry Lee (rhlee)
Changed in ubuntu-website:
status: New → Confirmed
Chris Johnston (cjohnston) wrote :

Richard and Alejandra, is this theme used by Canonical or strictly just the community? I'm not sure if this is a valid bug for ubuntu-website-content as it is a community supported theme.

Changed in ubuntu-community-webthemes:
status: New → Confirmed
tags: added: drupal

We are relying on external resources because some things are provided by the community theme that are not exactly GPLv2 compliant. The project that is building the drupal version of this theme (lp:ubuntu-drupal-theme) has every intention of keeping the code we produce compliant with GPLv2 so that it we can keep the final product hosted on drupal.org which is where the final product of our work winds up. The resources that are referred to are not GPLv2 compliant. Things like the Ubuntu logo are included in the light-base theme but we are not able to actually upload that to drupal.org. This is the same with the custom css. In this particular case, we are talking about the CSS. This CSS uses a color scheme that has basically been trademarked by Canonical.

This means that including this CSS is not acceptable if the code hosted needs to be GPLv2 compliant. In bug 688289, we are working on a method to download that file if the site admin wants to use the trademarks colors.

I do agree that this bug is valid because it should not regularly request the outside resource. However, we will not be including this trademarked code with the ubuntu-drupal-theme source. We will also not condone its addition in the light-drupal-theme source. Remember.. It's only because the ubuntu-community-webthemes came into existance that this resource exists at all.

To the extent this will be solved, it has been. If the user chooses to use the Ubuntu/Canonical trademarked stuff, then external resources will be used. The CSS file will be downloaded as it exists on Launchpad. It will then be server locally. This particular CSS file uses resources that are also trademarked but references them only from inside that file.

I'm unable to see a more optimal solution to this. (Thanks to Pierre Buyle for the amazing patch.) I will push the resolution into target branches after a few more patches and proper QA.

Changed in ubuntu-website:
status: Confirmed → Invalid
Changed in ubuntu-community-webthemes:
status: Confirmed → Fix Committed
Changed in ubuntu-website-content:
status: Triaged → Fix Released
Chris Jones (cmsj) wrote :

Chris: I don't believe we are using this theme ourselves - I filed this bug because we have had requests for the theme to be deployed on our community servers, but I blocked it since it abuses launchpad as a CDN.
I can't speak for <email address hidden>, but I don't think using Launchpad in this way is appropriate under any circumstances (and I note that the css file referred to also includes images from a third host, s.ubuntu.ru).

The theme is not using LP as a CDN but rather as a resource for
obtaining content to be delivered that is not permitted to be stored
on drupal.org based on the Canonical trademark policy. I used
s.ubuntu.ru because I didn't know of any other resource for this. You
are right - the theme is using that as a CDN and I agree that it
shouldn't be. Perhaps we could bundle this all into a download from
LP. Either that or I could just rip out that entire feature...

I'll be honest- I don't really care what you decide at this point. The
trademark stuff can't be delivered with the theme though unless you
want the content entirely banned from drupal.org. Tell me what you
want and I'll see about getting it done.

On Tue, Jun 14, 2011 at 5:55 AM, Chris Jones <email address hidden> wrote:
> Chris: I don't believe we are using this theme ourselves - I filed this bug because we have had requests for the theme to be deployed on our community servers, but I blocked it since it abuses launchpad as a CDN.
> I can't speak for <email address hidden>, but I don't think using Launchpad in this way is appropriate under any circumstances (and I note that the css file referred to also includes images from a third host, s.ubuntu.ru).
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/681596
>
> Title:
>  light-drupal-theme contains hardcoded resources
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-community-webthemes/+bug/681596/+subscriptions
>

--
Michael Lustfield
Ubuntu Member / Nginx Developer

"Storms make the oak grow deeper roots." ~ Herbert, George

Chris Jones (cmsj) wrote :

It sounds like a discussion needs to be had about this, probably in the Community Council. I can't speak for Canonical trademark policy, I am just able to suggest that relying on Launchpad's code browsing features as a way to serve CSS, is a bad idea.
There must be a solution waiting to be found that gets the community the theme resources they need, in a way that lets them use the hosting platforms most suitable to them :)

Matthew East (mdke) wrote :

I've read Michael's explanation above, but I don't really understand the problem here, and I think it needs better explanation.

I'm struggling to understand how trademarks have anything to do with GPL compliance. The GPL deals with copyright, and not trademarks. There is no problem using a trademark in GPL code - if there were then it would not be possible to use trademarked words such as "Ubuntu", "Linux" or "drupal" in GPL licensed code.

It may be that I'm misunderstanding the problem. Can someone explain more carefully what the problem is?

Matthew East (mdke) wrote :

Another question I'm struggling with is also why the code needs to be stored on any external site (whether drupal.org, launchpad or ubuntu.ru). Why is all relevant css not contained within the theme?

Chris Johnston (cjohnston) wrote :

People want the code on drupal.org, wordpress.org, etc. The problem comes in, in my understanding, where you can't put trademarked stuff onto the drupal.org site. So, to get around that, the "trademarked stuff" isn't hosted on the drupal.org site. It is hosted elsewhere and referenced.

Matthew East (mdke) wrote :

Before we get into a discussion about why it is more important to have an Ubuntu theme on drupal.org than it is to have it designed properly for use by Ubuntu itself, can we have a reference to where the rule that "you can't put trademarked stuff onto the drupal.org site" comes from? It sounds like a very strange requirement, because as I said, very many things are "trademarked".

Just doing a brief search, I could only find the opposite answer (http://groups.drupal.org/node/152509).

Matthew Nuzum (newz) wrote :

I think that comment comes from our historical policy that we'd like to avoid clone sites that look like official Ubuntu sites but aren't.

I agree with mdke. First, get the theme working correctly for our use, then share it.

One way to do what is desired with Drupal is to create a sub-theme that includes the Ubuntu branding and inherits from a base-theme that is shared publicly. No hacks needed. Don't know if a similar solution exists for wordpress, but even if not then a more elegant solution may be an Ubuntu only patch that includes the necessary assets.

Mark Shuttleworth (sabdfl) wrote :

There are two separate issues here that we need to untangle.

First, the legalities. Trademarks and GPL compliance are completely separate; you can have a GPL work which contains trademarked material and is thus constrained in who can use it and for what purpose. It would be perfectly fine to host at drupal.org or wordpress.org GPL themes which are based on Ubuntu trademarks and trade dress and thus are only appropriate for use by people who are part of the Ubuntu community and have trademark approval for the use.

Second, there's the practical issue of consistency. We've been trying to arrange for some common CSS used across all Ubuntu web properties, so that tweaks can be applied cleanly. For example, when there's a new version of the font that we want to use for titles, we could modify the styling of h1-n and have that change appear across all Ubuntu sites. I don't know the status on that initiative but I assume Matt Nuzum does and can comment, regardless, I don't think a hardcoded LP url is the likely home of the standard bits :-)

So, as guidance: Please *do* use the standard CSS or other assets from standard locations (this LP one is not the standard, I'm sure), and please *don't* be too concerned about hosting an Ubuntu theme, it can be GPL and hosted anywhere, and it will still require some trademark compliance / permission, but that's normal and OK and anyone who would want to use the theme knows how to do that.

Matthew Nuzum (newz) wrote :

Thanks for clarifying that Mark. We do have a CDN set up and deployed, it's being used very minimally at the moment because it was put on the back burner once the font stuff went live. We need to work out a couple policies on how to use this. I'll talk to my team and the web-team to ensure this gets re-prioritized. The url for the CDN is http://files.ubuntu.com/

In the mean-time, it sounds like the traditional method of keeping the trademarked assets with the theme will work. If the theme is more generally useful without the trademarked assets consider the sub-theme approach. The sub-theme with the trademarks would likely be quite small.

I've created a bug #798248 which is to add documentation on how to use and contribute to this. It's on my team's backlog at the moment but it will be re-prioritized.

If you have questions, either about the sub-theme implementation details or about using the CDN to host resources, ping me, newz2000 or mhall119 in #ubuntu-website on freenode or e-mail the web-presence team mailing list, details at https://wiki.ubuntu.com/Website

Chris Johnston (cjohnston) wrote :

Correct me if I am wrong, but that would mean this would still need to be fixed?

Matthew East (mdke) wrote :

Yes, the upshot so far is that this is still a valid bug, until proven otherwise! I'm not 100% sure what bug tasks it should be open on, but I've reopened the bug on "Ubuntu Community Web Themes" as a starter.

Changed in ubuntu-community-webthemes:
status: Fix Committed → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints