Alarm time is wrongly displayed, after re enable disabled alarm

Bug #1530127 reported by Bartosz Kosiorek on 2015-12-30
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Alan Pope 🍺🐧🐱 πŸ¦„
Ubuntu Clock App
High
Unassigned

Bug Description

Alarm time is wrongly displayed, after re enable disabled alarm

Steps to reproduce:
1. Create several alarms
2. Set up OneTime alarm, which will ring after 2 minutes
2. Wait for alarm ringing without closing alarm list
3. Re enable alarm.

Expected result:
Alarm should be moved at the bottom of the alarm list.
The hour of alarm should be correctly set

Actual result:
Alarm is moved at the bottom of the alarm list.
Unfortunately the hour of current and previous alarm is not correctly set.

Workaround:
Close alarm list and open it again by swiping bottom edge.

Changed in ubuntu-clock-app:
milestone: 3.7 → 3.8
Anupam (anupam207) wrote :

Here's my alarm list, all are deactivated now. I'm going to activate the second one only (10:22 AM).

Anupam (anupam207) wrote :

After activating the second alarm, we find something's not right. The active one should have gone to the bottom of the list and 12:11 PM one should have been place fourth. But the time and toggle switch display is erroneous.

Anupam (anupam207) wrote :

Now I try to edit the 4th entry (displaying as 10:22 AM with toggle switch on), but the edit menu opens for the 12:11 PM one. Thus the problem is with the display of alarm time only, alarms are getting repositioned as expected after activating one of them.

Anupam (anupam207) wrote :

Normality is restored after closing and reopening the alarm list by swiping the bottom edge.

Changed in canonical-devices-system-image:
assignee: nobody → Alan Pope ξƒΏ (popey)
status: New → Confirmed
Changed in ubuntu-clock-app:
status: New → Triaged
importance: Medium → High
Bartosz Kosiorek (gang65) wrote :

This bug is not in Clock but rather in Ubuntu.Components.
First I would try to reproduce it with some minimum project.

Akos Mate (mateakos1) wrote :

This also happens to me every day.
It's not needed to keep the alarm list open, it's only needed to wait until the alarm rings.
When re-enabling the alarm in the middle, the remaining time is displayed at the bottom, but set time is not reordered. If I then tap again on the middle one, the UI gets even more messed up displaying the same time twice, but with different remaining times.

Akos Mate (mateakos1) wrote :

The displayed alarms and remaining times get corrected, if I close and reopen the alarm list, or if I swipe a little bit from the right like if I want to switch tasks, and select the same again or swipe back without actually changing to another task.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers