Stopwatch is not working correctly after change timezone during runtime

Bug #1493358 reported by Bartosz Kosiorek on 2015-09-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Unassigned
Ubuntu Clock App
Critical
Bartosz Kosiorek

Bug Description

Stopwatch is not working correctly after change timezone during runtime.

Steps to reproduce:
1. Run clock
2. Start stopwatch
3. Get Clock into background
4. Change timezone
5. Switch to stopwatch

Currently:
- Stopwatch is showing wrong time

Expected:
- Stopwatch should show correct time

Related branches

Changed in ubuntu-clock-app:
status: Triaged → In Progress
assignee: nobody → Bartosz Kosiorek (gang65)
Changed in ubuntu-clock-app:
milestone: none → 3.6
Victor Thompson (vthompson) wrote :

Wasn't this fixed under lp:1491024? Why was this not situation not tested under that fix?

Victor Thompson (vthompson) wrote :

Sorry, "Why was this situation not tested under that fix?"

Bartosz Kosiorek (gang65) wrote :

Hi Victor.

The solution from:
https://bugs.launchpad.net/ubuntu-clock-app/+bug/1491024
is working only when you close the app and change the timezone:
Testcase:
1. Run clock
2. Start stopwatch
3. Close clock app
4. Change timezone
5. Start stopwatch

Current implementation is fixing also changing timezone during runtime. You don't need to close app to change timezone (for stopwatch). With this branch also performance was improved.
Testcase:
1. Run clock
2. Start stopwatch
3. Get Clock into background
4. Change timezone
5. Start stopwatch

Currently I'm working also to fix runitme, timezone change issues also for clock and alarms. You could easily reproduce this by not closing Clock and change timezone.

Please test this branch very carefully, as I changed stopwatch engine, and we don't have autopilot tests (baloons is working on that)

description: updated
Nekhelesh Ramananthan (nik90) wrote :

@Victor, We did notice this issue when fixing bug 1491024, however we realized that the javascript Date() method is at fault and cannot handle timezone changes properly during runtime. Since this issue of changing timezone during runtime seems to be affecting pretty much all core functionality of the clock app like alarm, stopwatch and clock, we decided to migrate to QDateTime in subsequent MPs to ensure we don't introduce any regressions.

The transition to QDateTime is going to be tricky since our Autopilot Suite is down at the moment and we're introducing a change that should be handled carefully.

Fix committed into lp:ubuntu-clock-app at revision None, scheduled for release in ubuntu-clock-app, milestone 3.6

Changed in ubuntu-clock-app:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → Critical
milestone: none → ww46-2015
Changed in ubuntu-clock-app:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers