Startup animation (scroll up whole clock), is causing hiccups in Stopwatch.

Bug #1492502 reported by Bartosz Kosiorek on 2015-09-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Clock App
Medium
Unassigned

Bug Description

During Profiling I notice that stratup animation (scroll up whole clock), is causing hiccups in Stopwatch.

Steps to reproduce:
1. Start StopWatch.
2. Clock Clock
3. Start Clock app

Currently:
- Stopwatch is appering, and animation is running. Unfortunately it is not counting regularly and it stops for a moment. It is a bad user experience. When animation is complete the stopwatch is caunting ok

Expected:
- Stopwatch is caunting without hiccups.

More details in attached screenshot of profiler.

Bartosz Kosiorek (gang65) wrote :
Changed in ubuntu-clock-app:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 3.6
Nekhelesh Ramananthan (nik90) wrote :

I suspect that the lag could be due to two reasons,
1. The startup animation itself
2. The loading of the alarm model

Since we are in the stopwatch page, we could avoid showing the startup animation and load the alarm model only when the user goes to the clock page. That should fix this issue.

Changed in ubuntu-clock-app:
status: Confirmed → Triaged
Changed in ubuntu-clock-app:
milestone: 3.6 → 3.7
Nekhelesh Ramananthan (nik90) wrote :

Is this issue still reproducible? I believe Florian's work on improving the startup animation should have fixed this. Please confirm. Marking incomplete for now.

Changed in ubuntu-clock-app:
status: Triaged → Incomplete
milestone: 3.7 → 3.8
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers