Cannot add cities containing apostrophe due to u1db database error

Bug #1473074 reported by Gabriele on 2015-07-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Unassigned
Ubuntu Clock App
High
Bartosz Kosiorek

Bug Description

Steps to reproduce bug:
1. Change phone language to Italian
2. Try adding cities which contain apostrophe like New York, United States of America which has a apostrophe in Italian.
3. Fails to add city

----- original description -----

Hello , I tried to add and remove a number of cities ( for testing ) and I realized that the city of New York is not inserted .

I don't know why . The other cities that I have not tried this problem .

Use a Acquaris E4.5 Edition Ubuntu 4.15 R.23

Related branches

summary: - no way ti add new york time
+ no way to add time of NY

Hi Gabriele, thanks for filing this issue. You should be able to find NYC by searching for its proper name "New York" when you select "Add City". Let us know if you have further issues. Thanks!

Changed in ubuntu-clock-app:
status: New → Invalid
Gabriele (gabrielemartelli) wrote :

Hello. Maybe I have not explained well. I know perfectly how to select and add one or more cities. I specified that NYC is the only city that I did not install it even after having made choice and tap on

Gabriele

Changed in ubuntu-clock-app:
status: Invalid → New
Nekhelesh Ramananthan (nik90) wrote :

Hi Gabriele, thanks for taking the time to report the bug. Can you provide some with some additional info to help debug this issue pls?

1. Can you attach the clock app logs. Easiest way is to install the app "LogViewer" from the store, run the clock app and try reproducing the bug and then open logviewer, navigate to the clock app logs, and then attach that here.

2. Do you search for "New York" and then try adding it? Or do you use just scroll down the list and choose "new york". When you search, it goes online to retrieve search results, and could be fault there. Just speculations at the moment.

3. If we are still unable to debug the issue, then please attach the entire .local/share/com.ubuntu.clock folder that we can use to test against your local database to see if something is wrong there.

Gabriele (gabrielemartelli) wrote :

Hi Nekhelesh,
I add to Pastebin ubuntu clock app logs

You can see : http://paste.ubuntu.com/11895403/

The problem isn't just for NCY but also for many other cities. I noticied only now.

Gabriele

Nekhelesh Ramananthan (nik90) wrote :

Thanks Gabriele, the log is quite helpful. I notice the following statement,

qml: [LOG]: Adding city to U1db Database
u1db: Invalid docID New%20York_Stati%20Uniti%20d'America

Invalid docID rings bells. Bartosz can you take a look pls.

Changed in ubuntu-clock-app:
status: New → Confirmed
importance: Undecided → High
milestone: none → 3.4
Gabriele (gabrielemartelli) wrote :

Yes, I saw it too.
I did further tests and other cities have the same problem (also the first: Abidjan).

g

Gabriele (gabrielemartelli) wrote :

I understand the problem. In the Italian translation the nations that have the apostrophe in the name, are not working. In fact the problem is happening on all cities of the United States (in Italian "Stati Uniti d'America") and those in the Ivory Coast (in Italian Costa d'Avorio).

g

Changed in ubuntu-clock-app:
milestone: 3.4 → 3.5
Changed in ubuntu-clock-app:
status: Confirmed → In Progress
assignee: nobody → Bartosz Kosiorek (gang65)

Fix committed into lp:ubuntu-clock-app at revision 336, scheduled for release in ubuntu-clock-app, milestone 3.5

Changed in ubuntu-clock-app:
status: In Progress → Fix Committed
description: updated
summary: - no way to add time of NY
+ Cannot add cities containing apostrophe due to u1db database error
Changed in ubuntu-clock-app:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers