[Vivid][Regression]Cannot change alarm switch status (enable/disable alarms)

Bug #1422693 reported by Marcel Hörz on 2015-02-17
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Zoltan Balogh
Ubuntu Clock App
High
Zsombor Egri

Bug Description

ubuntu 15.04 (all releases) on mako
App-Version: 3.3.192

1st:
What I expected:
When I switch an alert off, it should be off until I turn it on.

What happens instead:
When I switch an alert off and wait a bit (5-10 sec), then goes the switch on.

2nd:
What I expected:
When I change an alert (alert-time or days-of-week, when it shall alert) and go back, it should save then changes.

What happens instead:
The change wasn't saved. So the time/the days, when/on which the alert rings, is the old one.

Related branches

summary: - Cannot change alerts
+ [Vivid][Regression]Cannot change alerts
Changed in ubuntu-clock-app:
status: New → Confirmed
importance: Undecided → High
summary: - [Vivid][Regression]Cannot change alerts
+ [Vivid][Regression]Cannot change alarm switch status (enable/disable
+ alarms)
Nekhelesh Ramananthan (nik90) wrote :

@Zsombor and Victor, This bug was indeed caused by the same regression in bug #1401883. On installing the latest SDK toolkit staging 1424 rev on Nexus 4, I am able to enable/disable alarms successfully. Thnx Zsombor for the fix. As such I am marking this bug fix committed.

On a side note, I have also noticed that the clock app now crashes often when pressing on the "Add new alarm" button. But I will investigate more on that and create a new bug to track that issue.

tags: added: alarm qa-promotion touch
removed: alert clock not save
Changed in ubuntu-clock-app:
status: Confirmed → Invalid
importance: High → Undecided
Marcel Hörz (marzel) wrote :

Nothing happens in the last two updates.

What work:
- Changing repeat-options of an alert.

What doesn't work:
- Switching on/off alert
- Changing time of alert

Device: malo (NEXUS 4)
System: Ubuntu 15.04 r121

Nekhelesh Ramananthan (nik90) wrote :

@Marcel, indeed which is why the bug has been marked as "Fix Committed" and not "Fix released" :) ... It still needs to land on the daily devel images which should happen soon.

Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → ww13-2015
status: New → Fix Committed
assignee: nobody → Zoltan Balogh (bzoltan)
Zsombor Egri (zsombi) on 2015-03-24
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Changed in ubuntu-clock-app:
milestone: none → 3.4
importance: Undecided → High
status: Invalid → Fix Released
assignee: nobody → Zsombor Egri (zsombi)
no longer affects: ubuntu-clock-app/vivid-15.04
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers