[Sdk]Bottom edge can get stuck part way exposed

Bug #1415902 reported by Alan Pope 🍺🐧🐱 🦄 on 2015-01-29
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Clock App
Low
Unassigned
messaging-app (Ubuntu)
Undecided
Unassigned
ubuntu-ui-toolkit (Ubuntu)
Medium
Unassigned
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:-

1. Open contacts (or another app with bottom edge such as clock or messaging)
2. Swipe up from the bottom slowly with one finger.
3. When half way swiped up, use another finger to swipe in from the right

Observe the bottom edge panel is now stuck half way up

4. Go back to the app.

Note the bottom edge panel is still stuck half way up.

I would expect the bottom edge panel to disappear/cancel or completely rise up (depending on how far you pull it) at step 3 or 4.

Screenshots:-
http://people.canonical.com/~alan/screenshots/device-2015-01-29-130655.png
http://people.canonical.com/~alan/screenshots/device-2015-01-29-130713.png

Albert Astals Cid (aacid) wrote :

This seems more like it'd be a SDK bug to me (if those apps are using a common item to implement the bottom edge swipe)

W dniu 29.01.2015 o 14:44, Albert Astals Cid pisze:
> This seems more like it'd be a SDK bug to me (if those apps are using a
> common item to implement the bottom edge swipe)

Yeah, or in qtubuntu that should make sure that an interrupted touch is
cancelled.

It appears that these apps use a PageWithBottomEdge component which is not a UITK component. I think it comes from here: http://ubuntu-component-store.readthedocs.org/en/latest/_components/pagewithbottomedge.html

no longer affects: ubuntu-ui-toolkit
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Invalid
Tim Peeters (tpeeters) wrote :

on the other hand, when we introduce such a component in UITK we need to make sure that it does not have this bug.

Tim Peeters (tpeeters) on 2015-02-04
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Invalid → New
Zsombor Egri (zsombi) wrote :

Never the less we must check this behavior in Panel.

Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Tim Peeters (tpeeters)
status: New → Triaged
affects: messaging-app → messaging-app (Ubuntu)
Changed in ubuntu-clock-app:
status: New → Incomplete
summary: - Bottom edge can get stuck part way exposed
+ [Sdk]Bottom edge can get stuck part way exposed
Changed in ubuntu-clock-app:
importance: Undecided → Low
Tim Peeters (tpeeters) on 2016-03-11
Changed in ubuntu-ui-toolkit (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in messaging-app (Ubuntu):
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: New → Confirmed
Tim Peeters (tpeeters) on 2016-11-23
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: Tim Peeters (tpeeters) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers