[Clock][Geonames]Need to be able to search cities by their lat and long

Bug #1359206 reported by Nekhelesh Ramananthan on 2014-08-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Clock App
Medium
Unassigned
Ubuntu Geonames
Undecided
Alan Pope 🍺🐧🐱 πŸ¦„
Ubuntu Weather App
Undecided
Unassigned

Bug Description

For the Ubuntu Clock App on Ubuntu Touch, we want to enable location services where it will use GPS to acquire the user's latitude and longitude. Once that happens, the clock app should be able to query ubuntu-geonames with the lat and long and get the nearest city.

Currently search only supports via city name, I am hoping searching via lat, long should be possible and require much infrastructure changes.

Something like, geoname-lookup.ubuntu.com/?lat=52.3&long=4.3&release=utopic

Related branches

description: updated
summary: - Need ability to search cities by their lat and long
+ Need to be able to search cities by their lat and long
Changed in ubuntu-geonames:
status: New → Confirmed
assignee: nobody → Alan Pope γ‹› (popey)
summary: - Need to be able to search cities by their lat and long
+ [Geonames] Need to be able to search cities by their lat and long
Changed in ubuntu-clock-app:
milestone: none → rtm
importance: Undecided → Medium
status: New → Triaged
Changed in ubuntu-clock-app:
milestone: rtm → ota-1
Changed in ubuntu-clock-app:
milestone: 3.3 → 3.4

Needs UX design for Clock app

summary: - [Geonames] Need to be able to search cities by their lat and long
+ [Clock][Geonames][UX] Need to be able to search cities by their lat and
+ long
Changed in ubuntu-clock-app:
status: Triaged → Incomplete
Bartosz Kosiorek (gang65) wrote :

I found following UX design for that issue (select city from a map):
https://docs.google.com/presentation/d/1JvDyhsW17d1-Mz8OY1YMBKwfRI2z9qgyRjbujEsxEMk/edit?pli=1#slide=id.g3420c61fa_059

Is it applicable in that case?

Victor Thompson (vthompson) wrote :

The app currently uses api.geonames.org to search by Lat and Long. So this bug is effectively invalid for the Clock app. Once Ubuntu Geonames has this feature then the Clock app can step up and use that API instead.

Changed in ubuntu-clock-app:
status: Incomplete → Invalid
Nekhelesh Ramananthan (nik90) wrote :

Well once Ubuntu Geonames provides this support, the clock app code will need to be adjusted to switch to it. So in that sense, the ubuntu-clock-app bug is valid and triaged in my opinion. I don't think it is invalid.

Changed in ubuntu-clock-app:
status: Invalid → Triaged
Nekhelesh Ramananthan (nik90) wrote :

@bartosz, this bug is concerning geolocation where clock app determines the user's location automatically using the latitude and longitude returned by Qt Location. It doesn't have anything to do with the design slide you are referring to in comment #3. That design slide is for an entirely new feature which was scrapped before RTM due to lack of time.

summary: - [Clock][Geonames][UX] Need to be able to search cities by their lat and
- long
+ [Clock][Geonames]Need to be able to search cities by their lat and long
Bartosz Kosiorek (gang65) wrote :

Do we need UX design for that issue?

I'm new in clock's app world, and i am confused with amount of features and bugs to implement, because most of them are blocked by externals (eg. Ux design).

To make things simpler I would like to set features and bug which is ready to implementation as Triaged.
If item has external dependency, I would like to set it as Incomplete. So we could still track progress of the issue /feature.

What do you think about that?

It will simplify and organize these items a little big (at least for me ).

Bartosz Kosiorek (gang65) wrote :

There are some code proposal. Maybe we should synchronize with trunk and review it ?

Nekhelesh Ramananthan (nik90) wrote :

Sure feel free to mark it incomplete when a bug is dependent on external factors like Ubuntu-UX or any other package. As for the merge proposal linked to this bug report, that is against ubuntu-geonames and not against clock app. We will need to wait for that to be merged before any action can be taken in the clock app.

Changed in ubuntu-clock-app:
status: Triaged → Incomplete
no longer affects: ubuntu-ux
Changed in ubuntu-weather-app:
status: New → Incomplete
Changed in ubuntu-clock-app:
milestone: 3.4 → 3.5
Changed in ubuntu-clock-app:
milestone: 3.5 → 3.6
Changed in ubuntu-clock-app:
milestone: 3.6 → 3.x.backlog
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers