Recurring alarm can't be set for sunday

Bug #1285958 reported by Nicholas Skaggs on 2014-02-28
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Clock App
High
Renato Araujo Oliveira Filho
Ubuntu UI Toolkit
Fix Released
High
Zsombor Egri
qtorganizer5-eds (Ubuntu)
High
Renato Araujo Oliveira Filho
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Vivid
Undecided
Unassigned

Bug Description

Recurring alarm can be set on Sunday. It works on all other days properly.

Steps to reproduce the bug:
1. Open the alarms tab
2. Enable the repeat switch to set the alarm type as recurring
3. Choose Sunday and also a couple of other days in the add alarms day dialog
4. Save alarm

What happens:
In the alarm page, it does not not show Sunday. It shows every other day you may have chosen in the add alarms day dialog.

What should happen:
The alarm page lists all the chosen days of the recurring alarm.

Facts:
Currently the clock app is at rev 362. I branches the clock app at rev 243 to check if this was caused by any recent commits in the clock app. However this bug was reproducible even at rev 243. I also repeated the steps in the sample alarm app provided by the SDK at http://bazaar.launchpad.net/~ubuntu-sdk-team/ubuntu-ui-toolkit/trunk/files/head:/tests/resources/alarm/ and I can see reproduce the alarm indicating that either the SDK or EDS broke things.

Update: On further testing, it has been found that EDS (qtorganizer5-eds) is causing this bug.

Related branches

summary: - Reccuring Alarm drops the last day
+ Reccuring Alarm can't be set for sunday
description: updated
Leo Arias (elopio) on 2014-02-28
tags: added: clock elopio qa-new
Changed in ubuntu-clock-app:
status: New → Confirmed

elopio, did you just add your name as a tag :P

tags: added: alarms dogfooding-blocker
Changed in ubuntu-clock-app:
importance: Undecided → High
milestone: none → 1.8
Changed in ubuntu-clock-app:
assignee: nobody → Zsombor Egri (zsombi)
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
description: updated
Leo Arias (elopio) wrote :

I did :)
That's how I track the bugs that are important for me. And qa-new is my team, so that's how I tell the others that there's something important to track.

affects: ubuntu-ui-toolkit → qtorganizer5-eds (Ubuntu)
Changed in ubuntu-clock-app:
assignee: Zsombor Egri (zsombi) → Renato Araujo Oliveira Filho (renatofilho)
description: updated
Nicholas Skaggs (nskaggs) wrote :

@boiko, are you able to have a look at this issue? I'm not sure renato is around to fix.

Bill Filler (bfiller) on 2014-03-04
Changed in qtorganizer5-eds (Ubuntu):
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
importance: Undecided → High

Me and zsombi are working to fix this bug on the sdk (alarm API).

Zsombor Egri (zsombi) on 2014-03-06
Changed in ubuntu-ui-toolkit:
assignee: nobody → Zsombor Egri (zsombi)
Zsombor Egri (zsombi) on 2014-03-06
Changed in ubuntu-ui-toolkit:
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtorganizer5-eds - 0.1.1+14.04.20140307-0ubuntu1

---------------
qtorganizer5-eds (0.1.1+14.04.20140307-0ubuntu1) trusty; urgency=low

  [ Renato Araujo Oliveira Filho ]
  * Fixed parse from icalrecurrencetype to
    QtOrganizer::QOrganizerRecurrenceRule for weekly recurrence. (LP:
    #1285958)
 -- Ubuntu daily release <email address hidden> Fri, 07 Mar 2014 04:49:19 +0000

Changed in qtorganizer5-eds (Ubuntu):
status: Confirmed → Fix Released
summary: - Reccuring Alarm can't be set for sunday
+ Recurring alarm can't be set for sunday
Changed in ubuntu-clock-app:
status: Confirmed → Invalid
Nekhelesh Ramananthan (nik90) wrote :

Marked bug as invalid for the clock app since the bug lies in the toolkit and EDS.

Changed in ubuntu-ui-toolkit:
status: New → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:~ubuntu-sdk-team/ubuntu-ui-toolkit/staging at revision 1004, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+14.10.20140502.6-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+14.10.20140502.6-0ubuntu1) utopic; urgency=low

  [ Tarmac ]
  * [ Zoltán Balogh]   * Skip tests only for powerpc   [ Christian Dywan
    ]   * Use locale format specifier in textfield_numbers. (LP:
    #1311907, #1283236, #1285958, #1124071, #1256424, #1276172,
    #1228042, #1183255, #1283212, #1168914, #1273187, #1276821,
    #1308086, #1288937, #1292601)

  [ Zoltán Balogh ]
  * [ Zoltán Balogh]   * Skip tests only for powerpc   [ Christian Dywan
    ]   * Use locale format specifier in textfield_numbers. (LP:
    #1311907, #1283236, #1285958, #1124071, #1256424, #1276172,
    #1228042, #1183255, #1283212, #1168914, #1273187, #1276821,
    #1308086, #1288937, #1292601)

  [ tpeeters ]
  * [ Zoltán Balogh]   * Skip tests only for powerpc   [ Christian Dywan
    ]   * Use locale format specifier in textfield_numbers. (LP:
    #1311907, #1283236, #1285958, #1124071, #1256424, #1276172,
    #1228042, #1183255, #1283212, #1168914, #1273187, #1276821,
    #1308086, #1288937, #1292601)
 -- Ubuntu daily release <email address hidden> Fri, 02 May 2014 16:31:41 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers