Unable to edit single type alarms and update them

Bug #1283212 reported by Pat McGowan on 2014-02-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Clock App
High
Unassigned
Ubuntu UI Toolkit
Fix Released
High
Zsombor Egri
qtorganizer5-eds (Ubuntu)
High
Renato Araujo Oliveira Filho
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Vivid
Undecided
Unassigned

Bug Description

Mako running build 200, 205

Steps to reproduce:
1. Create a single-type alarm (which triggers only once)
2. Select the alarm to go into edit mode
3. Change the time of the alarm (or the day)
4. Hit save

What happens:
The alarm is not updated with the new time set by the user. The new alarm time is also not shown in the indicator. The list shows the alarm with the original time setting, and entering that alarm to edit shows it did not update.

What happens:
The alarm is updated with the new time and is also reflected in the indicator date time.

This bug does not affect recurring alarms. Recurring can be edited and the clock app shows the updated time. However the indicator does not show the updated recurring alarm time. This is reported in bug #1283859

Related branches

Changed in ubuntu-clock-app:
status: New → Confirmed
importance: Undecided → High
milestone: none → 1.8
summary: - Edit an existing alarm and the new settings are not saved
+ Unable to edit single type alarms
summary: - Unable to edit single type alarms
+ Unable to edit single type alarms and update them
description: updated
description: updated
tags: added: alarms dogfooding-blocker
affects: qtorganizer5-eds → qtorganizer5-eds (Ubuntu)
Changed in qtorganizer5-eds (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Zsombor Egri (zsombi) on 2014-03-31
Changed in ubuntu-ui-toolkit:
importance: Undecided → High
assignee: nobody → Zsombor Egri (zsombi)
Zsombor Egri (zsombi) on 2014-03-31
Changed in ubuntu-ui-toolkit:
status: New → In Progress
Changed in ubuntu-clock-app:
status: Confirmed → Invalid
Nekhelesh Ramananthan (nik90) wrote :

Marked bug as invalid for the clock app since the bug lies in the toolkit and EDS.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:~ubuntu-sdk-team/ubuntu-ui-toolkit/staging at revision 1004, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Changed in qtorganizer5-eds (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+14.10.20140502.6-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+14.10.20140502.6-0ubuntu1) utopic; urgency=low

  [ Tarmac ]
  * [ Zoltán Balogh]   * Skip tests only for powerpc   [ Christian Dywan
    ]   * Use locale format specifier in textfield_numbers. (LP:
    #1311907, #1283236, #1285958, #1124071, #1256424, #1276172,
    #1228042, #1183255, #1283212, #1168914, #1273187, #1276821,
    #1308086, #1288937, #1292601)

  [ Zoltán Balogh ]
  * [ Zoltán Balogh]   * Skip tests only for powerpc   [ Christian Dywan
    ]   * Use locale format specifier in textfield_numbers. (LP:
    #1311907, #1283236, #1285958, #1124071, #1256424, #1276172,
    #1228042, #1183255, #1283212, #1168914, #1273187, #1276821,
    #1308086, #1288937, #1292601)

  [ tpeeters ]
  * [ Zoltán Balogh]   * Skip tests only for powerpc   [ Christian Dywan
    ]   * Use locale format specifier in textfield_numbers. (LP:
    #1311907, #1283236, #1285958, #1124071, #1256424, #1276172,
    #1228042, #1183255, #1283212, #1168914, #1273187, #1276821,
    #1308086, #1288937, #1292601)
 -- Ubuntu daily release <email address hidden> Fri, 02 May 2014 16:31:41 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
Selene ToyKeeper (toykeeper) wrote :

This works for me, in image utopic 18.

Changed in ubuntu-clock-app:
milestone: 1.8 → alarm-blockers
Changed in ubuntu-clock-app:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers