Selecting the same option again in an OptionSelector results in that option being hidden

Bug #1240629 reported by Nekhelesh Ramananthan on 2013-10-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Clock App
Medium
Unassigned
Ubuntu UI Toolkit
Fix Released
High
Nicolas d'Offay

Bug Description

Steps to reproduce:
1. Navigate to the Alarms Tab and press Add Alarm.
2. In the "Occurs" optionselector, select the same day shown again.

What happens:
The day disappears

What should happen:
The day appears as the selected option

----- Way to reproduce this in the SDK (general code) ----------

Steps to reproduce:
1. Open the SDK gallery project in qtcreator via Tools -> Ubuntu Touch -> Ubuntu Touch Showcase Gallery.
2. Open OptionSelectors.qml file
3. Change the first option selector code as shown below,

OptionSelector {
               objectName: "optionselector_collapsed"
               text: i18n.tr("Collapsed")
               selectedIndex: 1
                model: [i18n.tr("Value 1"),
                        i18n.tr("Value 2"),
                        i18n.tr("Value 3"),
                        i18n.tr("Value 4")]
            }

4. Now run the gallery, and choose the index: 1 again. Notice that it disappears.

The only additional code which was added above was selectedIndex: 1 which results in this bug appearing.

---- Additonal Information ---
Ubuntu: Saucy Salamander (with SDK ppa enabled)
UI Toolkit version: rev 801
This bug occurred even before https://bugs.launchpad.net/ubuntu-ui-toolkit/+bug/1231936 was reported.

Related branches

Changed in ubuntu-clock-app:
status: Triaged → In Progress
Changed in ubuntu-clock-app:
assignee: nobody → Nekhelesh Ramananthan (nik90)
Nekhelesh Ramananthan (nik90) wrote :

Turns out this is an upstream bug since I can reproduce this in the UITK gallery code as well.

summary: - Selecting the same option while setting the alarm day results in that
+ Selecting the same option again in an OptionSelector results in that
option being hidden
description: updated
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
Changed in ubuntu-clock-app:
status: In Progress → Confirmed
assignee: Nekhelesh Ramananthan (nik90) → nobody
description: updated
description: updated
Changed in ubuntu-ui-toolkit:
assignee: nobody → Nicolas d'Offay (nicolas-doffay)
Changed in ubuntu-clock-app:
milestone: backlog → 14.04-month-1
Changed in ubuntu-ui-toolkit:
status: Confirmed → Fix Committed
Nekhelesh Ramananthan (nik90) wrote :

@Nicolas d'Offay, can you list which UITK rev did this bug get fixed it? As of rev 801, I still face this bug using the steps produced above. I do not think this bug is fixed.

Changed in ubuntu-ui-toolkit:
status: Fix Committed → Confirmed
description: updated
Changed in ubuntu-ui-toolkit:
status: Confirmed → In Progress
Changed in ubuntu-ui-toolkit:
importance: Undecided → High

This should be fixed now. The selector refocuses on collapse as safety measure to prevent this.

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
Changed in ubuntu-clock-app:
status: Confirmed → Fix Committed
Changed in ubuntu-clock-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers